VCOM:VectorWorks:ISDK::TaggedDataSet

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Sets 'data' of type 'dataType' mapped to 'dataTag' into array created by GS_TaggedDataCreate. Sets the data in inOwner's aux list at <dataContainer, dataType, dataTag>

virtual bool TaggedDataSet(
MCObjectHandle inOwnerObj,
OSType dataContainer,
int dataType,
int dataTag,
int dataIndex,
const void* data)

Parameters

MCObjectHandle inOwnerObj No information available.
OSType dataContainer No information available.
int dataType No information available.
int dataTag No information available.
int dataIndex No information available.
constvoid* data No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009