VCOM:VectorWorks:ISDK::SetTextCustomStyle

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

This function sets the custom style for the indicated range of characters in the passed in text object. If the passed in value is 32, the characters are displayed as a superscript. If the value is 64, the characters are displayed as a subscript. Otherwise the characters are displayed normally.

virtual voidVCOM_CALLTYPE SetTextCustomStyle(
MCObjectHandle textBlock,
long firstChar,
long numChars,
unsigned char customStyle) = 0;

Parameters

textBlock MCObjectHandle The text object for which the custom style is being changed.
firstChar long The index of the first character to change.
numChars long The number of characters to change.
customStyle unsigned char The desired custom style value: 0 = normal, 32 = superscript, 64 = subscript.

Version

Availability: from Vectorworks 2010