VCOM:VectorWorks:ISDK::SetComponentManualEdgeOffset

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Sets the manual edge offset of a component in an object.

virtual Boolean VCOM_CALLTYPE SetComponentManualEdgeOffset(
MCObjectHandle object,
short componentIndex,
WorldCoord manualEdgeOffset) = 0;

Parameters

object MCObjectHandle The object. Can be a slab, Slab Style, or the Slab Preferences.
componentIndex short The index of the component.
manualEdgeOffset WorldCoord The manual edge offset.

Version

Availability: from Vectorworks 2010