VCOM:VectorWorks:ISDK::RunLayoutDialog

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Run the platform specific dialog. Returns the id of the button used to close the dialog. (1 = defualt button, 2 = cancel button)


handEvent is a pointer to a function with the following parameters (long dlogID, long& itemHit, void* data, void* env)

itemHit is the itemID of the control that recieved an event, data contains information specific to that control, and env is a pointer that can be use to pass in additional data. The documentation for the control creation routines contains an Event handling section which describes how individual controls use itemHit and data fields.


In addition to the control events there are two special events:

For dialog set up itemHit = kSetupMessage. This event occurs after the dialog is created but before it is displayed. Use this event to initialize control values.

For dialog set down itemHit = kSetdownMessage. This event can be used for storing control data.


To error check dialog data add a case for the default button (itemHit = 1) and check the data, to prevent the dialog from closing set itemHit = 0.

virtual long RunLayoutDialog(
long dialogID,
GS_EventHandlerProcPtr handleEvent = NULL,
void* env = NULL)

Parameters

long dialogID No information available.
GS_EventHandlerProcPtr handleEvent=NULL No information available.
void* env=NULL No information available.

Return Value

On error returns: 0

Version

Availability: from Vectorworks 2009