VCOM:VectorWorks:ISDK::NurbsSetKnot

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

sets the index2 knot of the index1 piece of the given nurbs curve or the index2 knot of U knot(index =1) or V knot(index=0) of the given nurbs surface

virtual bool NurbsSetKnot(
MCObjectHandle nHandle,
long index1,
long index2,
double knot)

Parameters

MCObjectHandle nHandle No information available.
long index1 No information available.
long index2 No information available.
double knot No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009