VCOM:VectorWorks:ISDK::Interactive2DDraw

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Interactive2DDraw is called when drawing interactively. To use it, you must define all drawing to be done as a function of the worldspace start and endpoints of a drag operation.

the prototype for Interactive2DDraw is :


Interactive2DDraw(CallBackPtr cbp, short options, short shiftConsMode, I2DDrawProcPtr drawProc, void *env);


where drawProc is the function that does the drawing. Interactive2DDraw takes care of

the draw and undraw for you as well as respond to any constraints set with shiftConsMode

or the constaint set in the TDef.

virtual void Interactive2DDraw(
short options,
short shiftConsMode,
GS_I2DDrawProcPtr drawProc,
void *env)

Parameters

short options No information available.
short shiftConsMode No information available.
GS_I2DDrawProcPtr drawProc No information available.
void *env No information available.

Version

Availability: from Vectorworks 2009