VCOM:VectorWorks:ISDK::GetTextStyleRef

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Get the Text Style RefID for a text-bearing object.

virtual InternalIndexVCOM_CALLTYPE GetTextStyleRef(
MCObjectHandle object) = 0;
virtual InternalIndexVCOM_CALLTYPE GetTextStyleRef(
MCObjectHandle object,
long charNum) = 0;

Parameters

object MCObjectHandle The text-bearing object to query.
charNum long The index of the character to query in the text block.

Return Value

The internal index of the text style, or 0 if the text is unstyled.

Remarks

Both are unimplemented.

Version

Availability: from Vectorworks 2011

See Also

VCOM:VectorWorks:ISDK::SetTextStyleRef

[[VCOM:VectorWorks:ISDK::SetTextStyleRef]]