VCOM:VectorWorks:ISDK::GetStoryBoundChoiceStrings

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace

Member of VCOM:VectorWorks:ISDK

Gets the choice strings for a story bound control.

virtual voidVCOM_CALLTYPE GetStoryBoundChoiceStrings(
MCObjectHandle story,
bool topBound,
TXStringArray& strings) = 0;

Parameters

story MCObjectHandle The story relative to which to get the strings. Nil gets a generic list of strings.
topBound bool Whether to get the strings for a top bound or a bottom bound.
strings TXStringArray& Returns the strings.

Version

Availability: from Vectorworks 2012