VCOM:VectorWorks:ISDK::GetSkylight

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Get skylight attributes.


skylightID: Identifier for this skylight. Value is returned by CreateSkylight().

edgeIndex: Index to which roof face this skylight is placed. Value is one based.

cornerOffset: Top/Plan distance from vertex referenced by 'edgeIndex' to center of skylight. This distance is parallel to the roof outline as defined by: vertex[edgeindex+1] - vertex[edgeIndex].

perpOffset: Top/Plan distance from roof outline to center of skylight.

symName: Skylight symbol to place in the roof.

virtual bool GetSkylight(
MCObjectHandle object,
const short skylightID,
short& edgeIndex,
WorldCoord& cornerOffset,
WorldCoord& perpOffset,
InternalIndex& symName)

Parameters

MCObjectHandle object No information available.
constshort skylightID No information available.
short& edgeIndex No information available.
WorldCoord& cornerOffset No information available.
WorldCoord& perpOffset No information available.
InternalIndex& symName No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009