VCOM:VectorWorks:ISDK::GetObjectStoryBoundsAt

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace

Member of VCOM:VectorWorks:ISDK

Return the story bound ID of the specified story bound index. The index is between 0 and the result of GetObjectStoryBoundsCount - 1.

virtual TObjectBoundIDVCOM_CALLTYPE GetObjectStoryBoundsAt(
MCObjectHandle hObject,
size_t index) = 0;

Parameters

hObject MCObjectHandle The object.
index size_t Index of the story bound which ID will be returned. This index should be between 0 and the result of GetObjectStoryBoundsCount - 1.

Return Value

The story bound ID.

Version

Availability: from Vectorworks 2012