VCOM:VectorWorks:ISDK::CreateHatch

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Creates a hatch definition with the given name, appending a nubmer if the name already exists. The hatch has one level (line), which can be changed with GS_SetHatchLevel(0, ...). Additional levels can be created with GS_SetHatchLevel(n, ...) where n is one more than the existing number of levels (which you can get with GS_GetObjectVariable(...ovHatchNumLevels...)). See MiniCadCallBacks.h for other hatch object variable selectors.

virtual MCObjectHandle CreateHatch(
const InternalName inName,
CBbool inUsePageUnits,
CBbool inRotateInWalls,
CBbool inRotateInSymbols,
CBbool inTransparent,
ColorRef inFillColorIndex)

Parameters

constInternalName inName No information available.
CBbool inUsePageUnits No information available.
CBbool inRotateInWalls No information available.
CBbool inRotateInSymbols No information available.
CBbool inTransparent No information available.
ColorRef inFillColorIndex No information available.

Return Value

On error returns: nil

Version

Availability: from Vectorworks 2009