VCOM:VectorWorks:Filing:XMLErrors:XMLExceptionDomain

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing::XMLErrors

reports Schema validation problems;

namespace XMLExceptionDomain
{
  enum ECodes
  {
      NoError                            = 0		// 
    // warnings --------------------------------------------------------------------------------------------------------
    , Scan_CouldNotOpenSource_Warning    = 2		// Warning: The primary document entity could not be opened. Id={0}
    , GC_ExistingGrammar                 = 3		// Warning: No caching of grammar set, a grammar with same key found in the cache pool.
    // errors --------------------------------------------------------------------------------------------------------
    , Array_BadIndex                     = 6		// The index is beyond the array bounds 
    , Array_BadNewSize                   = 7		// The new size is less than the old one
    , AttrList_BadIndex                  = 8		// The index given was beyond the max attribute index
    , AttDef_BadAttType                  = 9		// The passed AttTypes value is not known
    , AttDef_BadDefAttType               = 10		// The passed DefAttTypes value is not known
    , Bitset_BadIndex                    = 11		// The bit index was beyond the set size
    , Bitset_NotEqualSize                = 12		// The bit sets are not of the same size
    , BufMgr_NoMoreBuffers               = 13		// The buffer manager cannot provide any more buffers
    , BufMgr_BufferNotInPool             = 14		// The passed buffer was not found in this manager's pool
    , CPtr_PointerIsZero                 = 15		// The pointer has not been set
    , CM_BinOpHadUnaryType               = 16		// The binary operation node had a unary node type
    , CM_MustBeMixedOrChildren           = 17		// The content type must be mixed or children
    , CM_NoPCDATAHere                    = 18		// PCDATA nodes are not valid here
    , CM_NotValidForSpecType             = 19		// The {0} operation is invalid for the spec type
    , CM_UnaryOpHadBinType               = 20		// The unary operation node had a binary node type
    , CM_UnknownCMType                   = 21		// Unknown content model type
    , CM_UnknownCMSpecType               = 22		// Unknown content spec type
    , CM_NoParentCSN                     = 23		// The parent element has no content spec node
    , CM_NotValidSpecTypeForNode         = 24		// The spec type is not valid for {0}
    , DTD_UnknownCreateReason            = 25		// The creation reason enum has an unknown value
    , ElemStack_EmptyStack               = 26		// The element stack is empty
    , ElemStack_BadIndex                 = 27		// The element stack index given was beyond the stack top
    , ElemStack_StackUnderflow           = 28		// The element stack was already empty when a pop request occurred
    , ElemStack_NoParentPushed           = 29		// A parent operation was requested, but only one element is on the stack
    , Enum_NoMoreElements                = 30		// The enumerator contains no more elements
    , File_CouldNotOpenFile              = 31		// Could not open file: {0}
    , File_CouldNotGetCurPos             = 32		// Could not query the current file position
    , File_CouldNotCloseFile             = 33		// Could not close the file
    , File_CouldNotSeekToEnd             = 34		// Could not seek to end of file
    , File_CouldNotSeekToPos             = 35		// Could not seek to required position in file
    , File_CouldNotDupHandle             = 36		// Could not duplicate the handle
    , File_CouldNotReadFromFile          = 37		// Could not read data from file
    , File_CouldNotWriteToFile           = 38		// Could not write data to file
    , File_CouldNotResetFile             = 39		// Could not reset file to beginning
    , File_CouldNotGetSize               = 40		// Could not ascertain the file size
    , File_CouldNotGetBasePathName       = 41		// Could not determine base pathname of the file
    , File_BasePathUnderflow             = 42		// The base path had too few levels to weave in relative part
    , Gen_ParseInProgress                = 43		// Parse may not be called while parsing
    , Gen_NoDTDValidator                 = 44		// A DOCTYPE was seen but the installed validator does not understand DTDs
    , Gen_CouldNotOpenDTD                = 45		// Could not open DTD file '{0}'
    , Gen_CouldNotOpenExtEntity          = 46		// Could not open external entity '{0}'
    , Gen_UnexpectedEOF                  = 47		// The end of input was not expected
    , HshTbl_ZeroModulus                 = 48		// The hash modulus cannot be zero
    , HshTbl_BadHashFromKey              = 49		// Hashing the key returned an invalid bad hash value
    , HshTbl_NoSuchKeyExists             = 50		// The key '{0}' could not be found in the hash table
    , Mutex_CouldNotCreate               = 51		// Could not create mutex
    , Mutex_CouldNotClose                = 52		// Could not close mutex
    , Mutex_CouldNotLock                 = 53		// Could not lock mutex
    , Mutex_CouldNotUnlock               = 54		// Could not unlock mutex
    , Mutex_CouldNotDestroy              = 55		// Could not destroy mutex
    , NetAcc_InternalError               = 56		// Internal Error on NetAccessor
    , NetAcc_LengthError                 = 57		// Error on NetAccessor. Cannot determine length of remote file
    , NetAcc_InitFailed                  = 58		// The NetAccessor could not be initialized.
    , NetAcc_TargetResolution            = 59		// The host/address '{0}' could not be resolved
    , NetAcc_CreateSocket                = 60		// Could not create the socket for URL '{0}'
    , NetAcc_ConnSocket                  = 61		// Could not connect to the socket for URL '{0}'
    , NetAcc_WriteSocket                 = 62		// Could not write to the socket for URL '{0}'
    , NetAcc_ReadSocket                  = 63		// Could not read from the socket for URL '{0}'
    , NetAcc_UnsupportedMethod           = 64		// The specified HTTP method is not supported by this NetAccessor.
    , Pool_ElemAlreadyExists             = 65		// The element {0} already exists
    , Pool_BadHashFromKey                = 66		// Hashing the key returned an invalid bad hash value
    , Pool_InvalidId                     = 67		// The passed id is not valid for this pool
    , Pool_ZeroModulus                   = 68		// The modulus value cannot be zero
    , RdrMgr_ReaderIdNotFound            = 69		// The indicated reader id was never found
    , Reader_BadAutoEncoding             = 70		// The auto encoding enum has an unknown value
    , Reader_CouldNotDecodeFirstLine     = 71		// Could not decode first line of entity: {0}
    , Reader_NelLsepinDecl               = 72		// XMLDecl or TextDecl can not have NEL or lsep: {0}
    , Reader_EOIInMultiSeq               = 73		// End of input was hit in the middle of a multibyte sequence
    , Reader_SrcOfsNotSupported          = 74		// The current transcoding service does not support source offset information
    , Reader_EncodingStrRequired         = 75		// EBCDIC files must provide an encoding= string
    , Scan_CouldNotOpenSource            = 76		// The primary document entity could not be opened. Id={0}
    , Scan_UnbalancedStartEnd            = 77		// Unbalanced start/end tags found, cannot continue
    , Scan_BadPScanToken                 = 78		// The call to scanNext() is illegal at this time
    , Stack_BadIndex                     = 79		// The index is past the top of stack
    , Stack_EmptyStack                   = 80		// The stack is empty, cannot access members
    , Str_ZeroSizedTargetBuf             = 81		// The target buffer cannot have a max size of zero
    , Str_UnknownRadix                   = 82		// The given radix is not supported. Use 2, 8, 10, or 16
    , Str_TargetBufTooSmall              = 83		// The target buffer is too small to accept the results
    , Str_StartIndexPastEnd              = 84		// The start index is past the end of the string
    , Str_ConvertOverflow                = 85		// The represented value overflowed the output binary result
    , Strm_StdErrWriteFailure            = 86		// Could not write to standard err
    , Strm_StdOutWriteFailure            = 87		// Could not write to standard out
    , Strm_ConWriteFailure               = 88		// Could not write to console
    , StrPool_IllegalId                  = 89		// String pool id was not legal
    , Trans_CouldNotCreateDefCvtr        = 90		// Could not create a default transcoder
    , Trans_InvalidSizeReq               = 91		// The maximum size to xlat is larger than the declared block size
    , Trans_Unrepresentable              = 92		// Unicode char 0x{0} is not representable in encoding {1}
    , Trans_NotValidForEncoding          = 93		// Character {0} is not valid for encoding {1}
    , Trans_BadBlockSize                 = 94		// The requested block size is not equal to the size set during construction
    , Trans_BadSrcSeq                    = 95		// An invalid multi-byte source text sequence was encountered
    , Trans_BadSrcCP                     = 96		// {0} is not a valid value for encoding {1}
    , Trans_BadTrailingSurrogate         = 97		// Leading surrogate was not followed by trailing
    , Trans_CantCreateCvtrFor            = 98		// Could not create a converter for encoding: {0}
    , URL_MalformedURL                   = 99		// The URL was not correctly formed
    , URL_UnsupportedProto               = 100		// The URL used an unsupported protocol
    , URL_UnsupportedProto1              = 101		// Unsupported URL protocol: '{0}'
    , URL_OnlyLocalHost                  = 102		// Only localhost is supported at this time
    , URL_NoProtocolPresent              = 103		// No protocol prefix present
    , URL_ExpectingTwoSlashes            = 104		// Expected // after protocol
    , URL_IncorrectEscapedCharRef        = 105		// % must be followed by two hex digits
    , URL_UnterminatedHostComponent      = 106		// Unterminated host component
    , URL_RelativeBaseURL                = 107		// The base part of the URL cannot be relative
    , URL_BaseUnderflow                  = 108		// The base part has too few levels to weave in relative part
    , URL_BadPortField                   = 109		// The port field must be a 16 bit decimal number
    , UTF8_FormatError                   = 110		// invalid byte {0} ({1}) of a {2}-byte sequence.
    , UTF8_Invalid_2BytesSeq             = 111		// invalid byte {0} of 2-byte sequence.
    , UTF8_Invalid_3BytesSeq             = 112		// invalid bytes {0}, {1} of 3-byte sequence.
    , UTF8_Irregular_3BytesSeq           = 113		// irregular bytes {0}, {1} of 3-byte sequence.
    , UTF8_Invalid_4BytesSeq             = 114		// invalid bytes {0}, {1} of 4-byte sequence.
    , UTF8_Exceede_BytesLimit            = 115		// Exceede bytes limits {0}, {1}-byte sequence.
    , Vector_BadIndex                    = 116		// The passed index is past the end of the vector
    , Val_InvalidElemId                  = 117		// The element id was invalid
    , Val_CantHaveIntSS                  = 118		// When reusing the Grammar, no internal subset is allowed
    , XMLRec_UnknownEncoding             = 119		// The passed recognizer encoding was not known
    , Parser_Parse1                      = 120		// Wrong character
    , Parser_Parse2                      = 121		// Invalid reference number
    , Parser_Next1                       = 122		// A character is required after \ 
    , Parser_Next2                       = 123		// '?' is not expected.  '(?:' or '(?=' or '(?!' or '(?<' or '(?#' or '(?>'?
    , Parser_Next3                       = 124		// '(?<=' or '(?<!' is expected
    , Parser_Next4                       = 125		// A comment is not terminated
    , Parser_Factor1                     = 126		// ')' is expected
    , Parser_Factor2                     = 127		// Unexpected end of the pattern in a modifier group
    , Parser_Factor3                     = 128		// ':' is expected
    , Parser_Factor4                     = 129		// Unexpected end of the pattern in a conditional group
    , Parser_Factor5                     = 130		// A back reference or an anchor or a lookahead or a lookbehind is expected in a conditional pattern
    , Parser_Factor6                     = 131		// There are more than three choices in a conditional group
    , Parser_Atom1                       = 132		// A character in U+0040-U+005f must follow \c
    , Parser_Atom2                       = 133		// A '{' is required before a category character.
    , Parser_Atom3                       = 134		// A property name is not closed by '}'
    , Parser_Atom4                       = 135		// Unexpected meta character
    , Parser_Atom5                       = 136		// Unknown property
    , Parser_CC1                         = 137		// A POSIX character class must be closed by ':]'
    , Parser_CC2                         = 138		// Unexpected end of the pattern in a character class
    , Parser_CC3                         = 139		// Unknown name for a POSIX character class
    , Parser_CC4                         = 140		// '-' is invalid here
    , Parser_CC5                         = 141		// ']' is expected
    , Parser_CC6                         = 142		// '{0}' is not a valid character range; use '\{1}' instead
    , Parser_Ope1                        = 143		// ='[' is expected
    , Parser_Ope2                        = 144		// ')' or '-[' or '+[' or '&[' is expected
    , Parser_Ope3                        = 145		// The range end code point '{0}' is less than the start code point '{1}'
    , Parser_Descape1                    = 146		// Invalid Unicode hex notation
    , Parser_Descape2                    = 147		// Overflow in a hex notation
    , Parser_Descape3                    = 148		// '\ x{' must be closed by '}'
    , Parser_Descape4                    = 149		// Invalid Unicode code point
    , Parser_Descape5                    = 150		// An anchor must not be here
    , Parser_Process1                    = 151		// This expression is not supported in the current option setting
    , Parser_Process2                    = 152		// '{0}' is not a valid character escape
    , Parser_Quantifier1                 = 153		// Invalid quantifier in '{0}'. A digit is expected
    , Parser_Quantifier2                 = 154		// Invalid quantifier in '{0}'. Invalid quantity or a '}' is missing
    , Parser_Quantifier3                 = 155		// Invalid quantifier in '{0}'. A digit or '}' is expexted
    , Parser_Quantifier4                 = 156		// Invalid quantifier in '{0}'. A min quantity must be <= a max quantity
    , Parser_Quantifier5                 = 157		// Invalid quantifier in '{0}'. A quantity value overflow
    , Gen_NoSchemaValidator              = 158		// A schema was seen but the installed validator does not understand schema
    , XUTIL_UnCopyableNodeType           = 159		// The {0} node type is not valid for copy
    , SubGrpComparator_NGR               = 160		// SubstitutionGroupComparator has no grammar resolver
    , FACET_Invalid_Len                  = 161		// Length Value '{0}' is invalid
    , FACET_Invalid_maxLen               = 162		// maxLength Value '{0}' is invalid
    , FACET_Invalid_minLen               = 163		// minLength Value '{0}' is invalid
    , FACET_NonNeg_Len                   = 164		// Length Value '{0}' must be a nonNegativeInteger
    , FACET_NonNeg_maxLen                = 165		// maxLength Value '{0}' must be a nonNegativeInteger
    , FACET_NonNeg_minLen                = 166		// minLength Value '{0}' must be a nonNegativeInteger
    , FACET_Len_maxLen                   = 167		// It is an error for both length and maxLength to be members of facets
    , FACET_Len_minLen                   = 168		// It is an error for both length and minLength to be members of facets
    , FACET_maxLen_minLen                = 169		// Value of maxLength '{0}' must be greater than the value of minLength '{1}'
    , FACET_bool_Pattern                 = 170		// Only constraining facet in boolean datatype is PATTERN
    , FACET_Invalid_Tag                  = 171		// Invalid Facet Tag '{0}'
    , FACET_Len_baseLen                  = 172		// Value of Length '{0}' must be equal to the base Length '{1}'
    , FACET_minLen_baseminLen            = 173		// Value of minLength '{0}' must be greater than or equal to the base minLength '{1}'
    , FACET_minLen_basemaxLen            = 174		// Value of minLength '{0}' must be less than or equal to the base maxLength '{1}'
    , FACET_maxLen_basemaxLen            = 175		// Value of maxLength '{0}' must be less than or equal to the base maxLength '{1}'
    , FACET_maxLen_baseminLen            = 176		// Value of maxLength '{0}' must be greater than or equal to the base minLength '{1}'
    , FACET_Len_baseMinLen               = 177		// Value of Length '{0}' must be greater than or equal to the base minLength '{1}'
    , FACET_Len_baseMaxLen               = 178		// Value of Length '{0}' must be less than or equal to the base maxLength '{1}'
    , FACET_minLen_baseLen               = 179		// Value of minLength '{0}' must be less than or equal to the base Length '{1}'
    , FACET_maxLen_baseLen               = 180		// Value of maxLength '{0}' must be greater than or equal to the base Length '{1}'
    , FACET_enum_base                    = 181		// Value of enumeration = '{0}' must be from the value space of base
    , FACET_Invalid_WS                   = 182		// Value of whitespace '{0}' must be one of 'preserve', 'replace', 'collapse'
    , FACET_WS_collapse                  = 183		// It is an error if whiteSpace = 'preserve' or 'replace' and base.whiteSpace = 'collapse'.
    , FACET_WS_replace                   = 184		// It is an error if whiteSpace = 'preserve' and base.whiteSpace = 'replace'.
    , FACET_Invalid_MaxIncl              = 185		// MaxInclusive '{0}' is invalid
    , FACET_Invalid_MaxExcl              = 186		// MaxExclusive '{0}' is invalid
    , FACET_Invalid_MinIncl              = 187		// MinInclusive '{0}' is invalid
    , FACET_Invalid_MinExcl              = 188		// MinExclusive '{0}' is invalid
    , FACET_Invalid_TotalDigit           = 189		// TotalDigit Value '{0}' is invalid
    , FACET_Invalid_FractDigit           = 190		// FractionDigit Value '{0}' is invalid
    , FACET_PosInt_TotalDigit            = 191		// TotalDigit Value '{0}' must be a PositiveInteger
    , FACET_NonNeg_FractDigit            = 192		// FractionDigit Value '{0}' must be a nonNegativeInteger
    , FACET_max_Incl_Excl                = 193		// It is an error for both maxInclusive and maxExclusive to be specified for the same datatype
    , FACET_min_Incl_Excl                = 194		// It is an error for both minInclusive and minExclusive to be specified for the same datatype
    , FACET_maxExcl_minExcl              = 195		// maxExclusive value '{0}' must be greater than minExclusive value '{1}'
    , FACET_maxExcl_minIncl              = 196		// maxExclusive value '{0}' must be greater than minInclusive value '{1}'
    , FACET_maxIncl_minExcl              = 197		// maxInclusive value '{0}' must be greater than minExclusive value '{1}'
    , FACET_maxIncl_minIncl              = 198		// maxInclusive value '{0}' must be greater than minInclusive value '{1}'
    , FACET_TotDigit_FractDigit          = 199		// TotalDigit value '{0}' must be greater than FractionDigit value '{1}'
    , FACET_maxIncl_base_maxExcl         = 200		// maxInclusive value '{0}' must be less than base's maxExclusive value '{1}'
    , FACET_maxIncl_base_maxIncl         = 201		// maxInclusive value '{0}' must be less than or equal to base's maxInclusive value '{1}'
    , FACET_maxIncl_base_minIncl         = 202		// maxInclusive value '{0}' must be greater than or equal to base's minInclusive value '{1}'
    , FACET_maxIncl_base_minExcl         = 203		// maxInclusive value '{0}' must be greater than base's minExclusive value '{1}'
    , FACET_maxExcl_base_maxExcl         = 204		// maxExclusive value '{0}' must be less than or equal to base's maxExclusive value '{1}'
    , FACET_maxExcl_base_maxIncl         = 205		// maxExclusive value '{0}' must be less than or equal to base's maxInclusive value '{1}'
    , FACET_maxExcl_base_minIncl         = 206		// maxExclusive value '{0}' must be greater than base's minInclusive value '{1}'
    , FACET_maxExcl_base_minExcl         = 207		// maxExclusive value '{0}' must be greater than base's minExclusive value '{1}'
    , FACET_minExcl_base_maxExcl         = 208		// minExclusive value '{0}' must be less than base's maxExclusive value '{1}'
    , FACET_minExcl_base_maxIncl         = 209		// minExclusive value '{0}' must be less than or equal to base's maxInclusive value '{1}'
    , FACET_minExcl_base_minIncl         = 210		// minExclusive value '{0}' must be greater than base's minInclusive value '{1}'
    , FACET_minExcl_base_minExcl         = 211		// minExclusive value '{0}' must be greater than base's minExclusive value '{1}'
    , FACET_minIncl_base_maxExcl         = 212		// minInclusive value '{0}' must be less than base's maxExclusive value '{1}'
    , FACET_minIncl_base_maxIncl         = 213		// minInclusive value '{0}' must be less than or equal to base's maxInclusive value '{1}'
    , FACET_minIncl_base_minIncl         = 214		// minInclusive value '{0}' must be greater than or equal to base's minInclusive value '{1}'
    , FACET_minIncl_base_minExcl         = 215		// minInclusive value '{0}' must be greater than base's minExclusive value '{1}'
    , FACET_maxIncl_notFromBase          = 216		// maxInclusive value '{0}' must be from the base's value space
    , FACET_maxExcl_notFromBase          = 217		// maxExclusive value '{0}' must be from the base's value space
    , FACET_minIncl_notFromBase          = 218		// minInclusive value '{0}' must be from the base's value space
    , FACET_minExcl_notFromBase          = 219		// minExclusive value '{0}' must be from the base's value space
    , FACET_totalDigit_base_totalDigit   = 220		// totalDigit value '{0}' must be less than or equal to base's totalDigit value '{1}'
    , FACET_fractDigit_base_totalDigit   = 221		// fractDigit value '{0}' must be less than or equal to base's totalDigit value '{1}'
    , FACET_fractDigit_base_fractDigit   = 222		// fractDigit value '{0}' must be less than or equal to base's fractDigit value '{1}'
    , FACET_maxIncl_base_fixed           = 223		// maxInclusive '{0}' must be equal to base's maxInclusive '{1}' , fixed
    , FACET_maxExcl_base_fixed           = 224		// maxExclusive '{0}' must be equal to base's maxExclusive '{1}' , fixed
    , FACET_minIncl_base_fixed           = 225		// minInclusive '{0}' must be equal to base's minInclusive '{1}' , fixed
    , FACET_minExcl_base_fixed           = 226		// minExclusive '{0}' must be equal to base's minExclusive '{1}' , fixed
    , FACET_totalDigit_base_fixed        = 227		// totalDigit '{0}' must be equal to base's totalDigit '{1}'  , fixed
    , FACET_fractDigit_base_fixed        = 228		// fractDigit '{0}' must be equal to base's fractDigit '{1}' , fixed
    , FACET_maxLen_base_fixed            = 229		// maxLen '{0}' must be equal to base's maxLen '{1}' , fixed
    , FACET_minLen_base_fixed            = 230		// minLen '{0}' must be equal to base's minLen '{1}' , fixed
    , FACET_len_base_fixed               = 231		// len '{0}' must be equal to base's len '{1}' , fixed
    , FACET_whitespace_base_fixed        = 232		// whitespace '{0}' must be equal to base's whitespace '{1}' , fixed
    , FACET_internalError_fixed          = 233		// internal Error: fixed
    , FACET_List_Null_baseValidator      = 234		// Null base validator in List 
    , FACET_Union_Null_memberTypeValidators   = 235	// Null member type validators in Union 
    , FACET_Union_Null_baseValidator     = 236		// Null base validator in Union
    , FACET_Union_invalid_baseValidatorType   = 237	// Union's base validator's type '{0}' must be union too 
    , VALUE_NotMatch_Pattern             = 238		// Value '{0}' does not match regular expression facet '{1}'
    , VALUE_Not_Base64                   = 239		// Value '{0}' is not encoded in Base64 
    , VALUE_Not_HexBin                   = 240		// Value '{0}' is not encoded in HexBin 
    , VALUE_GT_maxLen                    = 241		// Value '{0}' with length '{1}' exceeds maximum length facet of '{2}' 
    , VALUE_LT_minLen                    = 242		// Value '{0}' with length '{1}' is less than minimum length facet of '{2}' 
    , VALUE_NE_Len                       = 243		// Value '{0}' with length '{1}' is not equal to length facet of '{2}' 
    , VALUE_NotIn_Enumeration            = 244		// Value '{0}' is not in enumeration 
    , VALUE_exceed_totalDigit            = 245		// Value '{0}' with total digits '{1}' exceeds total digit facet of '{2}' 
    , VALUE_exceed_fractDigit            = 246		// Value '{0}' with fraction digits '{1}' exceeds fraction digit facet of '{2}' 
    , VALUE_exceed_maxIncl               = 247		// Value '{0}' must be less than or equal to MaxInclusive '{1}' 
    , VALUE_exceed_maxExcl               = 248		// Value '{0}' must be less than MaxExclusive '{1}' 
    , VALUE_exceed_minIncl               = 249		// Value '{0}' must be greater than or equal to MinInclusive '{1}' 
    , VALUE_exceed_minExcl               = 250		// Value '{0}' must be greater than MinExclusive '{1}' 
    , VALUE_WS_replaced                  = 251		// Value '{0}' is not whitespace replaced 
    , VALUE_WS_collapsed                 = 252		// Value '{0}' is not a whitespace collapsed 
    , VALUE_Invalid_NCName               = 253		// Value '{0}' is not valid NCName 
    , VALUE_Invalid_Name                 = 254		// Value '{0}' is not valid Name 
    , VALUE_ID_Not_Unique                = 255		// ID '{0}' is not unique 
    , VALUE_ENTITY_Invalid               = 256		// Value '{0}' is not valid ENTITY 
    , VALUE_QName_Invalid                = 257		// Value '{0}' is not valid QName 
    , VALUE_NOTATION_Invalid             = 258		// NOTATION '{0}' must be a valid QName 
    , VALUE_no_match_memberType          = 259		// Value '{0}' does not match any member types (of the union) 
    , VALUE_URI_Malformed                = 260		// Value '{0}' is NOT a valid URI 
    , XMLNUM_emptyString                 = 261		//  Empty string encountered.
    , XMLNUM_WSString                    = 262		//  String contains whitespaces only.
    , XMLNUM_2ManyDecPoint               = 263		//  More than one decimal points encountered.
    , XMLNUM_Inv_chars                   = 264		//  Invalid chars encountered.
    , XMLNUM_null_ptr                    = 265		//  Null pointer encountered.
    , XMLNUM_URI_Component_Empty         = 266		//  Cannot construct URI with null/empty '{0}' 
    , XMLNUM_URI_Component_for_GenURI_Only= 267		//  '{0}', '{1}' can only be set for a generic URI! 
    , XMLNUM_URI_Component_Invalid_EscapeSequence   //  '{0}' contains invalid escape sequence '{1}'= 268
    , XMLNUM_URI_Component_Invalid_Char   = 269		//  '{0}' contains invalid char '{1}'
    , XMLNUM_URI_Component_Set_Null      = 270		//  '{0}' can not be set to null 
    , XMLNUM_URI_Component_Not_Conformant   = 271	//  '{0}' is NOT conformance '{1}' 
    , XMLNUM_URI_No_Scheme               = 272		//  No scheme found in URI
    , XMLNUM_URI_NullHost                = 273		//  '{0}', '{1}' may not be specified if host is not specified 
    , XMLNUM_URI_NullPath                = 274		//  '{0}', '{1}' may not be specified if path is not specified 
    , XMLNUM_URI_Component_inPath        = 275		//  '{0}', '{1}' cannot be specified in path
    , XMLNUM_URI_PortNo_Invalid          = 276		//  Port no '{0}' shall be in (0, 65535) 
    , XMLNUM_DBL_FLT_maxNeg              = 277		//  Value '{0}' shall be greater than the max Negative value '{1}' 
    , XMLNUM_DBL_FLT_maxPos              = 278		//  Value '{0}' shall be less than the max Negative value '{1}' 
    , XMLNUM_DBL_FLT_minNegPos           = 279		//  Value '{0}' shall be in the range of '{1}', '{2}' 
    , XMLNUM_DBL_FLT_InvalidType         = 280		//  Type '{0}' is invalid: internal error 
    , XMLNUM_DBL_FLT_No_Exponent         = 281		//  Value '{0}' shall have exponent. 
    , Regex_Result_Not_Set               = 282		// A result is not set.
    , Regex_CompactRangesError           = 283		// CompactRanges - Internal Error
    , Regex_MergeRangesTypeMismatch      = 284		// Merge Ranges - Mismatched type
    , Regex_SubtractRangesError          = 285		// SubtractRanges - Internal Error
    , Regex_IntersectRangesError         = 286		// IntersectRanges - Internal Error
    , Regex_ComplementRangesInvalidArg   = 287		// ComplementRanges - Argument must be a RangeToken
    , Regex_InvalidCategoryName          = 288		// Invalid category name: {0}
    , Regex_KeywordNotFound              = 289		// Keyword '{0}' not found
    , Regex_BadRefNo                     = 290		// Reference no must be more than zero
    , Regex_UnknownOption                = 291		// Unknown option: {0}
    , Regex_UnknownTokenType             = 292		// Unknown token type
    , Regex_RangeTokenGetError           = 293		// Failed to get RangeToken for: {0}
    , Regex_NotSupported                 = 294		// Not supported
    , Regex_InvalidChildIndex            = 295		// Invalid child index
    , Regex_RepPatMatchesZeroString      = 296		// Replace pattern cannot match zero length string
    , Regex_InvalidRepPattern            = 297		// Invalid replace pattern
    , NEL_RepeatedCalls                  = 298		// Enabling the NEL option can only be called once per process.
    , RethrowError                       = 299		// {0}
    , Out_Of_Memory                      = 300		// operator new fails.  Possibly running Of memory
    , DV_InvalidOperation                = 301		// Operation is not allowed
    , XPath_NoAttrSelector               = 302		// Selectors cannot select attributes
    , XPath_NoUnionAtStart               = 303		// Not allowed to have '|' at the beginning of an xpath value
    , XPath_NoMultipleUnion              = 304		// Not allowed to have '||' in an xpath value
    , XPath_MissingAttr                  = 305		// Missing attribute name in xpath
    , XPath_ExpectedToken1               = 306		// Expected xpath token 'NAMETEST_QNAME' or 'NAMETEST_ANY' or 'NAMETEST_NAMESPACE'
    , XPath_PrefixNoURI                  = 307		// Prefix '{0}' not bound to namespace URI in an xpath value
    , XPath_NoDoubleColon                = 308		// Not allowed to have double colon in the xpath expression
    , XPath_ExpectedStep1                = 309		// Expected step following token 'AXISNAME_CHILD::'
    , XPath_ExpectedStep2                = 310		// Expected step following '//' in xpath
    , XPath_ExpectedStep3                = 311		// Expected step following '/' in xpath
    , XPath_NoForwardSlash               = 312		// '/' not allowed after '//' in xpath
    , XPath_NoDoubleForwardSlash         = 313		// '//' only allowed after '.' at the beginning of an xpath
    , XPath_NoForwardSlashAtStart        = 314		// Not allowed to have '/' at the beginning of an xpath value
    , XPath_NoSelectionOfRoot            = 315		// Not allowed to select the root of an xpath
    , XPath_EmptyExpr                    = 316		// Empty xpath expression
    , XPath_NoUnionAtEnd                 = 317		// The xpath expression cannot end with '|'
    , XPath_InvalidChar                  = 318		// Invalid character following '.' in xpath
    , XPath_TokenNotSupported            = 319		// XPath token not supported
    , XPath_FindSolution                 = 320		// Find a solution!
    , DateTime_Assert_Buffer_Fail        = 321		// buffer not initialized yet!
    , DateTime_dt_missingT               = 322		// 'T' is missing! '{0}' 
    , DateTime_gDay_invalid              = 323		// invalid gDay! '{0}' 
    , DateTime_gMth_invalid              = 324		// invalid gMonth! '{0}' 
    , DateTime_gMthDay_invalid           = 325		// invalid gMonthDay! '{0}' 
    , DateTime_dur_Start_dashP           = 326		// Duration shall start with '-' or 'P'! '{0}' 
    , DateTime_dur_noP                   = 327		// Duration shall always have 'P'! '{0}' 
    , DateTime_dur_DashNotFirst          = 328		// '-' can only appear at first! '{0}' 
    , DateTime_dur_inv_b4T               = 329		// Duration has invalid stuff before 'T'! '{0}' 
    , DateTime_dur_NoTimeAfterT          = 330		// Duration has no time elements after 'T'! '{0}' 
    , DateTime_dur_NoElementAtAll        = 331		// Duration shall have at least element ! '{0}' 
    , DateTime_dur_inv_seconds           = 332		// Duration shall have at least one digit after the . ! '{0}' 
    , DateTime_date_incomplete           = 333		// Incomplete Date ! '{0}' 
    , DateTime_date_invalid              = 334		// Invalid Date ! '{0}' 
    , DateTime_time_incomplete           = 335		// Incomplete Time ! '{0}' 
    , DateTime_time_invalid              = 336		// Invalid Time ! '{0}' 
    , DateTime_ms_noDigit                = 337		// ms shall be present once '.' is present ! '{0}' 
    , DateTime_ym_incomplete             = 338		// Incomplete YearMonth! '{0}' 
    , DateTime_ym_invalid                = 339		// Year separator is missing or misplaced ! '{0}' 
    , DateTime_year_tooShort             = 340		// Year must have 'CCYY' format ! '{0}' 
    , DateTime_year_leadingZero          = 341		// Invalid leading zero in year! '{0}' 
    , DateTime_ym_noMonth                = 342		// no month in YearMonth ! '{0}' 
    , DateTime_tz_noUTCsign              = 343		// TimeZone is expected ! '{0}' 
    , DateTime_tz_stuffAfterZ            = 344		// Expecting nothing after 'Z'! '{0}' 
    , DateTime_tz_invalid                = 345		// Invalid TimeZone! '{0}' 
    , DateTime_year_zero                 = 346		// The year (0000) is an illegal year value! '{0}' 
    , DateTime_mth_invalid               = 347		// The month must have values 1 to 12! '{0}' 
    , DateTime_day_invalid               = 348		// The day must have values 1 to 31! '{0}' 
    , DateTime_hour_invalid              = 349		// Hour must have values 0-23! '{0}' 
    , DateTime_min_invalid               = 350		// Minute must have values 0-59! '{0}' 
    , DateTime_second_invalid            = 351		// Second must have values 0-60! '{0}' 
    , DateTime_tz_hh_invalid             = 352		// Minute must have values 0-59! '{0}' 
    , PD_EmptyBase                       = 353		// Particle Derivation Restriction: The derived complexType has content, while base is empty.
    , PD_NSCompat1                       = 354		// NSCompat: The namespace of '{0}' is not allowed by wildcard in base
    , PD_OccurRangeE                     = 355		// The occurrence range of '{0}' is not a valid restriction of base element's range
    , PD_NameTypeOK1                     = 356		// NameAndTypeOK: The Element name/uri in restriction does not match that of corresponding base element
    , PD_NameTypeOK2                     = 357		// NameAndTypeOK: Element '{0}' is nillable in the restriction, while it's not in the base
    , PD_NameTypeOK3                     = 358		// NameAndTypeOK: Element '{0}' is either not fixed, or is not fixed with the same value as in the base
    , PD_NameTypeOK4                     = 359		// NameAndTypeOK: The disallowed substitutions, for element '{0}', are not a superset of those of the base element
    , PD_NameTypeOK5                     = 360		// NameAndTypeOK: Element '{0}' has a type that does not derive from that of the base
    , PD_NameTypeOK6                     = 361		// NameAndTypeOK: Derived element '{0}' has fewer Identity Constraints than base element '{1}'
    , PD_NameTypeOK7                     = 362		// NameAndTypeOK: Derived element '{0}' has an Identity Constraint that does not appear on base element '{1}'
    , PD_RecurseAsIfGroup                = 363		// RecurseAsIfGroup: Element '{0}' belongs to a group of a variety different from that of the base
    , PD_Recurse1                        = 364		// Occurrence range of group is not a valid restriction of occurrence range of base group
    , PD_Recurse2                        = 365		// Recurse: There is not a complete functional mapping between the particles
    , PD_ForbiddenRes1                   = 366		// Forbidden restriction of 'any': Choice,Seq,All,Elt
    , PD_ForbiddenRes2                   = 367		// Forbidden restriction of 'all': Choice,Seq,Elt
    , PD_ForbiddenRes3                   = 368		// Forbidden restriction of 'choice': All,Seq,Leaf
    , PD_ForbiddenRes4                   = 369		// Forbidden restriction of 'sequence': Elt
    , PD_NSSubset1                       = 370		// Wildcard's occurrence range not a restriction of base wildcard's range
    , PD_NSSubset2                       = 371		// Wildcard is not a subset of corresponding wildcard in base
    , PD_NSRecurseCheckCardinality1      = 372		// Group's occurrence range not a restriction of base wildcard's range
    , PD_RecurseUnordered                = 373		// RecurseUnordered: There is not a complete functional mapping between the particles
    , PD_MapAndSum                       = 374		// MapAndSum: There is not a complete functional mapping between the particles
    , PD_InvalidContentType              = 375		// Particle derivation: Invalid content spec node type
    , NodeIDMap_GrowErr                  = 376		// NodeIDMap overflows and exceeds the largest available size
    , XSer_ProtoType_Null_ClassName      = 377		// ProtoType has null class name
    , XSer_ProtoType_NameLen_Dif         = 378		// ProtoType name length diff '{0}' vs '{1}'
    , XSer_ProtoType_Name_Dif            = 379		// ProtoType name diff '{0}' vs '{1}'
    , XSer_InStream_Read_LT_Req          = 380		// InputStream read '{0}' less than required '{1}'
    , XSer_InStream_Read_OverFlow        = 381		// InputStream read '{0}' beyond buffer available '{1}'
    , XSer_Storing_Violation             = 382		// Storing violation
    , XSer_StoreBuffer_Violation         = 383		// Store buffer violation '{0}', '{1}'
    , XSer_LoadPool_UppBnd_Exceed        = 384		// Object Tag '{0}' exceed load pool uppper Boundary '{1}'
    , XSer_LoadPool_NoTally_ObjCnt       = 385		// Load pool size '{0}' not tally with object count '{1}'
    , XSer_Loading_Violation             = 386		// Loading violation
    , XSer_LoadBuffer_Violation          = 387		// Load buffer violation '{0}', '{1}'
    , XSer_Inv_ClassIndex                = 388		// Invalid class index '{0}', '{1}'
    , XSer_Inv_FillBuffer_Size           = 389		// Invalid fillBuffer size '{0}', '{1}'
    , XSer_Inv_checkFillBuffer_Size      = 390		// Invalid checkFillBuffer size '{0}'
    , XSer_Inv_checkFlushBuffer_Size     = 391		// Invalid checkFlushBuffer size '{0}'
    , XSer_Inv_Null_Pointer              = 392		// Invalid null pointer encountered '{0}'
    , XSer_Inv_Buffer_Len                = 393		// Invalid buffer length '{0}'
    , XSer_CreateObject_Fail             = 394		// CreateObject fails 
    , XSer_ObjCount_UppBnd_Exceed        = 395		// Object count '{0}' exceed upper boundary '{1}'
    , XSer_GrammarPool_Locked            = 396		// Grammar Pool is locked by other party
    , XSer_GrammarPool_Empty             = 397		// Grammar Pool is empty
    , XSer_GrammarPool_NotEmpty          = 398		// Grammar Pool is NOT empty
    , XSer_StringPool_NotEmpty           = 399		// String Pool is NOT empty
    , XSer_BinaryData_Version_NotSupported= 400		// Binary Data Version '{0}','{1}','{2}' not supported 
  };
}

Remarks

See remarsk of IXMLFileValidator::SetErrorListener

Some error descriptions contain '{0}', '{1}', '{2}' or '{3}'. On this place of the error text (IXMLFileValidatorErrorListener::fDescription) that is reported represents dynamic text reported by IXMLFileValidatorErrorListener::fText1, IXMLFileValidatorErrorListener::fText2, IXMLFileValidatorErrorListener::fText3, or IXMLFileValidatorErrorListener::fText4

See Also

VCOM:VCOMPtr | VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier | VCOM:VectorWorks:Filing:IXMLFile | VCOM:VectorWorks:Filing:IXMLFileValidator | VCOM:VectorWorks:Filing:XMLErrors

[[VCOM:VCOMPtr]] | [[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]] | [[VCOM:VectorWorks:Filing:IXMLFile]] | [[VCOM:VectorWorks:Filing:IXMLFileValidator]] | [[VCOM:VectorWorks:Filing:XMLErrors]]