VCOM:VectorWorks:Filing:XMLErrors:ValidityDomain

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Filing::XMLErrors

reports XML parsing problem within the XML interface impelementatoin.

namespace ValidityDomain
{
  enum Codes
  {
      NoError                            = 0		// 
      // errors --------------------------------------------------------------------------------------------------------
    , ElementNotDefined                  = 2		// Unknown element '{0}'
    , AttNotDefined                      = 3		// Attribute '{0}' not defined
    , NotationNotDeclared                = 4		// Notation '{0}' was referenced but never declared
    , RootElemNotLikeDocType             = 5		// Root element different from DOCTYPE
    , RequiredAttrNotProvided            = 6		// Required attribute '{0}' was not provided
    , ElementNotValidForContent          = 7		// Element '{0}' is not valid for content model: '{1}'
    , BadIDAttrDefType                   = 8		// ID attributes must be #IMPLIED or #REQUIRED
    , InvalidEmptyAttValue               = 9		// This type of attribute cannot have an empty value
    , ElementAlreadyExists               = 10		// Element '{0}' has already been declared
    , MultipleIdAttrs                    = 11		// Element '{0}' has more than one ID attribute
    , ReusedIDValue                      = 12		// ID '{0}' has already been used
    , IDNotDeclared                      = 13		// ID attribute '{0}' was referenced but never declared
    , UnknownNotRefAttr                  = 14		// Attribute '{0}' refers to an unknown notation '{1}'
    , UndeclaredElemInDocType            = 15		// Element '{0}' was used in the DOCTYPE but never declared
    , EmptyNotValidForContent            = 16		// Empty content not valid for content model: '{0}'
    , AttNotDefinedForElement            = 17		// Attribute '{0}' is not declared for element '{1}'
    , BadEntityRefAttr                   = 18		// The value '{0}' for attribute '{1}' of type ENTITY/ENTITIES must refer to an external, unparsed entity
    , UnknownEntityRefAttr               = 19		// Attribute '{0}' refers to an unknown entity '{1}'
    , ColonNotValidWithNS                = 20		// If namespaces are enabled, it's invalid for an attribute of type ID/IDREF/IDREFS/ENTITY/ENTITIES/NOTATION to contain a colon.
    , NotEnoughElemsForCM                = 21		// Not enough elements to match content model : '{0}'
    , NoCharDataInCM                     = 22		// No character data is allowed by content model
    , DoesNotMatchEnumList               = 23		// The value '{0}' for attribute '{1}' does not match its defined enumeration or notation list
    , AttrValNotName                     = 24		// The value '{0}' for attribute '{1}' must be Name or Nmtoken
    , NoMultipleValues                   = 25		// Attribute '{0}' does not support multiple values
    , NotSameAsFixedValue                = 26		// Attribute '{0}' has a value, '{1}', that does not match its #FIXED value, '{2}'
    , RepElemInMixed                     = 27		// Element types cannot be duplicated in Mixed content models
    , NoValidatorFor                     = 28		// No validator for datatype {0}
    , IncorrectDatatype                  = 29		// Incorrect datatype: {0}
    , NotADatatype                       = 30		// {0} is not a datatype.
    , TextOnlyContentWithType            = 31		// The content attribute must be 'textOnly' if you specify a type attribute.
    , FeatureUnsupported                 = 32		// {0} is unsupported
    , NestedOnlyInElemOnly               = 33		// Nested Element decls only allowed in elementOnly content
    , EltRefOnlyInMixedElemOnly          = 34		// Element references only allowed in mixed or elementOnly content
    , OnlyInEltContent                   = 35		// {0} only allowed in elementOnly content.
    , OrderIsAll                         = 36		// {0} not allowed if the order is all.
    , DatatypeWithType                   = 37		// Datatype qualifiers can only be used if you specify a type attribute.
    , DatatypeQualUnsupported            = 38		// The datatype qualifier {0} is not supported.
    , GroupContentRestricted             = 39		// Error: {0} content must be one of element, group, modelGroupRef. Saw {1}
    , UnknownBaseDatatype                = 40		// Unknown base type {0} for type {1}.
    , OneOfTypeRefArchRef                = 41		// Can only have one of type and ref attributes.
    , NoContentForRef                    = 42		// A <{0}> declaration that has a ref attribute, cannot have child content.
    , IncorrectDefaultType               = 43		// Incorrect type for {0}'s default value: {1}
    , IllegalAttContent                  = 44		// Illegal content {0} in attribute group
    , ValueNotInteger                    = 45		// Value of {0} is not an integer.
    , DatatypeError                      = 46		// Datatype error: Type:{0}, Message:{1}.
    , SchemaError                        = 47		// Schema error: Type:{0}, Message:{1}
    , TypeAlreadySet                     = 48		// The type of the element has already been declared.
    , ProhibitedAttributePresent         = 49		// Prohibited Attribute is found.
    , IllegalXMLSpace                    = 50		// Illegal xml:space declaration.
    , NotBoolean                         = 51		// {0} is not a boolean.
    , NotDecimal                         = 52		// {0} is not a decimal.
    , FacetsInconsistent                 = 53		// Facets are inconsistent with base type.
    , IllegalFacetValue                  = 54		// Illegal value {0} for facet {1}.
    , IllegalDecimalFacet                = 55		// Illegal Facet for decimal type.
    , UnknownFacet                       = 56		// Unknown Facet: {0}.
    , InvalidEnumValue                   = 57		// Invalid value for Enum constant: {0}.
    , OutOfBounds                        = 58		// {0} is out of bounds:[ {1} {3} X  {4} {2} ].
    , NotAnEnumValue                     = 59		// {0} is not one of the specified enum values.
    , NotInteger                         = 60		// {0} is not an integer.
    , IllegalIntegerFacet                = 61		// Illegal Facet for Integer type.
    , NotReal                            = 62		// {0} is not a double.
    , IllegalRealFacet                   = 63		// Illegal Facet for Real type.
    , ScaleLargerThanPrecision           = 64		// Scale Facet must be less than or equal to Precision Facet
    , PrecisionExceeded                  = 65		// {0} has exceeded the precision Facet {1}
    , ScaleExceeded                      = 66		// {0} has exceeded the scale Facet {1}
    , NotFloat                           = 67		// {0} is not a float.
    , SchemaRootError                    = 68		// Can't get back Schema document's root element {0}.
    , WrongTargetNamespace               = 69		// Schema in {0} has a different target namespace from the one specified in the instance document {1}.
    , SimpleTypeHasChild                 = 70		// In element {0}: Can not have element children within a simple type content.
    , NoDatatypeValidatorForSimpleType   = 71		// This element {0} has a simpletype but no datatype validator was found.
    , GrammarNotFound                    = 72		// There is no Grammar for uri: {0}.
    , DisplayErrorMessage                = 73		// {0}
    , NillNotAllowed                     = 74		// xsi:nil must not be specified for the element {0} with nillable equals false
    , NilAttrNotEmpty                    = 75		// Element {0} with attribute xsi:nil=true must be empty
    , FixedDifferentFromActual           = 76		// Content of element '{0}' is different from the fixed attribute value in the element's schema declaration.
    , NoDatatypeValidatorForAttribute    = 77		// No datatype validator was found for this attribute {0}.
    , GenericError                       = 78		// Schema error during parsing
    , ElementNotQualified                = 79		// Element '{0}' should be qualified
    , ElementNotUnQualified              = 80		// Element '{0}' should be un-qualified
    , VC_IllegalRefInStandalone          = 81		// Reference to external entity declaration '{0}' is not allowed in a standalone document.
    , NoDefAttForStandalone              = 82		// Attribute '{0}' for element '{1}' has a default value and must be specified in a standalone document.
    , NoAttNormForStandalone             = 83		// Attribute '{0}' must not be changed by normalization in a standalone document.
    , NoWSForStandalone                  = 84		// White space must not occur between externally declared elements with element content in a standalone document.
    , VC_EntityNotFound                  = 85		// Entity '{0}' was not found
    , PartialMarkupInPE                  = 86		// Partial markup in parameter entity replacement text.
    , DatatypeValidationFailure          = 87		// Failed to validate '{0}'
    , UniqueParticleAttributionFail      = 88		// Complex type '{0}' violates the Unique Particle Attribution rule in its components '{1}' and '{2}'
    , NoAbstractInXsiType                = 89		// Abstract type '{0}' should not be used in xsi:type
    , NoDirectUseAbstractElement         = 90		// A member of abstract element {0} substitution group must be specified
    , NoUseAbstractType                  = 91		// Element {0} is declared with a type that is abstract.  Use xsi:type to specify a non-abstract type
    , BadXsiType                         = 92		// Unresolved type '{0}' found in xsi:type handling
    , NonDerivedXsiType                  = 93		// Type '{0}' that is used in xsi:type is not derived from the type of element '{1}'
    , NoSubforBlock                      = 94		// Element '{0}' has blocking constraint and does not permit substitution
    , AttributeNotQualified              = 95		// Attribute '{0}' should be qualified
    , AttributeNotUnQualified            = 96		// Attribute '{0}' should be un-qualified
    , IC_FieldMultipleMatch              = 97		// Field matches more than one value within the scope of its selector; fields must match unique values
    , IC_UnknownField                    = 98		// Internal identity constraint error; unknown field.
    , IC_AbsentKeyValue                  = 99		// Identity-constraint 4.2.1: element '{0}' has a key with no value.
    , IC_UniqueNotEnoughValues           = 100		// Not enough values specified for <unique> identity constraint for element '{0}'.
    , IC_KeyNotEnoughValues              = 101		// Not enough values specified for <key name={1}> identity constraint for element '{0}'.
    , IC_KeyRefNotEnoughValues           = 102		// Not enough values specified for <keyref name={1}> identity constraint for element '{0}'.
    , IC_KeyMatchesNillable              = 103		// Identity-constraint 4.2.3: element '{0}' has a key that matches an element that has nillable set to true.
    , IC_DuplicateUnique                 = 104		// Duplicate unique value declared for identity constraint of element '{0}'.
    , IC_DuplicateKey                    = 105		// Duplicate key value declared for identity constraint of element '{0}'.
    , IC_KeyRefOutOfScope                = 106		// The keyref '{0}' refers to a key/unique that is out of scope.
    , IC_KeyNotFound                     = 107		// The key for identity constraint of element '{0}' is not found.
    , NonWSContent                       = 108		// Non-whitespace characters are not allowed in schema elements other than 'appinfo' and 'documentation'.
    , EmptyElemNotationAttr              = 109		// EMPTY Element '{0}' has Attribute '{1}' of type NOTATION 
    , EmptyElemHasContent                = 110		// EMPTY Element '{0}' can't have content(not even entity references, comments, PIs or white space). 
    , ElemOneNotationAttr                = 111		// Element '{0}' has more than one Attribute of type NOTATION 
    , AttrDupToken                       = 112		// Attribute '{0}' has non distinct token '{1}' 
    , ElemChildrenHasInvalidWS           = 113		// Element '{0}' 's content model(children) does not allow escaped white space. 
  };
}

Remarks

See remarsk of IXMLFileValidator::SetErrorListener

Some error descriptions contain '{0}', '{1}', '{2}' or '{3}'. On this place of the error text (IXMLFileValidatorErrorListener::fDescription) that is reported represents dynamic text reported by IXMLFileValidatorErrorListener::fText1, IXMLFileValidatorErrorListener::fText2, IXMLFileValidatorErrorListener::fText3, or IXMLFileValidatorErrorListener::fText4

See Also

VCOM:VCOMPtr | VCOM:VectorWorks:Filing:IFolderIdentifier | VCOM:VectorWorks:Filing:IFileIdentifier | VCOM:VectorWorks:Filing:IXMLFile | VCOM:VectorWorks:Filing:IXMLFileValidator | VCOM:VectorWorks:Filing:XMLErrors

[[VCOM:VCOMPtr]] | [[VCOM:VectorWorks:Filing:IFolderIdentifier]] | [[VCOM:VectorWorks:Filing:IFileIdentifier]] | [[VCOM:VectorWorks:Filing:IXMLFile]] | [[VCOM:VectorWorks:Filing:IXMLFileValidator]] | [[VCOM:VectorWorks:Filing:XMLErrors]]