VCOM:VectorWorks:Extension:IProviderReshape3D::UseStandardReshape

From Vectorworks Developer
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::Extension

Member of VCOM:VectorWorks:Extension:IProviderReshape3D

Specify whether the standard reshaper will be used for the object instead of the one implemented by the interface.

virtual boolVCOM_CALLTYPE UseStandardReshape(
MCObjectHandle h) = 0;

Parameters

h MCObjectHandle the object.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.