VCOM:VectorWorks:Extension:IDTMTIN::GetBoundedSurfaceInfo

From Vectorworks Developer
Jump to navigation Jump to search

Description

namespace VectorWorks::Extension

Member of VCOM:VectorWorks:Extension:IDTMTIN

Calculates the surface informations from the region of the Site model under the bounding poly.

virtual VCOMErrorVCOM_CALLTYPE GetBoundedSurfaceInfo(
IPolyDef* inBoundPoly2D,
double& outProjArea,
double& outExisSurfArea,
double& outPropSurfArea) = 0;

Parameters

inBoundPoly2D IPolyDef* the bounding poly.
outProjArea double& resulting projected area.
outExisSurfArea double& resulting existing surface area.
outPropSurfArea double& resulting proposed surface area.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.