Worksheet Functions: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Fix for VB-190600 and VB-190626)
No edit summary
Line 18: Line 18:
</pre>
</pre>
|-
|-
| colspan="3" | <big>FormatField(format_name, field_name)</big>
| colspan="3" | <big>FormatField(record_format_name, field_name)</big>
|-
|-
|  || valign="top" | Returns the default value of a given field name for the specified record format.
|  || valign="top" | Returns the default value of a given field name of the specified record format.
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell: =FormatField(‘Door’, ‘Width’), where “Door” is the name of a record format, returns the record default value for the “Width” field for each object in the database. The value will be the same for every item in the database.
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=FormatField(‘Door’, ‘Width’), where “Door” is the name of a record format, returns the default value for the “Width” field.


Spreadsheet cell: =FormatField('Door', ‘Width’), where “Door” is the name of a record format, returns the record default value for the “Width” field.  Note: unlike many of the functions that require a criteria for the Spreadsheet version of the function call, since FormatField is not specific to an object, no criteria is needed or allowed.
</pre>
</pre>
|-
|-
Line 76: Line 75:
|  || valign="top" | True when the value is N/A.
|  || valign="top" | True when the value is N/A.
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=IF(IsNA(Angle('energos'), '-', 'has value') On a database row, calculates the Energos angle of the objects, and decides which value to output based on if energos is applicable or not.
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=IF(IsNA(Angle('energos')), '-', 'has value') On a database row, calculates the Energos angle of the objects, and decides which value to output based on if energos is applicable or not.


Note, you can use IfNA in order to use alternative value only when it's not applicable, the 'Angle' would have to be repeated for the IF function.
Note, you can use IfNA in order to use alternative value only when it's not applicable, the 'Angle' would have to be repeated for the IF function.
Line 127: Line 126:
| colspan="3" | <big>VLookup(value, [use_pattern], result_col_index, not_found_value, table)</big>
| colspan="3" | <big>VLookup(value, [use_pattern], result_col_index, not_found_value, table)</big>
|-
|-
| style="width: 10pt;" |  || valign="top" | Finds a value in the table range, looking at the leftmost column, and returns the value at the result_col_index in that same row. The pattern uses ECMAScript syntax: https://www.cplusplus.com/reference/regex/ECMAScript/?kw=ECMAScript
| style="width: 10pt;" |  || valign="top" | Finds a value in the table range, looking at the leftmost column, and returns the value at the result_col_index in that same row. Uses ECMAScript syntax for the pattern: https://www.cplusplus.com/reference/regex/ECMAScript/?kw=ECMAScript
|-
|-
| style="width: 10pt;" |  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=VLookup(value, [use_pattern], result_col_index, not_found_value, table)
| style="width: 10pt;" |  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=VLookup(value, [use_pattern], result_col_index, not_found_value, table)
Line 157: Line 156:
| colspan="3" | <big>XLookup(value, [use_pattern], not_found_value, array_lookup, array_result)</big>
| colspan="3" | <big>XLookup(value, [use_pattern], not_found_value, array_lookup, array_result)</big>
|-
|-
|  || valign="top" | Finds a value in the array_lookup, and returns the value from the array_result at the found row. The arrays should be ranges on the same column. The pattern uses ECMAScript syntax: https://www.cplusplus.com/reference/regex/ECMAScript/?kw=ECMAScript
|  || valign="top" | Finds a value in the array_lookup, and returns the value from the array_result at the found row. The arrays should be ranges on the same column. Uses ECMAScript syntax for the pattern: https://www.cplusplus.com/reference/regex/ECMAScript/?kw=ECMAScript
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=XLookup(value, [use_pattern], not_found_value, array_lookup, array_result)
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=XLookup(value, [use_pattern], not_found_value, array_lookup, array_result)
Line 296: Line 295:
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=quotient(5, 2) returns 2
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=quotient(5, 2) returns 2
</pre>
 
You can clculate the remainder by using the MOD operator
=5 MOD 2</pre>
|-
|-
| colspan="3" | <big>gcd(number1, number2, …)</big>
| colspan="3" | <big>gcd(number1, number2, …)</big>
Line 351: Line 352:
|  || valign="top" | A number between bottom and top, including bottom but not including top.
|  || valign="top" | A number between bottom and top, including bottom but not including top.
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=rand(10, 100) returns a random number in the range [10, 100]
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=randBetween(10, 100) returns a random number in the range [10, 100]
</pre>
</pre>
|-
|-
Line 478: Line 479:
|-
|-
|  ||  
|  ||  
|-
| colspan="3" | <big>ObjectData('component', <value> [, <component index>])</big>
|-
|  || valign="top" | Returns the specified <value> about a component by index, or the core component if <component index> is missing. See the example for more details.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Available optiosn for <value>:
- Name
- Function
- Class
- Class Desc
- Thickness
- Lambda
- U-Value
- Net Area
- Net Volume
Examples:
# return component name
ObjectData('component', 'Name') # core compoent
ObjectData('component', 'Name', 2) # component with index = 2
# return component Function value
ObjectData('component', 'Function') # core compoent
ObjectData('component', 'Function', 2) # component with index = 2
# return component class
ObjectData('component', 'Class') # core compoent
ObjectData('component', 'Class', 2) # component with index = 2
# return component class description
ObjectData('component', 'Class Desc') # core compoent
ObjectData('component', 'Class Desc', 2) # component with index = 2
ObjectData('component', 'Class Description') # core compoent
ObjectData('component', 'Class Description', 2) # component with index = 2
# return component thickness
ObjectData('component', 'Thickness') # core compoent
ObjectData('component', 'Thickness', 2) # component with index = 2
# return component lambda value
ObjectData('component', 'Lambda') # core compoent
ObjectData('component', 'Lambda', 2) # component with index = 2
# return component U-value
ObjectData('component', 'U-Value') # core compoent
ObjectData('component', 'U-Value', 2) # component with index = 2
# return component net area
ObjectData('component', 'Net Area') # core compoent
ObjectData('component', 'Net Area', 2) # component with index = 2
# return component net volume
ObjectData('component', 'Net Volume') # core compoent
ObjectData('component', 'Net Volume', 2) # component with index = 2
</pre>
|-
|-
| colspan="3" | <big>ObjectData('General Name')</big>
| colspan="3" | <big>ObjectData('General Name')</big>
|-
|-
|  || valign="top" | Returns the object's name and if it's a symbol with no name, returns the symbol name.
|  || valign="top" | Returns the object's or symbol's name and if it's a symbol with no name, returns the symbol definition resource name.
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
Line 491: Line 556:
                                       If the object is a symbol, it will return the name of the symbol
                                       If the object is a symbol, it will return the name of the symbol
</pre>
</pre>
|-
| colspan="3" | <big>ObjectData(criteria, 'inventory part', part_univ_name, part_index)</big>
|-
|  || valign="top" | Get inventory part name from inventory supported object.
|-
|  ||
|-
| colspan="3" | <big>ObjectData(criteria, 'inventory part param', part_univ_name, part_index, param_index)</big>
|-
|  || valign="top" | Get inventory part parameter value from inventory supported object.
|-
|  ||
|-
| colspan="3" | <big>ObjectData(criteria, 'inventory part quantity', part_univ_name, part_index)</big>
|-
|  || valign="top" | Get inventory part quantity from inventory supported object.
|-
|  ||
|-
|-
| colspan="3" | <big>ObjectData('Layer Description')</big>
| colspan="3" | <big>ObjectData('Layer Description')</big>
Line 586: Line 669:


Spreadsheet cell:
Spreadsheet cell:
=IsFlipped(PON='window') returns the flip state of the window object if it resolves to only one, otherwise returns the total number of window objects in the drawing that are flipped</pre>
=IsFlipped(PON='window') returns the flip state of the window object if it resolves to only one, otherwise returns the total number of window objects in the drawing that are flipped
</pre>
|-
|-
| colspan="3" | <big>XCoordinate()</big>
| colspan="3" | <big>XCoordinate()</big>
Line 1,479: Line 1,563:


Spreadsheet cell:
Spreadsheet cell:
=MaterialIsSimple(t=SOLIDCSG) returns TRUE if the material of the generic solid in 6th drawing is a simple material.
=MaterialIsSimple(t=SOLIDCSG) returns TRUE if the material of the generic solid in the drawing is a simple material.
</pre>
</pre>
|-
|-
Line 1,586: Line 1,670:
'MaterialStandard'
'MaterialStandard'
</pre>
</pre>
|}
== Specialized for Adapter ==
{| border=0
| colspan="3" | <big>ObjectData('eval adapter plug device', '<RecordName>', '<FieldName>')</big>
|-
| style="width: 10pt;" |  || valign="top" | Get parameter value or attached record field from the adapter's plug device.
|-
| style="width: 10pt;" |  ||
|-
| colspan="3" | <big>ObjectData('eval adapter plug socket', '<RecordName>', '<FieldName>')</big>
|-
|  || valign="top" | Get parameter value or attached record field from the adapter's plug socket.
|-
|  ||
|}
|}


Line 1,591: Line 1,691:


{| border=0
{| border=0
| colspan="3" | <big>ObjectData('eval circuit destination adapter', '<RecordName>', '<FieldName>')</big>
|-
| style="width: 10pt;" |  || valign="top" | Get parameter value or attached record field from the circuit's destination adapter.
|-
| style="width: 10pt;" |  ||
|-
| colspan="3" | <big>ObjectData('eval circuit destination device', '<RecordName>', '<FieldName>')</big>
| colspan="3" | <big>ObjectData('eval circuit destination device', '<RecordName>', '<FieldName>')</big>
|-
|-
| style="width: 10pt;" |  || valign="top" | Get parameter value or attached record field from the circuit's destination device.
|  || valign="top" | Get parameter value or attached record field from the circuit's destination device.
|-
|-
| style="width: 10pt;" |  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('eval circuit destination socket', '<RecordName>', '<FieldName>')</big>
| colspan="3" | <big>ObjectData('eval circuit destination socket', '<RecordName>', '<FieldName>')</big>
|-
|-
|  || valign="top" | Get parameter value or attached record field from the circuit's destination socket.
|  || valign="top" | Get parameter value or attached record field from the circuit's destination socket.
|-
|  ||
|-
| colspan="3" | <big>ObjectData('eval circuit route', ['<RecordName>]', '[<FieldName>]')</big>
|-
|  || valign="top" | Get path IDs, parameter values or attached record fields from the circuit's used cable paths. The drawing needs to be analyzed.
|-
|  ||
|-
| colspan="3" | <big>ObjectData('eval circuit source adapter', '<RecordName>', '<FieldName>')</big>
|-
|  || valign="top" | Get parameter value or attached record field from the circuit's source adapter.
|-
|-
|  ||  
|  ||  
Line 1,651: Line 1,769:
=CurtWallPnlAreaNet(t=wall, 'Class-1') returns the combined net area of the curtain wall panels assigned to the class “Class-1” for all curtain walls in the drawing
=CurtWallPnlAreaNet(t=wall, 'Class-1') returns the combined net area of the curtain wall panels assigned to the class “Class-1” for all curtain walls in the drawing
</pre>
</pre>
|}
== Specialized for Device ==
{| border=0
| colspan="3" | <big>ObjectData('eval equipment item', '<RecordName>', '<FieldName>')</big>
|-
| style="width: 10pt;" |  || valign="top" | Get parameter value or attached record field from the device's corresponding equipment item.
|-
| style="width: 10pt;" |  ||
|}
|}


Line 1,713: Line 1,841:
|}
|}


== Specialized for Landscape Area ==
== Specialized for Hedgerow ==


{| border=0
{| border=0
| colspan="3" | <big>Depth()</big>
| colspan="3" | <big>ObjectData('percentage')</big>
|-
| style="width: 10pt;" |  || valign="top" | Return the percentage value of this plant from a Landscape Area. This must be used on a database row listing the plants of Landscape Areas.
|-
| style="width: 10pt;" |  ||
|-
| colspan="3" | <big>ObjectData('Plant Record', <field>)</big>
|-
|  || valign="top" | Provides access to the Plant Record data of the Landscape Area Plant subparts for edit if the style allows.
|-
|  ||
|-
| colspan="3" | <big>ObjectData('rate')</big>
|-
|  || valign="top" | Return the rate value value of this plant from a Landscape Area. This must be used on a database row listing the plants of Landscape Areas.
|-
|  ||
|-
| colspan="3" | <big>ObjectData('rate unit')</big>
|-
|  || valign="top" | Return the rate unit string of this plant from a Landscape Area. This must be used on a database row listing the plants of Landscape Areas.
|-
|  ||
|-
| colspan="3" | <big>ObjectData('rate with unit')</big>
|-
|  || valign="top" | Return the rate value and unit of this plant from a Landscape Area. This must be used on a database row listing the plants of Landscape Areas.
|-
|  ||
|}
 
== Specialized for Landscape Area ==
 
{| border=0
| colspan="3" | <big>Depth()</big>
|-
|-
| style="width: 10pt;" |  || valign="top" | Calculate the depth of the Landscape Area, Hardscape, or Site Model and their components.
| style="width: 10pt;" |  || valign="top" | Calculate the depth of the Landscape Area, Hardscape, or Site Model and their components.
Line 1,795: Line 1,957:
|}
|}


== Specialized for Plant ==
== Specialized for Lighting Device ==


{| border=0
{| border=0
| colspan="3" | <big>PlantImage(index)</big>
| colspan="3" | <big>Weight(criteria)</big>
|-
|-
| style="width: 10pt;" |  || valign="top" | Returns an image of the object at the specified index.
| style="width: 10pt;" |  || valign="top" | Returns the total weight of the Lighting Device and all it's accessories.
|-
|-
| style="width: 10pt;" |  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
| style="width: 10pt;" |  ||  
=PlantImage(2) displays the image specified for Image Detail in the Plant Data pane of the plant symbol definition
|-
 
| colspan="3" | <big>ObjectData('Lighting Device', <field>)</big>
Spreadsheet cell:
=PlantImage((‘Plant’.’plant ID’=’TaxfR’), 4) displays the image specified for Custom Image in the Plant Data pane of the plant symbol definition with a plant ID of TaxfR
</pre>
|}
 
== Specialized for Roof ==
 
{| border=0
| colspan="3" | <big>RoofArea_Total()</big>
|-
|-
| style="width: 10pt;" |  || valign="top" | Returns the total area along the slope of a roof.
|  || valign="top" | Provides access to the Instrument Type of Lighting Device accessories. Use no parameters for all cells and accessories or use parameters to specify cells or accessories.
|-
|-
| style="width: 10pt;" |  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
|  ||  
=RoofArea_Total returns the total area for each roof and roof face object in the database
 
Spreadsheet cell:
=RoofArea_Total(st=roofface) returns the combined total area of all roof face objects in the drawing</pre>
|-
|-
| colspan="3" | <big>RoofArea_Heated()</big>
| colspan="3" | <big>ObjectData('Lighting Device', <field>)</big>
|-
|-
|  || valign="top" | Returns the heated area along the slope of a roof.  
|  || valign="top" | Provides access to a data of the Lighting Device accessory. Use  the first parameter to specify the universal parameter name. Use no parameters additional for all cells and accessories or use additional parameters to specify cells or accessories.
The heated area is the area that does not include an overhang.
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
|  ||  
=RoofArea_Heated returns the heated area for each roof and roof face object in the database
 
Spreadsheet cell:
=RoofArea_Heated (st=roofface) returns the combined heated area of all roof face objects in the drawing</pre>
|-
|-
| colspan="3" | <big>RoofArea_TotalProj()</big>
| colspan="3" | <big>ObjectData('Lighting Device', <field>)</big>
|-
|-
|  || valign="top" | Returns the total area of a roof projected on the active layer plane.
|  || valign="top" | Provides access to the symbol names of Lighting Device accessories. Use no parameters for all cells and accessories or use parameters to specify cells or accessories.
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
|  ||  
=RoofArea_TotalProj returns the total area for each roof and roof face object in the database, as projected to the layer plane
 
Spreadsheet cell:
=RoofArea_Totalproj(t=roof) returns the combined total area of all roof objects in the drawing, as projected to the layer plane
</pre>
|-
|-
| colspan="3" | <big>RoofArea_HeatedProj()</big>
| colspan="3" | <big>ObjectData('Lighting Device', <field>)</big>
|-
|-
|  || valign="top" | Returns the heated area of a roof projected on the active layer plane.  
|  || valign="top" | Provides access to a parameter of the Lighting Devices and ignores accessories. Use parameters to specify the universal parameter name.
The heated area is the area that does not include an overhang.
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
|  ||  
=RoofArea_HeatedProj returns the heated area for each roof and roof face object in the database, as projected to the layer plane
 
Spreadsheet cell:
=RoofArea_HeatedProj (t=roof) returns the combined heated area of all roof objects in the drawing, as projected to the layer plane
</pre>
|-
| colspan="3" | <big>RoofStyleName()</big>
|-
|  || valign="top" | Returns the name the roof style used by the object.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=RoofStyleName returns the roof style name for each roof object in the database
 
Spreadsheet cell:
=RoofStyleName(n='roof-1') returns the roof style name for the object named “roof-1”
</pre>
|}
 
== Specialized for Site Model ==
 
{| border=0
| colspan="3" | <big>Depth()</big>
|-
| style="width: 10pt;" |  || valign="top" | Calculate the depth of the Landscape Area, Hardscape, or Site Model and their components.
|-
|-
| style="width: 10pt;" | ||
| colspan="3" | <big>ObjectData('Lighting Device', <field>)</big>
|-
|-
| colspan="3" | <big>ProjectedArea()</big>
|  || valign="top" | Provides access to the channel of Lighting Devices. Use no parameters for all cells and accessories or use parameters to specify cells or accessories.
|-
|  || valign="top" | Calculate the projected area of the Landscape Area, Hardscape, or Site Model and their components.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('component name')</big>
| colspan="3" | <big>ObjectData('Lighting Device', <field>)</big>
|-
|-
|  || valign="top" | Return the name of the component subpart for Landscape Area, Hardscape, and Site Model.
|  || valign="top" | Provides access to the color of Lighting Devices. Use no parameters for all cells and accessories or use parameters to specify cells or accessories.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Area()</big>
| colspan="3" | <big>ObjectData('Lighting Device', <field>)</big>
|-
|-
|  || valign="top" | Calculate the surface area of the Landscape Area, Hardscape, or Site Model and their components.
|  || valign="top" | Provides access to a parameter of Lighting Devices. Use parameters to specify the universal parameter name, cell number and accessory number.
|-
|-
|  ||  
|  ||  
|}
== Specialized for Plant ==
{| border=0
| colspan="3" | <big>PlantImage(index)</big>
|-
|-
| colspan="3" | <big>SurfaceArea()</big>
| style="width: 10pt;" | || valign="top" | Returns an image of the object at the specified index.
|-
|-
|  || valign="top" | Calculate the surface area of the Landscape Area, Hardscape, or Site Model and their components.
| style="width: 10pt;" |  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
|-
=PlantImage(2) displays the image specified for Image Detail in the More Data pane of the plant symbol definition
|  ||
 
|-
Spreadsheet cell:
| colspan="3" | <big>Volume()</big>
=PlantImage((‘Plant’.’plant ID’=’TaxfR’), 4) displays the image specified for Custom Image in the More Data pane of the plant symbol definition with a plant ID of TaxfR
|-
</pre>
|  || valign="top" | Calculate the volume of the Landscape Area, Hardscape, or Site Model and their components.
|-
|  ||
|}
|}


== Specialized for Slab ==
== Specialized for Railing/Fence ==


{| border=0
{| border=0
| colspan="3" | <big>ObjectData('Component Name')</big>
| colspan="3" | <big>Width()</big>
|-
|-
| style="width: 10pt;" |  || valign="top" | Returns the name of the wall, slab or roof component.
| style="width: 10pt;" |  || valign="top" | Width([optional parameter])
 
This function is applicable to the following subparts: Wall Bracket, Face Mount, Frame and Panel.
 
OPTIONAL PARAMETER:
'subpart=...': If provided, only the given subpart is included.
 
QUANTITY DESCRIPTION:
For Wall Bracket: Horizontal dimension of the Top Rails Wall Bracket.
 
For Face Mount: Horizontal dimension of the Face Mount Post.
 
For Frame: Width of the rectangular frame.
 
For Panel: Width of the panel in elevation.
|-
|-
| style="width: 10pt;" |  ||  
| style="width: 10pt;" |  ||  
|-
|-
| colspan="3" | <big>ObjectData('Component Name')</big>
| colspan="3" | <big>Width('profile')</big>
|-
|-
|  || valign="top" | Returns the name of the wall, slab or roof component.
|  || valign="top" | Width('profile', [optional parameter])
|-
 
|  ||
This function is applicable to the following subparts: Top Rail, Post, Crossbar Top and Bottom, Bar Vertical and Horizontal, Frame.
|-
 
| colspan="3" | <big>ObjectData('Lambda')</big>
OPTIONAL PARAMETER:
|-
'subpart=...': If provided, only the given subpart is included.
|  || valign="top" | Returns the Lambda value of the object.
 
QUANTITY DESCRIPTION:
For Top Rail: Width of the Railings TopRail cross section profile. For round or octagonal shape of profile, width equals height. For custom profile (symbol), the bounding box is used to calculate this value.
 
For Post: Width of the Posts cross section profile.
 
For Crossbar Top and Crossbar Bottom: Width of the profile of the crossbar.
 
For Bar Vertical and Bar Horizontal: Width of the vertical bars profile.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('Lambda')</big>
| colspan="3" | <big>Height()</big>
|-
|-
|  || valign="top" | Returns the Lambda value of the object.
|  || valign="top" | Height([optional parameter])
 
This function is applicable to the Railing object and the following subparts: Top Rail, Wall Bracket, Post, Face Mount, Frame, Panel.
 
OPTIONAL PARAMETER:
'subpart=...': If provided, only the given subpart is included.
 
QUANTITY DESCRIPTION:
For Railing object: The height of the railing, measured as the vertical distance between the top of the floor or stair (which is Height Point 1 in the object info palette) and the top of the highest subpart of the Railing (Top Rail if available, Frame, Panel or Crossbar Top).
This value is written into the IFC-field Pset_RailingCommon.Height.
 
For Top Rail: Height of the TopRail, measured as the distance between the top of the floor or stair (which is Height Point 1 in the object info palette) and the top of the Railings Top Rail.
 
For Wall Bracket: Vertical dimension of the Top Rails Wall Bracket.
 
For Post: Height of the Post.
 
For Face Mount: Vertical dimension of the Face Mount Post.
 
For Frame: Height of the rectangular frame.
 
For Panel: Height of the panel in elevation.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('RValue')</big>
| colspan="3" | <big>Height('profile')</big>
|-
|-
|  || valign="top" | Returns the R-Value of the object.
|  || valign="top" | Height('profile', [optional parameter])
 
This function is applicable to the following subparts: Top Rail, Post, Crossbar Top and Bottom, Bar Vertical and Horizontal, Frame.
 
OPTIONAL PARAMETER:
'subpart=...': If provided, only the given subpart is included.
 
QUANTITY DESCRIPTION:
For Top Rail: Height of the Railings TopRail cross section profile. For round or octagonal shape of profile, width equals height. For custom profile (symbol), the bounding box is used to calculate this value.
 
For Post: Height of the Posts cross section profile.
 
For Crossbar Top and Crossbar Bottom: Height of the profile of the crossbar.
 
For Bar Vertical and Bar Horizontal: Height of the vertical bars profile.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('RValue')</big>
| colspan="3" | <big>Count('angle')</big>
|-
|-
|  || valign="top" | Returns the R-Value of the object.
|  || valign="top" | Count('angle', [optional parameter])
 
This function is applicable to the Railing object and the Top Rail.
 
OPTIONAL PARAMETER:
'subpart=...': If provided, only the given subpart is included.
 
QUANTITY DESCRIPTION:
For Railing: Number of vertices that change the path without the beginning and end. Or IOW: the number of angles in the path..
 
For Top Rail: Number of angles  in the Top Rail subpart.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('UValue')</big>
| colspan="3" | <big>Angle()</big>
|-
|-
|  || valign="top" | Returns the U-Value of the object.
|  || valign="top" | Angle([optional parameter])
 
This function is applicable to the following subparts: Bar Vertical and Bar Horizontal.
 
OPTIONAL PARAMETER:
'subpart=...': If provided, only the given subpart is included.
 
QUANTITY DESCRIPTION:
For Bar Vertical: Angle of the vertical bars. Vertical is 0°.
 
For Bar Horizontal: Angle of the horizontal bar. horizontal is 0°.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('UValue')</big>
| colspan="3" | <big>Area()</big>
|-
|-
|  || valign="top" | Returns the U-Value of the object.
|  || valign="top" | Area([optional parameter])
 
This function is applicable to the Railing object and the Panel subpart.
 
OPTIONAL PARAMETER:
'subpart=...': If provided, only the given subpart is included.
 
QUANTITY DESCRIPTION:
For Railing: Area of the Railing object measured by Railing Length multiplied by Railing Height. Length is the distance between the outer edges of the first and last post or between the infills, whichever results in the higher value. Extended handrails are excluded. This Length differs from buildingSMART standard which is stored in the Railing objects record field RailingLengthIFC. The height of the railing is measured as the vertical distance between the top of the floor or stair (which is Height Point 1 in the object info palette) and the top of the highest subpart of the Railing (Top Rail if available, Frame, Panel or Crossbar Top).
 
For Panel: Area of the panel (Width x Height).
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Width()</big>
| colspan="3" | <big>Perimeter()</big>
|-
|-
|  || valign="top" | Returns the thickness of a wall, slab, roof or a roof face object or their components.
|  || valign="top" |  
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Width()</big>
| colspan="3" | <big>Length('')</big>
|-
|-
|  || valign="top" | Returns the thickness of a wall, slab, roof or a roof face object or their components.
|  || valign="top" | Length([optional parameter])
 
This function is applicable to the Railing object and the following subparts: Top Rail, Crossbar Top, Crossbar Bottom, Bar Vertical, Bar Horizontal, Frame.
 
OPTIONAL PARAMETER:
'subpart=...': If provided, only the given subpart is included.
 
QUANTITY DESCRIPTION:
For Railing object: It is the distance between the outer edges of the first and last post or between the infills, whichever results in the higher value. Extended handrails are excluded. This Length differs from buildingSMART standard which is stored in the Railing objects record field RailingLengthIFC and written into Qto_RailingBaseQuantities.Length and BaseQuantities.Length.
 
For Top Rail: Length of the 3D path object of the top rail including extensions of the Top Rail at beginning or end of the Railing object.
 
For Crossbar Top and Bottom: Length of the crossbar.
 
For Bar Vertical and Horizontal: Length of the bar.
 
For Frame: It is the same value as for Width when applied to a Frame.
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Angle('energos')</big>
| colspan="3" | <big>Length('max')</big>
|-
|-
|  || valign="top" | Get the orientation from the north used in the Energos calculations for this object.
|  || valign="top" | Maximum occuring distance between the axes of all instances of a subparts.
Eligible subparts are Wall Bracket, Post and Face Mount.
 
OPTIONAL PARAMETER:
'subpart=...': If provided, only the given subpart is included.
 
QUANTITY DESCRIPTION:
For Wall Bracket: Returns the maximum distance between the axes of all Wall Brackets occuring anywhere in the Railing object.
 
For Post: Maximum occuring distance between the axes of all posts.
 
For Face Mount: Maximum Distance between the axes of all Face Mounts.  
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Angle('energos')</big>
| colspan="3" | <big>SurfaceArea()</big>
|-
|-
|  || valign="top" | Get the orientation from the north used in the Energos calculations for this object.
|  || valign="top" | SurfaceArea([optional parameter])
 
This function is applicable to the following subparts: Top Rail, Wall Bracket, Post, Face Mount, Crossbar Top and Bottom, Bar Vertical and Horizontal, Frame, Panel.
 
OPTIONAL PARAMETER:
'subpart=...': If provided, only the given subpart is included.
 
QUANTITY DESCRIPTION:
For Top Rail: Outer surface of the top rail on all sides including the two caps at beginning and end.
 
For Wall Bracket: Complete outer surface of the Top Rails Wall Bracket.
 
For Post: Complete Outer Surface of the Post including the sides which face the stair or wall or handrail.
 
For Face Mount: Complete Outer Surface of the Face Mount Post including the caps surfaces which are mounted against a wall, post, stair or other object.
 
For Crossbar Top and Bottom: Complete Surface of all sides of the crossbar.
 
Bar Vertical and Horizontal: Complete Surface of all sides of the bar.
 
For Frame: Complete Surface of the rectangular frame.
 
For Panel: Complete surface area of all sides of the panel.
|-
|-
|  ||  
|  ||  
|}
== Specialized for Roof ==
{| border=0
| colspan="3" | <big>ObjectData('Component Name')</big>
|-
|-
| colspan="3" | <big>SlabThickness()</big>
| style="width: 10pt;" | || valign="top" | Returns the name of the wall, slab or roof component.
|-
|-
| || valign="top" | Returns the thickness of slab objects.
| style="width: 10pt;" | ||
|-
|-
| || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
| colspan="3" | <big>ObjectData('Cost Index Code')</big>
=SlabThickness returns the thickness for each object in the database
 
Spreadsheet cell:
=SlabThickness(PON=slab) returns the combined thickness of all slab objects in the drawing
</pre>
|-
|-
| colspan="3" | <big>SlabStyleName()</big>
| || valign="top" |  
|-
|-
|  || valign="top" | Returns the name of the slab style used by the slab.
|  ||  
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
| colspan="3" | <big>ObjectData('Cost Index System')</big>
=SlabStyleName returns the name of the slab style for each slab object in the database
 
Spreadsheet cell:
=SlabStyleName(n='slab-1') returns the name of the slab style for the object named “slab-1”
</pre>
|-
| colspan="3" | <big>Area()</big>
|-
|-
|  || valign="top" | Returns the area of a wall, slab, roof or a roof face object or their components.
|  || valign="top" |  
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Area()</big>
| colspan="3" | <big>ObjectData('Description')</big>
|-
|-
|  || valign="top" | Returns the area of a wall, slab, roof or a roof face object or their components.
|  || valign="top" |  
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Volume()</big>
| colspan="3" | <big>ObjectData('Exterior')</big>
|-
|-
|  || valign="top" | Returns the volume of a wall, slab, roof or a roof face object or their components.
|  || valign="top" |  
|-
|-
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Volume()</big>
| colspan="3" | <big>ObjectData('Fire Rating')</big>
|-
|-
|  || valign="top" | Returns the volume of a wall, slab, roof or a roof face object or their components.
|  || valign="top" |  
|-
|-
|  ||  
|  ||  
|}
== Specialized for Socket ==
{| border=0
| colspan="3" | <big>ObjectData('eval socket device', '<RecordName>', '<FieldName>')</big>
|-
|-
| style="width: 10pt;" |  || valign="top" | Get parameter value or attached record field from the socket's device.
| colspan="3" | <big>ObjectData('Function')</big>
|-
|  || valign="top" |  
|-
|  ||
|-
|-
| style="width: 10pt;" |  ||
| colspan="3" | <big>ObjectData('Lambda')</big>
|}
 
== Specialized for Space ==
 
{| border=0
| colspan="3" | <big>GetSpaceNameForObj()</big>
|-
|-
| style="width: 10pt;" |  || valign="top" | Returns the name of the space that surrounds the object.
|  || valign="top" | Returns the Lambda value of the object.
|-
|-
| style="width: 10pt;" |  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
|  ||  
=GetSpaceNameForObj returns the space name for each object in the database
 
Spreadsheet cell:
=GetSpaceNameForObj(n='chair-1') returns the space name for the object named “chair-1”
</pre>
|-
|-
| colspan="3" | <big>GetSpaceNumForObj()</big>
| colspan="3" | <big>ObjectData('Manufacturer')</big>
|-
|-
|  || valign="top" | Returns the number of the space that surrounds the object.
|  || valign="top" |  
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:=GetSpaceNumForObj returns the space number for each object in the database
|  ||  
 
|-
Spreadsheet cell:
| colspan="3" | <big>ObjectData('Mark')</big>
=GetSpaceNumForObj(n='chair-1') returns the space number for the object named “chair-1”</pre>
|}
 
== Specialized for Wall ==
 
{| border=0
| colspan="3" | <big>ObjectData('Component Name')</big>
|-
|-
| style="width: 10pt;" |  || valign="top" | Returns the name of the wall, slab or roof component.
|  || valign="top" |  
|-
|-
| style="width: 10pt;" |  ||  
|  ||  
|-
|-
| colspan="3" | <big>ObjectData('Lambda')</big>
| colspan="3" | <big>ObjectData('Model')</big>
|-
|-
|  || valign="top" | Returns the Lambda value of the object.
|  || valign="top" |  
|-
|-
|  ||  
|  ||  
Line 2,092: Line 2,317:
|  ||  
|  ||  
|-
|-
| colspan="3" | <big>Width()</big>
| colspan="3" | <big>RoofArea_Total()</big>
|-
|-
|  || valign="top" | Returns the thickness of a wall, slab, roof or a roof face object or their components.
|  || valign="top" | Returns the total area along the slope of a roof.
|-
|-
|  ||  
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=RoofArea_Total returns the total area for each roof and roof face object in the database
 
Spreadsheet cell:
=RoofArea_Total(st=roofface) returns the combined total area of all roof face objects in the drawing</pre>
|-
|-
| colspan="3" | <big>Height('average')</big>
| colspan="3" | <big>RoofArea_Heated()</big>
|-
|-
|  || valign="top" | Returns the average height of a wall, including wall peaks and different starting and ending heights.
|  || valign="top" | Returns the heated area along the slope of a roof.
The heated area is the area that does not include an overhang.
|-
|-
|  ||  
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=RoofArea_Heated returns the heated area for each roof and roof face object in the database
 
Spreadsheet cell:
=RoofArea_Heated (st=roofface) returns the combined heated area of all roof face objects in the drawing
</pre>
|-
|-
| colspan="3" | <big>Height('overall')</big>
| colspan="3" | <big>RoofArea_TotalProj()</big>
|-
|-
|  || valign="top" | Returns the overall height of a wall.
|  || valign="top" | Returns the total area of a roof projected on the active layer plane.
|-
|  ||
|-
| colspan="3" | <big>Angle('energos')</big>
|-
|  || valign="top" | Get the orientation from the north used in the Energos calculations for this object.
|-
|  ||
|-
| colspan="3" | <big>WallArea_Net()</big>
|-
|  || valign="top" | Returns the average of the net area of the interior and exterior face of the wall. The net area is adjusted for holes in the wall.
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=WallArea_Net returns the average of the net area of the interior and exterior face of the wall, for each wall in the database; the net area is adjusted for holes in the wall
=RoofArea_TotalProj returns the total area for each roof and roof face object in the database, as projected to the layer plane


Spreadsheet cell:
Spreadsheet cell:
=WallArea_Net(t=wall) returns the average of the net area of the interior and exterior face of the wall, combined for all walls in the drawing; the net area is adjusted for holes in the wall
=RoofArea_Totalproj(t=roof) returns the combined total area of all roof objects in the drawing, as projected to the layer plane
</pre>
</pre>
|-
|-
| colspan="3" | <big>WallArea_Gross()</big>
| colspan="3" | <big>RoofArea_HeatedProj()</big>
|-
|-
|  || valign="top" | Returns the average of the gross area of the interior and exterior face of the wall. The gross area ignores holes in the wall.
|  || valign="top" | Returns the heated area of a roof projected on the active layer plane.  
The heated area is the area that does not include an overhang.
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=WallArea_Gross returns the average of the gross area of the interior and exterior face of the wall, for each wall in the database; the gross area ignores holes in the wall
=RoofArea_HeatedProj returns the heated area for each roof and roof face object in the database, as projected to the layer plane


Spreadsheet cell:
Spreadsheet cell:
=WallArea_Gross(t=wall) returns the average of the gross area of the interior and exterior face of the wall, combined for all walls in the drawing; the gross area ignores holes in the wall
=RoofArea_HeatedProj (t=roof) returns the combined heated area of all roof objects in the drawing, as projected to the layer plane
</pre>
</pre>
|-
|-
| colspan="3" | <big>WallAverageHeight()</big>
| colspan="3" | <big>RoofStyleName()</big>
|-
|-
|  || valign="top" | Returns the average wall height of a wall, including wall peaks and different starting and ending heights.
|  || valign="top" | Returns the name the roof style used by the object.
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=WallAverageHeight returns the average height for each wall object in the database
=RoofStyleName returns the roof style name for each roof object in the database


Spreadsheet cell:
Spreadsheet cell:
=WallAverageHeight((t=wall)&(sel=true)) returns the average height of all walls that are selected in the drawing
=RoofStyleName(n='roof-1') returns the roof style name for the object named “roof-1”
</pre>
</pre>
|-
|}
| colspan="3" | <big>WallThickness()</big>
 
|-
== Specialized for Site Model ==
|  || valign="top" | Returns the thickness of the wall.
 
|-
{| border=0
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
| colspan="3" | <big>Depth()</big>
=WallThickness returns the thickness for each wall object in the database
|-
 
| style="width: 10pt;" |  || valign="top" | Calculate the depth of the Landscape Area, Hardscape, or Site Model and their components.
Spreadsheet cell:
|-
=WallThickness(t=wall) returns the combined thickness of all walls in the drawing
| style="width: 10pt;" |  ||  
</pre>
|-
|-
| colspan="3" | <big>ProjectedArea()</big>
| colspan="3" | <big>WallStyleName()</big>
|-
|-
|  || valign="top" | Calculate the projected area of the Landscape Area, Hardscape, or Site Model and their components.
|  || valign="top" | Returns the name of the wall style used by the wall.
|-
|-
|  ||
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
|-
=WallStyleName returns the name of the wall style for each wall object in the database
| colspan="3" | <big>ObjectData('component name')</big>
 
|-
Spreadsheet cell:
|  || valign="top" | Return the name of the component subpart for Landscape Area, Hardscape, and Site Model.
=WallStyleName(n='wall-1') returns the name of the wall style for the object named “wall-1”
|-
</pre>
|  ||
|-
|-
| colspan="3" | <big>Area()</big>
| colspan="3" | <big>Area()</big>
|-
|-
|  || valign="top" | Returns the area of a wall, slab, roof or a roof face object or their components.
|  || valign="top" | Calculate the surface area of the Landscape Area, Hardscape, or Site Model and their components.
|-
|-
|  ||  
|  ||
|-
|-
| colspan="3" | <big>Volume()</big>
| colspan="3" | <big>SurfaceArea()</big>
|-
|-
|  || valign="top" | Returns the volume of a wall, slab, roof or a roof face object or their components.
|  || valign="top" | Calculate the surface area of the Landscape Area, Hardscape, or Site Model and their components.
|-
|-
| ||  
|  ||  
|-
|-
| colspan="3" | <big>WallOverallHeight()</big>
| colspan="3" | <big>SurfaceArea( 'existing' )</big>
|-
|  || valign="top" | Calculate the existing surface area of the Site Model and their components.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=SURFACEAREA('Existing')    Returns the existing Surface Area for Site Model object or component in the DB row.
 
Spreadsheet cell:
=SURFACEAREA(SEL; 'Existing')   Returns the existing Surface Area for the selected Site Model object.
</pre>
|-
| colspan="3" | <big>SurfaceArea( 'proposed' )</big>
|-
|  || valign="top" | Calculate the proposed surface area of the Site Model and their components.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=SURFACEAREA('Proposed')    Returns the proposed Surface Area for Site Model object or component in the DB row.
 
Spreadsheet cell:
=SURFACEAREA(SEL; 'Proposed')    Returns the proposed Surface Area for the selected Site Model object.
</pre>
|-
| colspan="3" | <big>Volume()</big>
|-
|  || valign="top" | Calculate the volume of the Landscape Area, Hardscape, or Site Model and their components.
|-
|  ||
|-
| colspan="3" | <big>Volume('existing')</big>
|-
|  || valign="top" | Calculate the existing volume of the Site Model and their components.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=VOLUME('existing')    Returns the existing volume for Site Model object or component in the DB row.
 
Spreadsheet cell:
=VOLUME(SEL, 'existing')    Returns the existing volume for the selected Site Model object.
</pre>
|-
| colspan="3" | <big>Volume('proposed')</big>
|-
|  || valign="top" | Calculate the proposed volume of the Site Model and their components.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=VOLUME('proposed')    Returns the proposed volume for Site Model object or component in the DB row.
 
Spreadsheet cell:
=VOLUME(SEL, 'proposed')    Returns the proposed volume for the selected Site Model object.
</pre>
|}
 
== Specialized for Slab ==
 
{| border=0
| colspan="3" | <big>Weight('gross', [optional parameters])</big>
|-
| style="width: 10pt;" |  || valign="top" | Returns the weight of a slab or slab component in kg. All openings are ignored.
 
'component name=...': If provided, only openings in the components with the given name will be counted.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.
|-
| style="width: 10pt;" |  ||
|-
| colspan="3" | <big>Weight('net', [optional parameters])</big>
|-
|  || valign="top" | Returns the weight of a slab or slab component in kg.
 
'component name=...': If provided, only openings in the components with the given name will be counted.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Acoustic Rating')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Combustible Construction')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Compartmentation')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Component Name')</big>
|-
|  || valign="top" | Returns the name of the wall, slab or roof component.
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Cost Index Code')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Cost Index System')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Description')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Exterior')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Fire Rating')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Function')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Lambda')</big>
|-
|  || valign="top" | Returns the Lambda value of the object.
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Load Bearing')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Manufacturer')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Mark')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Model')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('RValue')</big>
|-
|  || valign="top" | Returns the R-Value of the object.
|-
|  ||
|-
| colspan="3" | <big>ObjectData('UValue')</big>
|-
|  || valign="top" | Returns the U-Value of the object.
|-
|  ||
|-
| colspan="3" | <big>Width()</big>
|-
|  || valign="top" | Returns the thickness of a wall, slab, roof or a roof face object or their components.
|-
|  ||
|-
| colspan="3" | <big>Count('modifiers', [optional parameters])</big>
|-
|  || valign="top" | Returns the number of modifiers in a slab or wall. For walls, recesses and projections are counted. For slabs, additions, subtractions and drains are counted.
 
'modifier type=...': If provided, only modifiers with any of the given types are counted. Multiple types can be delimited by a semicolon.
 
'exclude modifier type=...': If provided, modifiers with any of the given types will not be counted.
|-
|  ||
|-
| colspan="3" | <big>Count('openings', [optional parameters])</big>
|-
|  || valign="top" | Returns the number of openings in a wall, wall component, slab or slab component.
 
'component name=...': If provided, only openings in the components with the given name will be counted.
 
'component material=...': If provided, only openings in the components with the given material will be counted.
 
'component=...': If provided, only openings in the given components will be counted. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.
 
opening criteria: If provided, only openings that satisfy all given criteria will be counted. If the values don't have any units specified, millimeters, square millimeters or cubic millimeters will be assumed. For slabs, the following criteria are available: min opening area top, max opening area top, min opening area bottom, max opening area bottom, min opening volume, max opening volume, min opening perimeter top, max opening perimeter top, min opening perimeter bottom, max opening perimeter bottom. For walls, the following criteria are available: min opening area left, max opening area left, min opening area right, max opening area right, min opening area facing core, max opening area facing core, min opening area avert core, max opening area avert core, min opening area center, max opening area center, min opening area footprint, max opening area footprint, min opening length footprint left, max opening length footprint left, min opening length footprint right, max opening length footprint right, min opening length footprint facing core, max opening length footprint facing core, min opening length footprint avert core, max opening length footprint avert core, min opening length footprint center, max opening length footprint center, min opening volume, max opening volume.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon. Only applicable for walls.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted. Only applicable for walls.
 
'height=...': Specifies the height relative to the layer plane at which the footprint area and length along footprint criteria are measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=Count('openings') returns the number of openings in the wall, wall component, slab or slab component.
 
=Count('openings', 'min opening volume=10 cu cm') returns the number of openings with a volume of at least 10 cubic centimeters.
 
=Count('openings', 'min opening area top=0.5 sq m', 'max opening area top=1 sq m') returns the number of openings with an area between 0.5 and 1 square meter on the top of the slab or slab component.
 
=Count('openings', 'min opening area bottom=1 sq ft', 'max opening volume=10 cu in') returns the number of openings with an area of at least 1 square foot on the bottom of the slab or slab component and a volume of at most 10 cubic inches.
 
=Count('openings', 'opening type=Window') returns the number of openings created by "Window" plug-in objects.
 
=Count('openings', 'opening type=Window;WinDoor 6.0') returns the number of openings created by "Window" and "WinDoor 6.0" plug-in objects.
 
=Count('openings', 'component=core', 'min opening volume=10 cu cm') returns the number of openings with a volume of at least 10 cubic centimeters in the wall core component.
 
The difference between Count('inserts') and Count('openings') is that in the rare cases where two inserts share the same opening, Count('inserts') will treat them as different inserts, but Count('openings') will treat them as one large opening.</pre>
|-
| colspan="3" | <big>Angle('energos')</big>
|-
|  || valign="top" | Get the orientation from the north used in the Energos calculations for this object.
|-
|  ||
|-
| colspan="3" | <big>SlabThickness()</big>
|-
|  || valign="top" | Returns the thickness of slab objects.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=SlabThickness returns the thickness for each object in the database
 
Spreadsheet cell:
=SlabThickness(PON=slab) returns the combined thickness of all slab objects in the drawing
</pre>
|-
| colspan="3" | <big>SlabStyleName()</big>
|-
|  || valign="top" | Returns the name of the slab style used by the slab.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=SlabStyleName returns the name of the slab style for each slab object in the database
 
Spreadsheet cell:
=SlabStyleName(n='slab-1') returns the name of the slab style for the object named “slab-1”
</pre>
|-
| colspan="3" | <big>Area()</big>
|-
|  || valign="top" | Returns the area of a wall, slab, roof or a roof face object or their components.
|-
|  ||
|-
| colspan="3" | <big>Perim('bottom', [optional parameters])</big>
|-
|  || valign="top" | Returns the perimeter of the bottom surface of a slab or slab component.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are top, bottom or a number indicating the component index.
|-
|  ||
|-
| colspan="3" | <big>Perim('openings bottom', [optional parameters])</big>
|-
|  || valign="top" | Returns the sum of the opening perimeters on the bottom surface of a slab or slab component.
 
'component name=...': If provided, only openings in the components with the given name will be included.
 
'component material=...': If provided, only openings in the components with the given material will be included.
 
'component=...': If provided, only openings in the given components will be included. Possible values are top, bottom or a number indicating the component index.
 
'min opening perimeter=...' / 'max opening perimeter=...': If provided, only openings with a perimeter of at least min opening perimeter and at most max opening perimeter will be included. If the values don't have any units specified, millimeters will be assumed.
|-
|  ||
|-
| colspan="3" | <big>Perim('openings top', [optional parameters])</big>
|-
|  || valign="top" | Returns the sum of the opening perimeters on the top surface of a slab or slab component.
 
'component name=...': If provided, only openings in the components with the given name will be included.
 
'component material=...': If provided, only openings in the components with the given material will be included.
 
'component=...': If provided, only openings in the given components will be included. Possible values are top, bottom or a number indicating the component index.
 
'min opening perimeter=...' / 'max opening perimeter=...': If provided, only openings with a perimeter of at least min opening perimeter and at most max opening perimeter will be included. If the values don't have any units specified, millimeters will be assumed.
|-
|  ||
|-
| colspan="3" | <big>Perim('top', [optional parameters])</big>
|-
|  || valign="top" | Returns the perimeter of the top surface of a slab or slab component.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are top, bottom or a number indicating the component index.
|-
|  ||
|-
| colspan="3" | <big>SurfaceArea('bottom gross', [optional parameters])</big>
|-
|  || valign="top" | Returns the area of the bottom surface of a slab or slab component. All openings are ignored.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are top, bottom or a number indicating the component index.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('bottom gross') returns the gross area of the bottom face of the slab or slab component.
 
=SurfaceArea('bottom gross', 'component=top') returns the gross area of the bottom face of the top component of the slab.</pre>
|-
| colspan="3" | <big>SurfaceArea('bottom net', [optional parameters])</big>
|-
|  || valign="top" | Returns the area of the bottom surface of a slab or slab component.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are top, bottom or a number indicating the component index.
 
'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('bottom net') returns the area of the bottom face of the slab or slab component.
 
=SurfaceArea('bottom net', 'min opening area=0.5 sq m') returns the area of the bottom face of the slab or slab component, but ignoring any openings under 0.5 square meters.
 
=SurfaceArea('bottom net', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the area of the bottom face of the slab or slab component, but ignoring any openings under 0.5 square meters or over 1 square meter.
 
=SurfaceArea('bottom net', 'component=top') returns the area of the bottom face of the top component of the slab.</pre>
|-
| colspan="3" | <big>SurfaceArea('openings bottom', [optional parameters])</big>
|-
|  || valign="top" | Returns the area of the openings on the bottom surface of a slab or slab component.
 
'component name=...': If provided, only openings in the components with the given name will be included.
 
'component material=...': If provided, only openings in the components with the given material will be included.
 
'component=...': If provided, only openings in the given components will be included. Possible values are top, bottom or a number indicating the component index.
 
'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('openings bottom') returns the total area of openings on the bottom face of the slab or slab component.
 
=SurfaceArea('openings bottom', 'min opening area=0.5 sq m') returns the total area of openings on the bottom face of the slab or slab component, but ignoring any openings under 0.5 square meters.
 
=SurfaceArea('openings bottom', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the total area of openings on the bottom face of the slab or slab component, but ignoring any openings under 0.5 square meters or over 1 square meter.
 
=SurfaceArea('openings bottom', 'component=top') returns the total area of openings on the bottom face of the top component of the slab.</pre>
|-
| colspan="3" | <big>SurfaceArea('openings top', [optional parameters])</big>
|-
|  || valign="top" | Returns the area of the openings on the top surface of a slab or slab component.
 
'component name=...': If provided, only openings in the components with the given name will be included.
 
'component material=...': If provided, only openings in the components with the given material will be included.
 
'component=...': If provided, only openings in the given components will be included. Possible values are top, bottom or a number indicating the component index.
 
'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('openings top') returns the total area of openings on the top face of the slab or slab component.
 
=SurfaceArea('openings top', 'min opening area=0.5 sq m') returns the total area of openings on the top face of the slab or slab component, but ignoring any openings under 0.5 square meters.
 
=SurfaceArea('openings top', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the total area of openings on the top face of the slab or slab component, but ignoring any openings under 0.5 square meters or over 1 square meter.
 
=SurfaceArea('openings top', 'component=bottom') returns the total area of openings on the top face of the bottom component of the slab.</pre>
|-
| colspan="3" | <big>SurfaceArea('top gross', [optional parameters])</big>
|-
|  || valign="top" | Returns the area of the top surface of a slab or slab component. All openings are ignored.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are top, bottom or a number indicating the component index.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('top gross') returns the gross area of the top face of the slab or slab component.
 
=SurfaceArea('top gross', 'component=bottom') returns the gross area of the top face of the bottom component of the slab.</pre>
|-
| colspan="3" | <big>SurfaceArea('top net', [optional parameters])</big>
|-
|  || valign="top" | Returns the area of the top surface of a slab or slab component.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are top, bottom or a number indicating the component index.
 
'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('top net') returns the area of the top face of the slab or slab component.
 
=SurfaceArea('top net', 'min opening area=0.5 sq m') returns the area of the top face of the slab or slab component, but ignoring any openings under 0.5 square meters.
 
=SurfaceArea('top net', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the area of the top face of the slab or slab component, but ignoring any openings under 0.5 square meters or over 1 square meter.
 
=SurfaceArea('top net', 'component=bottom') returns the area of the top face of the bottom component of the slab.</pre>
|-
| colspan="3" | <big>Volume()</big>
|-
|  || valign="top" | Returns the volume of a wall, slab, roof or a roof face object or their components.
|-
|  ||
|-
| colspan="3" | <big>Volume('gross', [optional parameters])</big>
|-
|  || valign="top" | Returns the volume of a wall, wall component, slab or slab component. All openings are ignored.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=Volume('gross') returns the gross volume of the wall, wall component, slab or slab component.
 
=Volume('gross', 'component=core') returns the gross volume of the core wall component.</pre>
|-
| colspan="3" | <big>Volume('net', [optional parameters])</big>
|-
|  || valign="top" | Returns the volume of a wall, wall component, slab or slab component.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.
 
'min opening volume=...' / 'max opening volume=...': If provided, only openings with a volume of at least min opening volume and at most max opening volume will be included. If the values don't have any units specified, cubic millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon. Only applicable for walls.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted. Only applicable for walls.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=Volume('net') returns the volume of the wall, wall component, slab or slab component.
 
=Volume('net', 'min opening volume=10 cu cm') returns the volume of the wall, wall component, slab or slab component, but only taking openings with at least 10 cubic centimeters of volume into account.
 
=Volume('net', 'min opening volume=10 cu cm', 'max opening volume=1 cu m') returns the volume of the wall, wall component, slab or slab component, but only taking openings with between 10 cubic centimeters and 1 cubic meter of volume into account.
 
=Volume('net', 'opening type=Window') returns the volume of the wall or wall component, but only taking openings created by "Window" plug-in objects into account.
 
=Volume('net', 'opening type=Window;WinDoor 6.0') returns the volume of the wall or wall component, but only taking openings created by "Window" and "WinDoor 6.0" plug-in objects into account.
 
=Volume('net', 'component=core', 'min opening volume=10 cu cm') returns the volume of the core wall component, but only taking openings with a volume of at least 10 cubic centimeters into account.</pre>
|-
| colspan="3" | <big>Volume('openings', [optional parameters])</big>
|-
|  || valign="top" | Returns the volume of the openings in a wall, wall component, slab or slab component.
 
'component name=...': If provided, only openings in the components with the given name will be included.
 
'component material=...': If provided, only openings in the components with the given material will be included.
 
'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.
 
'min opening volume=...' / 'max opening volume=...': If provided, only openings with a volume of at least min opening volume and at most max opening volume will be included. If the values don't have any units specified, cubic millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon. Only applicable for walls.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted. Only applicable for walls.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=Volume('openings') returns the total volume of openings in the wall, wall component, slab or slab component.
 
=Volume('openings', 'min opening volume=10 cu cm') returns the total volume of openings with a volume of at least 10 cubic centimeters.
 
=Volume('openings', 'min opening volume=10 cu cm', 'max opening volume=1 cu m') returns the total volume of openings with a volume of at least 10 cubic centimeters and at most 1 cubic meter.
 
=Volume('openings', 'opening type=Window') returns the total volume of openings created by "Window" plug-in objects.
 
=Volume('openings', 'opening type=Window;WinDoor 6.0') returns the total volume of openings created by "Window" and "WinDoor 6.0" plug-in objects.
 
=Volume('openings', 'component=core', 'min opening volume=10 cu cm') returns the total volume of openings with a volume of at least 10 cubic centimeters in the wall core component.</pre>
|}
 
== Specialized for Socket ==
 
{| border=0
| colspan="3" | <big>ObjectData('eval socket circuits', '<RecordName>', '<FieldName>')</big>
|-
| style="width: 10pt;" |  || valign="top" | Get parameter values or attached record fields from the socket's connected circuits.
|-
| style="width: 10pt;" |  ||
|-
| colspan="3" | <big>ObjectData('eval socket device', '<RecordName>', '<FieldName>')</big>
|-
|  || valign="top" | Get parameter value or attached record field from the socket's device.
|-
|  ||
|}
 
== Specialized for Space ==
 
{| border=0
| colspan="3" | <big>GetSpaceNameForObj()</big>
|-
| style="width: 10pt;" |  || valign="top" | Returns the name of the space that surrounds the object.
|-
| style="width: 10pt;" |  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=GetSpaceNameForObj returns the space name for each object in the database
 
Spreadsheet cell:
=GetSpaceNameForObj(n='chair-1') returns the space name for the object named “chair-1”
</pre>
|-
| colspan="3" | <big>GetSpaceNumForObj()</big>
|-
|  || valign="top" | Returns the number of the space that surrounds the object.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=GetSpaceNumForObj returns the space number for each object in the database
 
Spreadsheet cell:
=GetSpaceNumForObj(n='chair-1') returns the space number for the object named “chair-1”</pre>
|}
 
== Specialized for Structural Member ==
 
{| border=0
| colspan="3" | <big>ObjectData(criteria, 'cover bound bottom')</big>
|-
| style="width: 10pt;" |  || valign="top" | Returns the bottom bound of the structural member cover.
|-
| style="width: 10pt;" |  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=OBJECTDATA('cover bound bottom')    Returns the bottom bound of the Structural Member cover.
 
Spreadsheet cell:
=OBJECTDATA(SEL; 'cover bound bottom')    Returns the bottom bound of the Structural Member cover.
</pre>
|-
| colspan="3" | <big>ObjectData(criteria, 'cover bound top')</big>
|-
|  || valign="top" | Returns the top bound of the Structural Member cover.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=OBJECTDATA('cover bound top')    Returns the top bound of the Structural Member cover.
 
Spreadsheet cell:
=OBJECTDATA(SEL; 'cover bound top')    Returns the top bound of the Structural Member cover.
</pre>
|-
| colspan="3" | <big>ObjectData(criteria, 'cover physical length')</big>
|-
|  || valign="top" | Returns the physical length of the structural member cover including its start and end conditions.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=OBJECTDATA('cover physical length')    Returns the physical length of the structural member cover including its start and end conditions.
 
Spreadsheet cell:
=OBJECTDATA(SEL; 'cover physical length')    Returns the physical length of the structural member cover including its start and end conditions.
</pre>
|-
| colspan="3" | <big>ObjectData(criteria, 'member bound bottom')</big>
|-
|  || valign="top" | Returns the bottom bound of the Structural Member.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=OBJECTDATA('member bound bottom')    Returns the bottom bound of the Structural Member.
 
Spreadsheet cell:
=OBJECTDATA(SEL; 'member bound bottom')    Returns the bottom bound of the Structural Member.
</pre>
|-
| colspan="3" | <big>ObjectData(criteria, 'member bound top')</big>
|-
|  || valign="top" | Returns the top bound of the Structural Member.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=OBJECTDATA('member bound top')    Returns the top bound of the Structural Member.
 
Spreadsheet cell:
=OBJECTDATA(SEL; 'member bound top')    Returns the top bound of the Structural Member.
</pre>
|-
| colspan="3" | <big>ObjectData(criteria, 'member physical length')</big>
|-
|  || valign="top" | Returns the physical length of the structural member including its start and end conditions.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=OBJECTDATA('member physical length')    Returns the physical length of the structural member including its start and end conditions.
 
Spreadsheet cell:
=OBJECTDATA(SEL; 'member physical length')    Returns the physical length of the structural member including its start and end conditions.
</pre>
|}
 
== Specialized for Wall ==
 
{| border=0
| colspan="3" | <big>Weight('gross', [optional parameters])</big>
|-
| style="width: 10pt;" |  || valign="top" | Returns the weight of a slab or slab component in kg. All openings are ignored.
 
'component name=...': If provided, only openings in the components with the given name will be counted.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.
|-
| style="width: 10pt;" |  ||
|-
| colspan="3" | <big>Weight('net', [optional parameters])</big>
|-
|  || valign="top" | Returns the weight of a slab or slab component in kg.
 
'component name=...': If provided, only openings in the components with the given name will be counted.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.
|-
|  ||
|-
| colspan="3" | <big>FootPrintArea('gross', [optional parameters])</big>
|-
|  || valign="top" | Returns the footprint area of a wall or wall component. All openings are ignored.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'height=...': Specifies the height relative to the layer plane at which the area is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|  ||
|-
| colspan="3" | <big>FootPrintArea('net', [optional parameters])</big>
|-
|  || valign="top" | Returns the footprint area of a wall or wall component.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
 
'height=...': Specifies the height relative to the layer plane at which the area is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|  ||
|-
| colspan="3" | <big>FootPrintArea('openings', [optional parameters])</big>
|-
|  || valign="top" | Returns the area of the openings in the footprint of a wall or wall component.
 
'component name=...': If provided, only openings in the components with the given name will be included.
 
'component material=...': If provided, only openings in the components with the given material will be included.
 
'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
 
'height=...': Specifies the height relative to the layer plane at which the area is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Acoustic Rating')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Combustible Construction')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Compartmentation')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Component Name')</big>
|-
|  || valign="top" | Returns the name of the wall, slab or roof component.
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Cost Index Code')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Cost Index System')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Description')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Exterior')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Fire Rating')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Function')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Lambda')</big>
|-
|  || valign="top" | Returns the Lambda value of the object.
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Load Bearing')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Manufacturer')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Mark')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Model')</big>
|-
|  || valign="top" |
|-
|  ||
|-
| colspan="3" | <big>ObjectData('Path Type')</big>
|-
|  || valign="top" | Returns the path type of a wall. 0 is line, and 1 is arc.
|-
|  ||
|-
| colspan="3" | <big>ObjectData('RValue')</big>
|-
|  || valign="top" | Returns the R-Value of the object.
|-
|  ||
|-
| colspan="3" | <big>ObjectData('UValue')</big>
|-
|  || valign="top" | Returns the U-Value of the object.
|-
|  ||
|-
| colspan="3" | <big>Width()</big>
|-
|  || valign="top" | Returns the thickness of a wall, slab, roof or a roof face object or their components.
|-
|  ||
|-
| colspan="3" | <big>Height('average')</big>
|-
|  || valign="top" | Returns the average height of a wall, including wall peaks and different starting and ending heights.
|-
|  ||
|-
| colspan="3" | <big>Height('overall')</big>
|-
|  || valign="top" | Returns the overall height of a wall.
|-
|  ||
|-
| colspan="3" | <big>Count('inserts', [optional parameters])</big>
|-
|  || valign="top" | Returns the number of inserts (symbols and parametric objects) in a wall.
 
'insert type=...': If provided, only inserts with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude insert type=...': If provided, inserts with any of the given types will not be counted.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=Count('inserts') returns the number of inserts in the wall object.
 
=Count('inserts', 'opening type=Window') returns the number of "Window" plug-in object inserts.
 
=Count('inserts', 'opening type=Window;WinDoor 6.0') returns the number of by "Window" and "WinDoor 6.0" plug-in object inserts.
 
The difference between Count('inserts') and Count('openings') is that in the rare cases where two inserts share the same opening, Count('inserts') will treat them as different inserts, but Count('openings') will treat them as one large opening.</pre>
|-
| colspan="3" | <big>Count('modifiers', [optional parameters])</big>
|-
|  || valign="top" | Returns the number of modifiers in a slab or wall. For walls, recesses and projections are counted. For slabs, additions, subtractions and drains are counted.
 
'modifier type=...': If provided, only modifiers with any of the given types are counted. Multiple types can be delimited by a semicolon.
 
'exclude modifier type=...': If provided, modifiers with any of the given types will not be counted.
|-
|  ||
|-
| colspan="3" | <big>Count('openings', [optional parameters])</big>
|-
|  || valign="top" | Returns the number of openings in a wall, wall component, slab or slab component.
 
'component name=...': If provided, only openings in the components with the given name will be counted.
 
'component material=...': If provided, only openings in the components with the given material will be counted.
 
'component=...': If provided, only openings in the given components will be counted. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.
 
opening criteria: If provided, only openings that satisfy all given criteria will be counted. If the values don't have any units specified, millimeters, square millimeters or cubic millimeters will be assumed. For slabs, the following criteria are available: min opening area top, max opening area top, min opening area bottom, max opening area bottom, min opening volume, max opening volume, min opening perimeter top, max opening perimeter top, min opening perimeter bottom, max opening perimeter bottom. For walls, the following criteria are available: min opening area left, max opening area left, min opening area right, max opening area right, min opening area facing core, max opening area facing core, min opening area avert core, max opening area avert core, min opening area center, max opening area center, min opening area footprint, max opening area footprint, min opening length footprint left, max opening length footprint left, min opening length footprint right, max opening length footprint right, min opening length footprint facing core, max opening length footprint facing core, min opening length footprint avert core, max opening length footprint avert core, min opening length footprint center, max opening length footprint center, min opening volume, max opening volume.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon. Only applicable for walls.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted. Only applicable for walls.
 
'height=...': Specifies the height relative to the layer plane at which the footprint area and length along footprint criteria are measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=Count('openings') returns the number of openings in the wall, wall component, slab or slab component.
 
=Count('openings', 'min opening volume=10 cu cm') returns the number of openings with a volume of at least 10 cubic centimeters.
 
=Count('openings', 'min opening area top=0.5 sq m', 'max opening area top=1 sq m') returns the number of openings with an area between 0.5 and 1 square meter on the top of the slab or slab component.
 
=Count('openings', 'min opening area bottom=1 sq ft', 'max opening volume=10 cu in') returns the number of openings with an area of at least 1 square foot on the bottom of the slab or slab component and a volume of at most 10 cubic inches.
 
=Count('openings', 'opening type=Window') returns the number of openings created by "Window" plug-in objects.
 
=Count('openings', 'opening type=Window;WinDoor 6.0') returns the number of openings created by "Window" and "WinDoor 6.0" plug-in objects.
 
=Count('openings', 'component=core', 'min opening volume=10 cu cm') returns the number of openings with a volume of at least 10 cubic centimeters in the wall core component.
 
The difference between Count('inserts') and Count('openings') is that in the rare cases where two inserts share the same opening, Count('inserts') will treat them as different inserts, but Count('openings') will treat them as one large opening.</pre>
|-
| colspan="3" | <big>Angle('energos')</big>
|-
|  || valign="top" | Get the orientation from the north used in the Energos calculations for this object.
|-
|  ||
|-
| colspan="3" | <big>WallArea_Net()</big>
|-
|  || valign="top" | Returns the average of the net area of the interior and exterior face of the wall. The net area is adjusted for holes in the wall.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=WallArea_Net returns the average of the net area of the interior and exterior face of the wall, for each wall in the database; the net area is adjusted for holes in the wall
 
Spreadsheet cell:
=WallArea_Net(t=wall) returns the average of the net area of the interior and exterior face of the wall, combined for all walls in the drawing; the net area is adjusted for holes in the wall
</pre>
|-
| colspan="3" | <big>WallArea_Gross()</big>
|-
|  || valign="top" | Returns the average of the gross area of the interior and exterior face of the wall. The gross area ignores holes in the wall.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=WallArea_Gross returns the average of the gross area of the interior and exterior face of the wall, for each wall in the database; the gross area ignores holes in the wall
 
Spreadsheet cell:
=WallArea_Gross(t=wall) returns the average of the gross area of the interior and exterior face of the wall, combined for all walls in the drawing; the gross area ignores holes in the wall
</pre>
|-
| colspan="3" | <big>WallAverageHeight()</big>
|-
|  || valign="top" | Returns the average wall height of a wall, including wall peaks and different starting and ending heights.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=WallAverageHeight returns the average height for each wall object in the database
 
Spreadsheet cell:
=WallAverageHeight((t=wall)&(sel=true)) returns the average height of all walls that are selected in the drawing
</pre>
|-
| colspan="3" | <big>WallThickness()</big>
|-
|  || valign="top" | Returns the thickness of the wall.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=WallThickness returns the thickness for each wall object in the database
 
Spreadsheet cell:
=WallThickness(t=wall) returns the combined thickness of all walls in the drawing
</pre>
|-
| colspan="3" | <big>WallStyleName()</big>
|-
|  || valign="top" | Returns the name of the wall style used by the wall.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">Database header cell:
=WallStyleName returns the name of the wall style for each wall object in the database
 
Spreadsheet cell:
=WallStyleName(n='wall-1') returns the name of the wall style for the object named “wall-1”
</pre>
|-
| colspan="3" | <big>Area()</big>
|-
|  || valign="top" | Returns the area of a wall, slab, roof or a roof face object or their components.
|-
|  ||
|-
| colspan="3" | <big>Length()</big>
|-
|  || valign="top" | Returns the length of a wall or its components.
|-
|  ||
|-
| colspan="3" | <big>Length('control line avert core', [optional parameters])</big>
|-
|  || valign="top" | Returns the length of the control line of a wall component on the side that's oriented away from the core component. All openings, recesses, projections and peaks are ignored.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
|-
|  ||
|-
| colspan="3" | <big>Length('control line center', [optional parameters])</big>
|-
|  || valign="top" | Returns the length of the central control line of a wall or wall component. All openings, recesses, projections and peaks are ignored.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
|-
|  ||
|-
| colspan="3" | <big>Length('control line facing core', [optional parameters])</big>
|-
|  || valign="top" | Returns the length of the control line of a wall component on the side that's oriented towards the core component. All openings, recesses, projections and peaks are ignored.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
|-
|  ||
|-
| colspan="3" | <big>Length('control line left', [optional parameters])</big>
|-
|  || valign="top" | Returns the length of the left control line of a wall or wall component. All openings, recesses, projections and peaks are ignored.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
|-
|  ||
|-
| colspan="3" | <big>Length('control line right', [optional parameters])</big>
|-
|  || valign="top" | Returns the length of the right control line of a wall or wall component. All openings, recesses, projections and peaks are ignored.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
|-
|  ||
|-
| colspan="3" | <big>Length('avert core gross', [optional parameters])</big>
|-
|  || valign="top" | Returns the length of a wall component along the bottom of the side that's oriented away from the core component. All openings are ignored.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|  ||
|-
| colspan="3" | <big>Length('avert core net', [optional parameters])</big>
|-
|  || valign="top" | Returns the length of a wall component along the bottom of the side that's oriented away from the core component.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
 
'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|  ||
|-
| colspan="3" | <big>Length('center gross', [optional parameters])</big>
|-
|  || valign="top" | Returns the length of a wall or wall component along the bottom of the center line. All openings are ignored.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|  ||
|-
| colspan="3" | <big>Length('center net', [optional parameters])</big>
|-
|  || valign="top" | Returns the length of a wall or wall component along the bottom of the center line.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
 
'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|  ||
|-
| colspan="3" | <big>Length('facing core gross', [optional parameters])</big>
|-
|  || valign="top" | Returns the length of a wall component along the bottom of the side that's oriented towards the core component. All openings are ignored.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|  ||
|-
| colspan="3" | <big>Length('facing core net', [optional parameters])</big>
|-
|  || valign="top" | Returns the length of a wall component along the bottom of the side that's oriented towards the core component.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
 
'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|  ||
|-
| colspan="3" | <big>Length('left gross', [optional parameters])</big>
|-
|  || valign="top" | Returns the length of a wall or wall component along the bottom of the left face. All openings are ignored.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|  ||
|-
| colspan="3" | <big>Length('left net', [optional parameters])</big>
|-
|  || valign="top" | Returns the length of a wall or wall component along the bottom of the left face.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
 
'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|  ||
|-
| colspan="3" | <big>Length('right gross', [optional parameters])</big>
|-
|  || valign="top" | Returns the length of a wall or wall component along the bottom of the right face. All openings are ignored.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|  ||
|-
| colspan="3" | <big>Length('right net', [optional parameters])</big>
|-
|  || valign="top" | Returns the length of a wall or wall component along the bottom of the right face.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
 
'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|  ||
|-
| colspan="3" | <big>Length('openings avert core', [optional parameters])</big>
|-
|  || valign="top" | Returns the total length of wall or wall component openings along the side of the footprint that's oriented away from the core component.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only openings in the components with the given material will be included.
 
'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
 
'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|  ||
|-
| colspan="3" | <big>Length('openings center', [optional parameters])</big>
|-
|  || valign="top" | Returns the total length of openings along the center line of the footprint of a wall or wall component.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only openings in the components with the given material will be included.
 
'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
 
'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|  ||
|-
| colspan="3" | <big>Length('openings facing core', [optional parameters])</big>
|-
|  || valign="top" | Returns the total length of wall or wall component openings along the side of the footprint that's oriented towards the core component.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only openings in the components with the given material will be included.
 
'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
 
'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|  ||
|-
| colspan="3" | <big>Length('openings left', [optional parameters])</big>
|-
|  || valign="top" | Returns the total length of openings along the left side of the footprint of a wall or wall component.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only openings in the components with the given material will be included.
 
'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
 
'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|  ||
|-
| colspan="3" | <big>Length('openings right', [optional parameters])</big>
|-
|  || valign="top" | Returns the total length of openings along the right side of the footprint of a wall or wall component.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only openings in the components with the given material will be included.
 
'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
 
'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.
|-
|  ||
|-
| colspan="3" | <big>SurfaceArea('avert core gross', [optional parameters])</big>
|-
|  || valign="top" | Returns the area of a wall component's surface that's oriented away from the core component. All openings are ignored.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
|-
|  ||
|-
| colspan="3" | <big>SurfaceArea('avert core net', [optional parameters])</big>
|-
|  || valign="top" | Returns the area of a wall component's surface that's oriented away from the core component.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
|-
|  ||
|-
| colspan="3" | <big>SurfaceArea('center gross', [optional parameters])</big>
|-
|  || valign="top" | Returns the area along the center line of a wall or wall component. All openings are ignored.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('center gross') returns the gross area along the center line of the wall or wall component.
 
=SurfaceArea('center gross', 'component=core') returns the gross area along the center line of the core component of the wall.</pre>
|-
| colspan="3" | <big>SurfaceArea('center net', [optional parameters])</big>
|-
|  || valign="top" | Returns the area along the center line of a wall or wall component.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('center net') returns the area along the center line of the wall or wall component.
 
=SurfaceArea('center net', 'min opening area=0.5 sq m') returns the area along the center line of the wall or wall component, but ignoring any openings under 0.5 square meters.
 
=SurfaceArea('center net', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the area along the center line of the wall or wall component, but ignoring any openings under 0.5 square meters or over 1 square meter.
 
=SurfaceArea('center net', 'opening type=Window') returns the area along the center line of the wall or wall component, but only taking openings created by "Window" plug-in objects into account.
 
=SurfaceArea('center net', 'exclude opening type=Window') returns the area along the center line of the wall or wall component, but ignoring any openings that are created by "Window" plug-in objects.
 
=SurfaceArea('center net', 'opening type=Window;WinDoor 6.0') returns the area along the center line of the wall or wall component, but only taking openings created by "Window" or "WinDoor 6.0" plug-in objects into account.
 
=SurfaceArea('center net', 'component=core') returns the area along the center line of the core component of the wall.</pre>
|-
| colspan="3" | <big>SurfaceArea('facing core gross', [optional parameters])</big>
|-
|  || valign="top" | Returns the area of a wall component's surface that's oriented towards the core component. All openings are ignored.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
|-
|  ||
|-
| colspan="3" | <big>SurfaceArea('facing core net', [optional parameters])</big>
|-
|  || valign="top" | Returns the area of a wall component's surface that's oriented towards the core component.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
|-
|  ||
|-
| colspan="3" | <big>SurfaceArea('left gross', [optional parameters])</big>
|-
|  || valign="top" | Returns the area of the left surface of a wall or wall component. All openings are ignored.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('left gross') returns the gross area of the left side of the wall or wall component.
 
=SurfaceArea('left gross', 'component=core') returns the gross area of the left side of the core component of the wall.</pre>
|-
| colspan="3" | <big>SurfaceArea('left net', [optional parameters])</big>
|-
|  || valign="top" | Returns the area of the left surface of a wall or wall component.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('left net') returns the area of the left side of the wall or wall component.
 
=SurfaceArea('left net', 'min opening area=0.5 sq m') returns the area of the left side of the wall or wall component, but ignoring any openings under 0.5 square meters.
 
=SurfaceArea('left net', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the area of the left side of the wall or wall component, but ignoring any openings under 0.5 square meters or over 1 square meter.
 
=SurfaceArea('left net', 'opening type=Window') returns the area of the left side of the wall or wall component, but only taking openings created by "Window" plug-in objects into account.
 
=SurfaceArea('left net', 'exclude opening type=Window') returns the area of the left side of the wall or wall component, but ignoring any openings that are created by "Window" plug-in objects.
 
=SurfaceArea('left net', 'opening type=Window;WinDoor 6.0') returns the area of the left side of the wall or wall component, but only taking openings created by "Window" or "WinDoor 6.0" plug-in objects into account.
 
=SurfaceArea('left net', 'component=core') returns the area of the left side of the core component of the wall.</pre>
|-
| colspan="3" | <big>SurfaceArea('openings avert core', [optional parameters])</big>
|-
|  || valign="top" | Returns the area of the openings on a wall component's surface that's oriented away from the core component.
 
'component name=...': If provided, only openings in the components with the given name will be included.
 
'component material=...': If provided, only openings in the components with the given material will be included.
 
'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
|-
|  ||
|-
| colspan="3" | <big>SurfaceArea('openings center', [optional parameters])</big>
|-
|  || valign="top" | Returns the area of the openings along the center line of a wall or wall component.
 
'component name=...': If provided, only openings in the components with the given name will be included.
 
'component material=...': If provided, only openings in the components with the given material will be included.
 
'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('openings center') returns the total area of openings along the center line of the wall or wall component.
 
=SurfaceArea('openings center', 'min opening area=0.5 sq m') returns the total area of openings along the center line of the wall or wall component, but ignoring any openings under 0.5 square meters.
 
=SurfaceArea('openings center', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the total area of openings along the center line of the wall or wall component, but ignoring any openings under 0.5 square meters or over 1 square meter.
 
=SurfaceArea('openings center', 'opening type=Window') returns the total area of openings along the center line of the wall or wall component, but only taking openings created by "Window" plug-in objects into account.
 
=SurfaceArea('openings center', 'exclude opening type=Window') returns the total area of openings along the center line of the wall or wall component, but ignoring any openings that are created by "Window" plug-in objects.
 
=SurfaceArea('openings center', 'opening type=Window;WinDoor 6.0') returns the total area of openings along the center line of the wall or wall component, but only taking openings created by "Window" or "WinDoor 6.0" plug-in objects into account.
 
=SurfaceArea('openings center', 'component=core') returns the total area of openings along the center line of the core component of the wall.</pre>
|-
| colspan="3" | <big>SurfaceArea('openings facing core', [optional parameters])</big>
|-
|  || valign="top" | Returns the area of the openings on a wall component's surface that's oriented towards the core component.
 
'component name=...': If provided, only openings in the components with the given name will be included.
 
'component material=...': If provided, only openings in the components with the given material will be included.
 
'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
|-
|  ||
|-
| colspan="3" | <big>SurfaceArea('openings left', [optional parameters])</big>
|-
|  || valign="top" | Returns the area of the openings on the left surface of a wall or wall component.
 
'component name=...': If provided, only openings in the components with the given name will be included.
 
'component material=...': If provided, only openings in the components with the given material will be included.
 
'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('openings left') returns the total area of openings on the left side of the wall or wall component.
 
=SurfaceArea('openings left', 'min opening area=0.5 sq m') returns the total area of openings on the left side of the wall or wall component, but ignoring any openings under 0.5 square meters.
 
=SurfaceArea('openings left', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the total area of openings on the left side of the wall or wall component, but ignoring any openings under 0.5 square meters or over 1 square meter.
 
=SurfaceArea('openings left', 'opening type=Window') returns the total area of openings on the left side of the wall or wall component, but only taking openings created by "Window" plug-in objects into account.
 
=SurfaceArea('openings left', 'exclude opening type=Window') returns the total area of openings on the left side of the wall or wall component, but ignoring any openings that are created by "Window" plug-in objects.
 
=SurfaceArea('openings left', 'opening type=Window;WinDoor 6.0') returns the total area of openings on the left side of the wall or wall component, but only taking openings created by "Window" or "WinDoor 6.0" plug-in objects into account.
 
=SurfaceArea('openings left', 'component=core') returns the total area of openings on the left side of the core component of the wall.</pre>
|-
| colspan="3" | <big>SurfaceArea('openings right', [optional parameters])</big>
|-
|  || valign="top" | Returns the area of the openings on the right surface of a wall or wall component.
 
'component name=...': If provided, only openings in the components with the given name will be included.
 
'component material=...': If provided, only openings in the components with the given material will be included.
 
'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('openings right') returns the total area of openings on the right side of the wall or wall component.
 
=SurfaceArea('openings right', 'min opening area=0.5 sq m') returns the total area of openings on the right side of the wall or wall component, but ignoring any openings under 0.5 square meters.
 
=SurfaceArea('openings right', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the total area of openings on the right side of the wall or wall component, but ignoring any openings under 0.5 square meters or over 1 square meter.
 
=SurfaceArea('openings right', 'opening type=Window') returns the total area of openings on the right side of the wall or wall component, but only taking openings created by "Window" plug-in objects into account.
 
=SurfaceArea('openings right', 'exclude opening type=Window') returns the total area of openings on the right side of the wall or wall component, but ignoring any openings that are created by "Window" plug-in objects.
 
=SurfaceArea('openings right', 'opening type=Window;WinDoor 6.0') returns the total area of openings on the right side of the wall or wall component, but only taking openings created by "Window" or "WinDoor 6.0" plug-in objects into account.
 
=SurfaceArea('openings right', 'component=core') returns the total area of openings on the right side of the core component of the wall.</pre>
|-
| colspan="3" | <big>SurfaceArea('right gross', [optional parameters])</big>
|-
|  || valign="top" | Returns the area of the right surface of a wall or wall component. All openings are ignored.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('right gross') returns the gross area of the right side of the wall or wall component.
 
=SurfaceArea('right gross', 'component=core') returns the gross area of the right side of the core component of the wall.</pre>
|-
| colspan="3" | <big>SurfaceArea('right net', [optional parameters])</big>
|-
|  || valign="top" | Returns the area of the right surface of a wall or wall component.
 
'component name=...': If provided, components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.
 
'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=SurfaceArea('right net') returns the area of the right side of the wall or wall component.
 
=SurfaceArea('right net', 'min opening area=0.5 sq m') returns the area of the right side of the wall or wall component, but ignoring any openings under 0.5 square meters.
 
=SurfaceArea('right net', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the area of the right side of the wall or wall component, but ignoring any openings under 0.5 square meters or over 1 square meter.
 
=SurfaceArea('right net', 'opening type=Window') returns the area of the right side of the wall or wall component, but only taking openings created by "Window" plug-in objects into account.
 
=SurfaceArea('right net', 'exclude opening type=Window') returns the area of the right side of the wall or wall component, but ignoring any openings that are created by "Window" plug-in objects.
 
=SurfaceArea('right net', 'opening type=Window;WinDoor 6.0') returns the area of the right side of the wall or wall component, but only taking openings created by "Window" or "WinDoor 6.0" plug-in objects into account.
 
=SurfaceArea('right net', 'component=core') returns the area of the right side of the core component of the wall.</pre>
|-
| colspan="3" | <big>Volume()</big>
|-
|  || valign="top" | Returns the volume of a wall, slab, roof or a roof face object or their components.
|-
|  ||
|-
| colspan="3" | <big>Volume('gross', [optional parameters])</big>
|-
|  || valign="top" | Returns the volume of a wall, wall component, slab or slab component. All openings are ignored.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=Volume('gross') returns the gross volume of the wall, wall component, slab or slab component.
 
=Volume('gross', 'component=core') returns the gross volume of the core wall component.</pre>
|-
| colspan="3" | <big>Volume('net', [optional parameters])</big>
|-
|  || valign="top" | Returns the volume of a wall, wall component, slab or slab component.
 
'component name=...': If provided, only components with the given name will be included.
 
'component material=...': If provided, only components with the given material will be included.
 
'component=...': If provided, only the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.
 
'min opening volume=...' / 'max opening volume=...': If provided, only openings with a volume of at least min opening volume and at most max opening volume will be included. If the values don't have any units specified, cubic millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon. Only applicable for walls.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted. Only applicable for walls.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=Volume('net') returns the volume of the wall, wall component, slab or slab component.
 
=Volume('net', 'min opening volume=10 cu cm') returns the volume of the wall, wall component, slab or slab component, but only taking openings with at least 10 cubic centimeters of volume into account.
 
=Volume('net', 'min opening volume=10 cu cm', 'max opening volume=1 cu m') returns the volume of the wall, wall component, slab or slab component, but only taking openings with between 10 cubic centimeters and 1 cubic meter of volume into account.
 
=Volume('net', 'opening type=Window') returns the volume of the wall or wall component, but only taking openings created by "Window" plug-in objects into account.
 
=Volume('net', 'opening type=Window;WinDoor 6.0') returns the volume of the wall or wall component, but only taking openings created by "Window" and "WinDoor 6.0" plug-in objects into account.
 
=Volume('net', 'component=core', 'min opening volume=10 cu cm') returns the volume of the core wall component, but only taking openings with a volume of at least 10 cubic centimeters into account.</pre>
|-
| colspan="3" | <big>Volume('openings', [optional parameters])</big>
|-
|  || valign="top" | Returns the volume of the openings in a wall, wall component, slab or slab component.
 
'component name=...': If provided, only openings in the components with the given name will be included.
 
'component material=...': If provided, only openings in the components with the given material will be included.
 
'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.
 
'min opening volume=...' / 'max opening volume=...': If provided, only openings with a volume of at least min opening volume and at most max opening volume will be included. If the values don't have any units specified, cubic millimeters will be assumed.
 
'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon. Only applicable for walls.
 
'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted. Only applicable for walls.
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=Volume('openings') returns the total volume of openings in the wall, wall component, slab or slab component.
 
=Volume('openings', 'min opening volume=10 cu cm') returns the total volume of openings with a volume of at least 10 cubic centimeters.
 
=Volume('openings', 'min opening volume=10 cu cm', 'max opening volume=1 cu m') returns the total volume of openings with a volume of at least 10 cubic centimeters and at most 1 cubic meter.
 
=Volume('openings', 'opening type=Window') returns the total volume of openings created by "Window" plug-in objects.
 
=Volume('openings', 'opening type=Window;WinDoor 6.0') returns the total volume of openings created by "Window" and "WinDoor 6.0" plug-in objects.
 
=Volume('openings', 'component=core', 'min opening volume=10 cu cm') returns the total volume of openings with a volume of at least 10 cubic centimeters in the wall core component.</pre>
|-
| colspan="3" | <big>WallOverallHeight()</big>
|-
|-
|  || valign="top" | Returns the overall height of walls.
|  || valign="top" | Returns the overall height of walls.
Line 2,195: Line 4,095:
|}
|}


== Specialized for WinDoor 6.0 ==
== Specialized for WinDoor ==


{| border=0
{| border=0
Line 2,251: Line 4,151:
  - <ToUnit> - the units in which the value will be converted from the current document units
  - <ToUnit> - the units in which the value will be converted from the current document units
Possible options are for using the current document units:
Possible options are for using the current document units:
Dim - flinear dimension  
Dim - linear dimension  
Area - area dimension
Area - area dimension
Volume - volume dimension
Volume - volume dimension
Line 2,286: Line 4,186:
1/8 - would round to 1/8th
1/8 - would round to 1/8th
1/64 - would round to 1/64th
1/64 - would round to 1/64th
1/1 - wourd round to integer number
1/1 - would round to integer number


- <optional param> - rounding base using multiples of tenths, quarters, or halves
- <optional param> - rounding base using multiples of tenths, quarters, or halves
Line 2,297: Line 4,197:
Units
Units


- <optional param> - thoudsnds separator display
- <optional param> - thousands separator display
ThousandsSeparator
ThousandsSeparator
NoThousandsSeparator
NoThousandsSeparator
Line 2,388: Line 4,288:
|  || valign="top" | Replaces occurrences of a substring in a text with a different substring. If the optional argument count is given, only the first count occurrences are replaced.
|  || valign="top" | Replaces occurrences of a substring in a text with a different substring. If the optional argument count is given, only the first count occurrences are replaced.
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=replace('my car is your car', 'car', 'ball', 2) returns 'my ball is your ball'
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=replace('my car is your car', 'car', 'ball', 2) returns 'my car is your ball'
</pre>
</pre>
|-
|-
Line 2,514: Line 4,414:
| colspan="3" | <big>FindPattern(pattern, text, [caseSensitive])</big>
| colspan="3" | <big>FindPattern(pattern, text, [caseSensitive])</big>
|-
|-
|  || valign="top" | The lowest index in the (text) where the regular expression provided in (pattern)  is found.  If the optional argument (case) is set to true, case-sensitive search is performed. Index of -1 if (subtext) is not found. Regular expression is a sequence of characters that specifies a search pattern.
|  || valign="top" | The lowest index in the (text) where the regular expression provided in (pattern)  is found.  If the optional argument (case) is set to true, case-sensitive search is performed. Index of -1 if (subtext) is not found. Regular expression is a sequence of characters that specifies a search pattern. Uses ECMAScript syntax for the pattern: https://www.cplusplus.com/reference/regex/ECMAScript/?kw=ECMAScript
The pattern uses ECMAScript syntax: https://www.cplusplus.com/reference/regex/ECMAScript/?kw=ECMAScript
 
|-
|-
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=findPattern('(Soft)(.*)', 'soft Software', True) returns 5
|  || valign="top" | <pre style="white-space:-moz-pre-wrap; white-space:-pre-wrap; white-space:-o-pre-wrap; white-space:pre-wrap; word-wrap:break-word;">=findPattern('(Soft)(.*)', 'soft Software', True) returns 5
Line 2,528: Line 4,426:
</pre>
</pre>
|}
|}




[[Category:Worksheets]]
[[Category:Worksheets]]

Revision as of 15:22, 5 October 2022

.Worksheets|Worksheets ..Search Criteria Format|Search Criteria Format ..Worksheet Functions|Worksheet Functions ..Worksheets#Version_Information|Version Information

General

RunScript(scriptPath [, functionName])
Executes a script and returns the result value.
Database header cell:
=RunScript('My Script') executes the VectorScript script named “My Script” and returns a value for each object in the database

Spreadsheet cell:
=RunScript(2, 'ScriptFile.py', 2, 1) executes the Python script “ScriptFile.py” in the Vectorworks Plug-Ins folder, passing the parameters “2” and “1,” and returns a value
FormatField(record_format_name, field_name)
Returns the default value of a given field name of the specified record format.
=FormatField(‘Door’, ‘Width’), where “Door” is the name of a record format, returns the default value for the “Width” field.

RunScriptEdit(scriptPath [, functionName])
Executes a script and returns the result value. The cells are editable and the same script is executed to handle the edit.
Database(criteria)
Creates a database of objects that meet the criteria.
=DATABASE((L='Floor-1')) creates a worksheet database of all objects on layer “Floor-1.”
DatabaseByScript([scriptPath], scriptName, ...params...)
Runs a script to create a database of objects.
=DataBaseByScript('MyScript.py', 2, 1) creates a worksheet database by executing the script named “My Script.py,” passing the parameters “2” and “1” to the script.

Logic

Switch(number, value1, value2, ... value_no_match)
Use value1, or value2, or value3, etc depending on the (number). When no value is available, then use value_no_match.
=switch(3, 10, 20, 30, 40, 50, 60, 'no match') returns 30
IFS((logic1), value1, (logic2), value2, ..., (logicN), valueN))
One of several possible results based on a series of tests. The first value which passes the test is chosen.
=ifs(A4>30, 'yes', A4<=30, 'no') returns 'yes' if the number in the cell A4 is >30. Else, if it is <=30 'no' is returned
Exact(value1, value2)
True when the two values are exactly the same. It will perform a case-sensitive comparison if the values are strings.
=exact('text', 'text') returns True, while exact('Text', 'text') will return False.
IsNA(value)
True when the value is N/A.
=IF(IsNA(Angle('energos')), '-', 'has value') On a database row, calculates the Energos angle of the objects, and decides which value to output based on if energos is applicable or not.

Note, you can use IfNA in order to use alternative value only when it's not applicable, the 'Angle' would have to be repeated for the IF function.

IfNA(value, value_when_na)
Use value_when_na when value resolves to N/A, otherwise use the value itself.
=IfNA(Angle('energos'), '-') On a database row, calculates the Energos angle of the objects, and if they are not applicable, would use '-'

FirstNonEmpty(value1, value2, value3, ...)
Use value1 if not empty, otherwise use value2 if not empty, otherwise use value3 if not empty, etc. Empty means: empty string, zero value, or N/A value. N/A will be returned if no match.
=FirstNonEmpty('Format-1'.'data', B1, 'Empty')

Return the value of the data field of the Format-1, if empty return B1, or the string 'Empty' if that is empty too.

IsError(value)
True when the value resolves to an error.
IfError(value, value_when_error)
Use value_when_error when value resolved to an error, otherwise use the value itself.
if((logical_test), value_if_true, value_if_false)
Use value_if_true if logical_test is true, value_is_false if logical_test is false.
=if(('Existing Tree'.'Condition'='Not Set'), '-', 'Existing Tree'.'Condition') If no condition value was set for the existing tree object, the value in this cell is a dash; otherwise, the value in this cell is the condition value that was set for the tree object.

=if(('Existing Tree'.'Condition'='Not Set'); '-'; 'Existing Tree'.'Condition')

Lookup

VLookup(value, [use_pattern], result_col_index, not_found_value, table)
Finds a value in the table range, looking at the leftmost column, and returns the value at the result_col_index in that same row. Uses ECMAScript syntax for the pattern: https://www.cplusplus.com/reference/regex/ECMAScript/?kw=ECMAScript
=VLookup(value, [use_pattern], result_col_index, not_found_value, table)

Find a value in the table range, looking at the first column, and return the value at the resut_col_index of that row.

Parameters:
  value - the value that will be searched in the first column of 'table'.
  use_pattern - use regular expression pattern for the search.
  result_col_index - the number of the column in 'table' which will return the result_col_index.
  not_found_value - the result if 'value' is not found
  table - a range referencing the data. the first column will be searched, and 'result_col_index' will specify the result.

=VLookup(A3, 2, 'no email', B1..C4)
=VLookup(A3, 2, 'no email', 'Worksheet-1':B1..C4)

This example will search for the value of A3 in column B, and if found it will return the value in the C column, otherwise it will return 'no email'.

If the table is like this, 'tech' will be searched in B column, and it will return 'tech@vectorworks.net'
Note the second example, the table is a range for another worksheet named 'Worksheet-1'

  |    A   |     B     |     C
-------------------------------------------------
1 |        |  support  | support@vectorworks.net
2 |        |  tech     | tech@vectorworks.net
3 |  tech  |  PR       | PR@vectorworks.net
XLookup(value, [use_pattern], not_found_value, array_lookup, array_result)
Finds a value in the array_lookup, and returns the value from the array_result at the found row. The arrays should be ranges on the same column. Uses ECMAScript syntax for the pattern: https://www.cplusplus.com/reference/regex/ECMAScript/?kw=ECMAScript
=XLookup(value, [use_pattern], not_found_value, array_lookup, array_result)

Find a value in the array_lookup, and return the value from the array_result at the found row. the arrays should be ranges on the same column.

Parameters:
  value - the value that will be searched in 'array_lookup' (a range defined in a single column).
  use_pattern - use regular expression pattern for the search.
  not_found_value - the result if 'value' is not found
  array_lookup - a range defined in a single column to search the 'value' in
  array_result - a range defined in a single column to to provide the result from the row that the 'value' was found in 'array_lookup'

=XLookup('tech', 'not found', 'Worksheet-Values':A1..A3, 'Worksheet-Result':B1..B3)

Named worksheet: 'Worksheet-Values':

  |     A     
--------------
1 |  support
2 |  tech
3 |  PR       

Named worksheet: 'Worksheet-Result':

  |   A    |     B
-----------|-------------------------
1 |  1234  | support@vectorworks.net
2 |  1235  | tech@vectorworks.net
3 |  1236  | PR@vectorworks.net

Math

round(number)
Rounds the specified number to the nearest whole number.
=round(2.345) returns 2
sin(number)
Returns the sine of a given angle.
=sin(deg2rad(32)) converts a 32-degree angle to its radian equivalent, and returns the sine of the angle
cos(number)
Returns the cosine of a given angle.
=cos(deg2rad(23)) converts a 23-degree angle to its radian equivalent, and returns the cosine of the angle
exp(number)
Returns e raised to the power of number.
=exp(2) returns the numeric value of e raised to the power of 2
ln(number)
Returns the natural logarithm (base e) of a number.
=ln(12) returns the natural logarithm of 12
sqrt(number)
Returns the square root of a number.
=sqrt(D27) returns the square root of the number in cell D27
atan(number)
Returns the arctangent of a number.
=atan(A3) returns the angle for which the tangent value is given in cell A3
rad2deg(number)
Converts number from radians to degrees.
=rad2deg(0.5235987) converts the radian angle measurement to its degree equivalent
deg2rad(number)
Converts number from degrees to radians.
=deg2rad(47) converts the 47-degree angle measurement to its radian equivalent
asin(number)
Returns the arcsine of a number.
=asin(A3) returns the angle for which the sine value is given in cell A3
acos(number)
Returns the arccosine of a number.
=acos(3/5) returns the angle for which the cosine value is 3/5
rounddown(number, digits)
Rounds the specified number down to a specified number of decimal digits.
=rounddown(2.345, 2) returns 2.34
roundup(number, digits)
Rounds the specified number up to a specified number of decimal digits.
=roundup(2.345, 2) returns 2.35
abs(number)
The absolute value of a number.
=abs(-12) returns the absolute value of the number -12
quotient(numerator, denominator)
Computes the quotient of an integer division.
=quotient(5, 2) returns 2

You can clculate the remainder by using the MOD operator
=5 MOD 2
gcd(number1, number2, …)
The greatest common divisor of a group of numbers.
=gcd(5, 10, 20) returns 5
lcm(number1, number2, …)
The least common multiple of a group of numbers.
=lcm(2, 5, 11) returns 110
median(number1, number2, …)
The median (middle number) of a group of numbers
=median(1, 2, 3, 4, 5, 6) returns 3.5
logX(number, base)
The natural logarithm of a number with specified base. Number is the positive real number for which the logarithm is calculated. Related function: Power
=logx(16, 2) returns 4
power(number, power)
Raises a number to the given power. The function works like an exponent in a standard math equation.
=power(10, 3) returns 1000
sqrtpi(number)
The square root of (number * pi).
=sqrtpi(3.1415) returns 3.142 (square root of pi*3.1415)
sumsq(number1, number2, …)
The sum of the squares of the arguments.
=sumsq(0, 1, 2, 3, 4, 5) returns 55
randBetween(number1, number2)
A number between bottom and top, including bottom but not including top.
=randBetween(10, 100) returns a random number in the range [10, 100]
rand()
A number between 0 and 1, including 0 but not including 1.
=rand() returns a random number in the range [0, 1)
ceiling(number, [significance])
Rounds a number rounded up, away from zero, to the nearest multiple of significance.
=ceiling(123.123, 0.01) returns 123.13 (123.123 rounded up to the nearest multiple of 0.01)
floorNum(number, [significance])
Rounds a number down, toward zero, to the nearest multiple of significance.
=floorNum(123.123, 0.01) returns 123.12 (123.123 rounded down to the nearest multiple of 0.01)
truncate(number, [num digits])
A number truncated to the specified number of decimal places.
=truncate(123.123, 2) returns 123.12
average(number1, number2,...)
Returns the average (mean) of the arguments.
=average(A2,A10..A12) returns the average of the numbers contained in cells A2, A10, A11, and A12
int(number)
Rounds a number down to the nearest integer.
=int(3.8) returns the value 3
log(number)
Returns the base 10 logarithm of a number.
=log(100) returns the base 10 logarithm of 100
max(number1, number2,...)
Returns the largest number in the list of arguments.
=max(C5,C7,C9) returns the largest of the numbers that are in cells C5, C7, and C9
min(number1, number2,...)
Returns the smallest number in the list of arguments.
=min(C5,C7,C9) returns the smallest of the numbers that are in cells C5, C7, and C9
tan(number)
Returns the tangent of a given angle.
=tan(deg2rad(32)) converts a 32-degree angle to its radian equivalent, and returns the tangent of the angle
sum(number1, number2,...)
Returns the sum of all numbers in the list of arguments.
=sum(A2,A10..A12) returns the sum of the numbers contained in cells A2, A10, A11, and A12

Objects

General

Depth([optional parameters])
Returns the object's depth. The optional parameters will return specific values for certain objects, and the available options will be listed separately.
Weight([optional parameters])
Returns the object's wight. The optional parameters will return specific values for certain objects, and the available options will be listed separately.
ProjectedArea([optional parameters])
Returns the object's projected area. The optional parameters will return specific values for certain objects, and the available options will be listed separately.
FootPrintArea([optional parameters])
Returns the object's footprint area. The optional parameters will return specific values for certain objects, and the available options will be listed separately.
CrossSectionArea([optional parameters])
Returns the object's cross section area. The optional parameters will return specific values for certain objects, and the available options will be listed separately.
SpecialArea([optional parameters])
Returns the object's special area typically defined by parameters. The optional parameters will return specific values for certain objects, and the available options will be listed separately.
ObjectData('Class Description')
Returns the class description of the object's class.
ObjectData('component', <value> [, <component index>])
Returns the specified <value> about a component by index, or the core component if <component index> is missing. See the example for more details.
Available optiosn for <value>:
	- Name
	- Function
	- Class
	- Class Desc
	- Thickness
	- Lambda
	- U-Value
	- Net Area
	- Net Volume

Examples:
	# return component name
	ObjectData('component', 'Name')			# core compoent
	ObjectData('component', 'Name', 2)		# component with index = 2
	
	
	# return component Function value
	ObjectData('component', 'Function')		# core compoent
	ObjectData('component', 'Function', 2)	# component with index = 2
	
	
	# return component class
	ObjectData('component', 'Class')		# core compoent
	ObjectData('component', 'Class', 2)		# component with index = 2
	
	
	# return component class description
	ObjectData('component', 'Class Desc')			# core compoent
	ObjectData('component', 'Class Desc', 2)		# component with index = 2
	ObjectData('component', 'Class Description')	# core compoent
	ObjectData('component', 'Class Description', 2)	# component with index = 2
	
	
	# return component thickness
	ObjectData('component', 'Thickness')		# core compoent
	ObjectData('component', 'Thickness', 2)		# component with index = 2
	
	
	# return component lambda value
	ObjectData('component', 'Lambda')			# core compoent
	ObjectData('component', 'Lambda', 2)		# component with index = 2
	
	
	# return component U-value
	ObjectData('component', 'U-Value')			# core compoent
	ObjectData('component', 'U-Value', 2)		# component with index = 2
	
	
	# return component net area
	ObjectData('component', 'Net Area')			# core compoent
	ObjectData('component', 'Net Area', 2)		# component with index = 2
	
	
	# return component net volume
	ObjectData('component', 'Net Volume')		# core compoent
	ObjectData('component', 'Net Volume', 2)	# component with index = 2
	
	
ObjectData('General Name')
Returns the object's or symbol's name and if it's a symbol with no name, returns the symbol definition resource name.
Database header cell:
=ObjectData('General Name')        Returns the name for each object in the DB row.
                                If the object is a symbol, it will return the name of the symbol

Spreadsheet cell:
=ObjectData(SEL=TRUE, 'General Name')    Returns the name for the selected object
                                      If the object is a symbol, it will return the name of the symbol
ObjectData(criteria, 'inventory part', part_univ_name, part_index)
Get inventory part name from inventory supported object.
ObjectData(criteria, 'inventory part param', part_univ_name, part_index, param_index)
Get inventory part parameter value from inventory supported object.
ObjectData(criteria, 'inventory part quantity', part_univ_name, part_index)
Get inventory part quantity from inventory supported object.
ObjectData('Layer Description')
Returns the layer description of the object's layer.
ObjectData('Object Variable', variable_index)
Returns the specified object variable from the object.
ObjectData('Universal Value', format_name, field_name, [is format])
Returns the universal value of the specified field of record or format if the optional parameter is True. It will work with the parametric format when the format_name is empty. Returns N/A if the object doesn't have the record attached or the format doesn't exist.
Database header cell:
=ObjectData('Universal Value', 'My Format-1', 'data')        Returns the 'data' field for the attached 'My Format-1' for each object in the DB row. Returns N/A if the format or the field is not available.
=ObjectData('Universal Value', 'My Format-1', 'data', True)  Returns the 'data' field for the attached 'My Format-1' for each object in the DB row. Returns N/A if the format or the field is not available.
=ObjectData('Universal Value', '', 'DoorHeight')            Returns the 'DoorHeight' field for each parametric in the DB row. Returns N/A if the field is not avaialble or the object is not a parametric.
=ObjectData('Universal Value', '', 'DoorHeight', True)      Returns the 'DoorHeight' field default value for each parametric in the DB row. Returns N/A if the field is not avaialble or the object is not a parametric.

Spreadsheet cell:
=ObjectData(t=wall, 'Universal Value', 'My Format-1', 'data')        Returns the 'data' field for the attached 'My Format-1' for the wall. Returns N/A if the format or the field is not available.
=ObjectData(t=wall, 'Universal Value', 'My Format-1', 'data', True)  Returns the 'data' field for the attached 'My Format-1' for the wall. Returns N/A if the format or the field is not available.
=ObjectData(PON='Door', 'Universal Value', '', 'DoorHeight')        Returns the 'DoorHeight' field for the parametric object Door. Returns N/A if the field is not avaialble or the object is not a parametric.
=ObjectData(PON='Door', 'Universal Value', '', 'DoorHeight', True)  Returns the 'DoorHeight' field default value the parametric object Door. Returns N/A if the field is not avaialble or the object is not a parametric.
ObjectType()
Returns the object type ID.
Database header cell:
=ObjectType returns the object type value for each object in the database

Spreadsheet cell:
=ObjectType(sel=true) returns the object type value of the selected object; for example, the object type value for a light is 81
Width([optional parameters])
Returns the delta X (width) of objects. The optional parameters will return specific values for certain objects, and the available options will be listed separately.
Database header cell:
=Width returns the width (delta x) for each object in the database

Spreadsheet cell:
=Width(sel=true) returns the combined width (delta x value) of the selected object
Height([optional parameters])
Returns the delta Y (height) of objects. The optional parameters will return specific values for certain objects, and the available options will be listed separately.
Database header cell:
=Height returns the height (delta y) for each object in the database

Spreadsheet cell:
=Height(sel=true) returns the combined height (delta y) value of the selected objects in the drawing
Count([optional parameters])
Returns the number of objects. The optional parameters will return specific values for certain objects, and the available options will be listed separately.
Database header cell:
=Count returns the total number of objects for each row in the database

Spreadsheet cell:
=Count(s='simple sofa') returns the total number of symbol objects named “simple sofa” in the drawing

When used with the COUNT function, the SEL (selection status) criterion counts objects that are actually non-selectable, such as the individual items within a group. The VSEL (visible selection status) criterion counts only the visibly selected items, which is the same counting method used for the Object Info palette. For example, if you select and count a group that has 11 items in it, the SEL criterion returns a value of 12 (the group, plus the 11 items). The VSEL criterion returns a value of 1 (the group only).
Angle()
Returns the angle of lines and walls, the span angle of arcs (in degrees), and the slope angle of slabs (in degrees).
Database header cell:
=Angle returns the angle of each object in the database

Spreadsheet cell:
=Angle((t=arc)&(n='arc-1')) returns the sweep angle of the arc object named “arc-1” in the drawing
IsFlipped()
Returns 1 if the object is flipped, otherwise it returns 0.
Database header cell:
=IsFlipped returns the flip state for each object in the database

Spreadsheet cell:
=IsFlipped(PON='window') returns the flip state of the window object if it resolves to only one, otherwise returns the total number of window objects in the drawing that are flipped
XCoordinate()
Returns the X coordinate of the object relative to the user origin.
Database header cell:
=XCoordinate returns the x coordinate value for each object in the database
YCoordinate()
Returns the Y coordinate of the object relative to the user origin.
Database header cell:
=YCoordinate returns the y coordinate value for each object in the database
ZCoordinate()
Returns the Z coordinate of the object relative to the object's layer plane.
Database header cell:
=ZCoordinate returns the z coordinate value for each object in the database
Area()
Returns the area of 2D objects. The optional parameters will return specific values for certain objects, and the available options will be listed separately.
Database header cell:
=Area returns the area of each object in the database

Spreadsheet cell:
=Area(t=rect) returns the combined area of all rectangle objects in the drawing
BotBound()
Returns the minimum Y coordinate of objects.
Database header cell:
=BotBound returns the bottom 2D boundary of each object in the database

Spreadsheet cell:
=BotBound(t=locus) returns the bottom 2D boundary of the locus that has the lowest bottom 2D boundary value in the drawing
TopBound()
Returns the maximum Y (top boundary) of the objects.
Database header cell:
=TopBound returns the top 2D boundary for each object in the database

Spreadsheet cell:
=TopBound(sel=true) returns the top 2D boundary of the topmost selected object
LeftBound()
Returns the left side minimum X (left boundary) of the objects.
Database header cell:
=LeftBound returns the left 2D boundary for each object in the database

Spreadsheet cell:
=LeftBound(t=locus) returns the left 2D boundary of the leftmost locus in the drawing
RightBound()
Returns the right side minimum X (right boundary) of the objects.
Database header cell:
=RightBound returns the right 2D boundary for each object in the database

Spreadsheet cell:
=RightBound(t=rect) returns the right 2D boundary of the rightmost rectangle in the drawing
Perim([optional parameters])
Returns the object's perimeter. The optional parameters will return specific values for certain objects, and the available options will be listed separately.
Database header cell:
=Perim returns the perimeter for each object in the database

Spreadsheet cell:
=Perim(sel=true) returns the total perimeter of all selected objects
Length([optional parameters])
Returns the length of lines or walls. The optional parameters will return specific values for certain objects, and the available options will be listed separately.
Database header cell:
=Length returns the length for each object in the database

Spreadsheet cell:
=Length(t=line) returns the total length of all line objects in the drawing
XCenter()
Returns the center of objects in the X direction.
Database header cell:
=XCenter returns the x coordinate value of the center of the 2D boundary for each object in the database

Spreadsheet cell:
=XCenter(sel=true) returns the x coordinate value of the center of the 2D boundary of the selected object
YCenter()
Returns the center of objects in the Y direction.
Database header cell:
=YCenter returns the y coordinate value of the center of the 2D boundary for each object in the database

Spreadsheet cell:
=YCenter(sel=true) returns the y coordinate value of the center of the 2D boundary of the selected object
ZCenter()
Returns the center of objects in the Z direction.
Database header cell:
=ZCenter returns the z coordinate value of the center of the 2D boundary for each object in the database

Spreadsheet cell:
=ZCenter(sel=true) returns the z coordinate value of the center of the 2D boundary of the selected object
SurfaceArea([optional parameters])
Returns the object's surface area. The optional parameters will return specific values for certain objects, and the available options will be listed separately.
Database header cell:
=SurfaceArea returns the surface area for each object in the database

Spreadsheet cell:
=SurfaceArea(st=sphere) returns the total surface area of all sphere objects in the drawing
Volume([optional parameters])
Returns the object's volume of objects. The optional parameters will return specific values for certain objects, and the available options will be listed separately.
Database header cell:
=Volume returns the volume for each object in the database

Spreadsheet cell:
=Volume(t=xtrd) returns the total volume of all extrude objects in the drawing
Image()
Returns an image of the object.
Database header cell:
=Image returns the image for each object in the database

Spreadsheet cell:
=Image(s='cabinet') returns the image of the symbol named “Cabinet”
ObjUValue()
Returns the U-Value of objects.
Database header cell:
=ObjectUValue returns the U-value for each wall, round wall, roof, roof face, slab, door, and window object in the database

Spreadsheet cell:
=ObjectUValue(n='wall-1') returns the U-value for the wall named “wall-1”
ObjRValue()
Returns the R-Value of objects.
Database header cell:
=ObjectRValue returns the R-value for each wall, round wall, roof, roof face, slab, door, and window object in the database

Spreadsheet cell:
=ObjectRValue(n='wall-1') returns the R-value for the wall named “wall-1”
ObjIncludeInEnergos()
Returns 1 if object will be included in Energos calculations, otherwise it returns 0.
Database header cell:
=ObjIncludeInEnergos returns the Energos status for each wall, round wall, roof, roof face, slab, door, and window object in the database

Spreadsheet cell:
=ObjIncludeInEnergos(t=wall) returns the Energos status for all walls in the drawing
PluginStyleName()
Returns the name of the plug-in style used by the object.
Database header cell:
=PluginStyleName returns the plug-in style name for each object in the database

Spreadsheet cell:
=PluginStyleName(sel=true) returns the plug-in style name for all selected objects in the drawing
Layer()
Returns the object's layer name.
Database header cell:
=Layer returns the layer of each object in the database

Spreadsheet cell:
=Layer(sel=true) returns the layer name of the selected objects in the drawing
Class()
Returns the object's class name.
Database header cell:
=Class returns the class of each object in the database

Spreadsheet cell:
=Class(sel=true) returns the class name of the selected objects in the drawing
ObjectTypeName()
Returns the object's type name.
Database header cell:
=ObjectTypeName returns the type name for each object in the database

Spreadsheet cell:
=ObjectTypeName(sel=true) returns the type name of the selected objects in the drawing
Name()
Returns the object's name.
Database header cell:
=Name returns the name for each object in the database

Spreadsheet cell:
=Name(sel=true) returns the name of the selected objects in the drawing
Story()
Returns the object's story.
Database header cell:
=Story returns the story name for each object in the database

Spreadsheet cell:
=Story(sel=true) returns the story name of the selected objects in the drawing
ObjectTileFill()
Returns the object's tile fill.
Database header cell:
=TileFill returns the tile fill for each object in the database

Spreadsheet cell:
=TileFill(sel=true) returns the tile fill of the selected objects in the drawing
ObjectHatchFill()
Returns the object's hatch fill.
Database header cell:
=HatchFill returns the hatch fill for each object in the database

Spreadsheet cell:
=HatchFill(sel=true) returns the hatch fill of the selected objects in the drawing
ObjectGradientFill()
Returns the object's gradient fill.
Database header cell:
=GradientFill returns the gradient fill for each object in the database

Spreadsheet cell:
=GradientFill(sel=true) returns the gradient fill of the selected objects in the drawing
ObjectTexture()
Returns the object's texture name.
Database header cell:
=ObjectTexture returns the texture of each object in the database

Spreadsheet cell:
=ObjectTexture(sel=true) returns the texture of the selected objects in the drawing
ObjectSketchStyle()
Returns the object's sketch style name.
Database header cell:
=SketchStyle returns the sketch style for each object in the database

Spreadsheet cell:
=SketchStyle(sel=true) returns the sketch style of the selected objects in the drawing
ObjectLineType()
Returns the object's line type.
Database header cell:
=LineType returns the line type for each object in the database

Spreadsheet cell:
=LineType(sel=true) returns the line type of the selected objects in the drawing
ObjectImageFill()
Returns the object's image fill.
Database header cell:
=ImageFill returns the image fill for each object in the database

Spreadsheet cell:
=ImageFill(sel=true) returns the image fill of the selected objects in the drawing
GetCOBieSource(worksheetName.columnName.country.version)
Returns data source of a COBie property for an object.
=GETCOBIESOURCE ('space.floorname') returns the FloorName data source for objects whose COBie property is Space
GetCOBieProperty(worksheetName.columnName.country.version)
Returns the value of a COBie property for an object.
=GETCOBIEPROPERTY ('space.floorname') returns the FloorName value for objects whose COBie property is Space
SymbolName()
Returns the symbol name.
Database header cell:
=SymbolName returns the name for each symbol instance in the database

Spreadsheet cell:
=SymbolName(sel=true) returns the symbol name of the selected symbol instances in the drawing
DataTagField(fieldname)
Returns the value of the specified field in the data tag object. Fieldname is the name of the field in the data tag layout.
Database header cell:
=DataTagField('Color'), where “Color” is the label of a user-entered text field in a data tag, returns the value for the “Color” field (for example, “Red”) for each data tag in the database.

Spreadsheet cell:
=DataTagField(sel=true, 'Color'), where “Color” is the label of a user-entered text field in a data tag, returns the value for the “Color” field (for example, “Red”) for the selected data tag in the drawing.
ImageByViewport(viewportName)
Returns an image of the object with the specified viewport's color scheme(s) applied.
Database header cell:
=Imagebyviewport('Plan A') applies the data visualizations from the viewport named “Plan A” to each image in the database 

Spreadsheet cell:
=Imagebyviewport('Space Allocation') applies the data visualization from the viewport named “Space Allocation” to the image in the cell
ImageByDataVis(dataVisName)
Returns an image of the object with the specified data visualizations's color scheme applied.
Database header cell:
=Imagebydatavis('truss by type') applies the “truss by type” data visualization to each image in the database rows

Spreadsheet cell:
=Imagebydatavis('offices') applies the data visualization named “offices” to the image in the cell
XRotation()
Returns the object's rotation angle (in degrees) around the X-axis.
YRotation()
Returns the object's rotation angle (in degrees) around the Y-axis.
ZRotation()
Returns the object's rotation angle (in degrees) around the Z-axis.
PartTypeName()
Returns the part type name of the subpart object. Returns the object type name if the object is not a subpart.
Database header cell:
=PartTypeName returns the part type name for each subpart object in the database. if the database object is not a subpart, the object type name is returned

FillForeColor()
Returns the object's fill foreground color name.
Database header cell:
=FillForeColor returns the name of the fill foreground color for each object in the database

Spreadsheet cell:
=FillForeColor(t=rect) returns the name of the fill foreground color of the rectangle object
FillBackColor()
Returns the object's fill background color name.
Database header cell:
=FillBackColor returns the name of the fill background color for each object in the database

Spreadsheet cell:
=FillBackColor(t=rect) returns the name of the fill background color of the rectangle object
PenForeColor()
Returns the object's pen foreground color name.
Database header cell:
=PenForeColor returns the name of the pen foreground color for each object in the database

Spreadsheet cell:
=PenForeColor(t=rect) returns the name of the pen foreground color of the rectangle object
PenBackColor()
Returns the object's pen background color name.
Database header cell:
=PenBackColor returns the name of the pen background color for each object in the database

Spreadsheet cell:
=PenBackColor(t=rect) returns the name of the pen background color of the rectangle object
IsFilled()
Returns 1 if the object has any fill attribute, otherwise returns 0.
Database header cell:
=IsFilled returns the attribute fill state (1 if filled, otherwise 0) for each object in the database



Spreadsheet cell:
=IsFilled(T=WALL) returns the attribute fill state of the wall object if the criteria resolves to one object, otherwise returns the total number of walls in the drawing that are filled

Legacy

ComponentArea( index)
Returns the area of one side of the specified component,

minus any holes in the 3D object.

Database header cell:
=ComponentArea(2) returns the combined area of the second component for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=ComponentArea(t=wall,1) returns the combined area of the first components for all walls in the drawing
ComponentVolume(index)
Returns the total 3D volume of the specified component,

minus any holes in the 3D object.

Database header cell:
=ComponentVolume(2) returns the combined volume of the second component for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=ComponentVolume(t=wall,1) returns the combined volume of the first components for all walls in the drawing
ComponentName(index)
Returns the name of the specified component.
Database header cell:
=ComponentName(2) returns the name of the second component for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=ComponentName(t=wall,1) returns the name of the first component for all walls in the drawing
GetIFCProperty(instanceName.propertyName)
Returns the value of the property field of the given instance or preset.
=GETIFCPROPERTY ('ifcfurnishingelement.name') returns the Name value for IFC objects whose IFC entity is IfcFurnishingElement 
ComponentLambda(index)
Returns the lambda of the specified component.
Database header cell:
=ComponentLambda(2) returns the Lambda value of the second component for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=ComponentLambda(t=wall,1) returns the Lambda value of the first component for all walls in the drawing
ComponentUValue(index)
Returns the U-Value of the specified component.
Database header cell:
=ComponentUValue(2) returns the combined U-values of the second component for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=ComponentUValue(t=wall,1) returns the combined U-values of the first components for all walls in the drawing
ComponentRValue(index)
Returns the R-Value of the specified component.
Database header cell:
=ComponentRValue(2) returns the combined R-values of the second component for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=ComponentRValue(t=wall,1) returns the combined R-values of the first components for all walls in the drawing
ComponentThickness(index)
Returns the thickness of the specified component.
Database header cell:
=ComponentThickness(2) returns the combined thickness of the second component for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=ComponentThickness(t=wall,1) returns the combined thickness of the first components for all walls in the drawing
CompAreaByClass(class)
The area of one side of the specified wall, slab, or roof component, minus any holes. Class is a string that specifies the component's class. If multiple components use the specified class the values will be summed.
Database header cell:
=CompAreaByClass('Class-1') returns the combined area of the components assigned to the class “Class-1” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompAreaByClass(t=wall,'Class-1') returns the combined area of the components assigned to the class “Class-1” for all walls in the drawing
CompLambdaByClass(class)
The Lambda value of the specified wall, slab, or roof component. Class is a string that specifies the component's class. If multiple components use the specified class the lambda value of the first matching component will be returned.
Database header cell:
=CompLambdaByClass('Class-1') returns the Lambda value of the first component assigned to the class “Class-1” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompLambdaByClass(t=wall,'Class-1') returns the Lambda value of the first component assigned to the class “Class-1” for all walls in the drawing
CompNameByClass(class)
The name of the specified wall, slab, or roof component. Class is a string that specifies the component's class. If multiple components use the specified class the first component name will be returned.
Database header cell:
=CompNameByClass('Class-1') returns the name of the first component assigned to the class “Class-1” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompNameByClass(t=wall,'Class-1') returns the name of the first component assigned to the class “Class-1” for all walls in the drawing
CompRValueByClass(class)
The R-Value of the specified wall, slab, or roof component. Class is a string that specifies the component's class. If multiple components use the specified class the values will be summed.
Database header cell:
=CompRValueByClass('Class-1') returns the combined R-values of the components assigned to the class “Class-1” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompRValueByClass(t=wall,'Class-1') returns the combined R-values of the components assigned to the class “Class-1” for all walls in the drawing
CompThicknessByClass(class)
The thickness of the specified wall, slab, or roof component. Class is a string that specifies the component's class. If multiple components use the specified class the values will be summed.
Database header cell:
=CompThicknessByClass('Class-1') returns the combined thickness of the components assigned to the class “Class-1” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompThicknessByClass(t=wall,'Class-1') returns the combined thickness of the components assigned to the class “Class-1” for all walls in the drawing
CompUValueByClass(class)
The U-Value of the specified wall, slab, or roof component. Class is a string that specifies the component's class. If multiple components use the specified class the values will be summed.
Database header cell:
=CompUValueByClass('Class-1') returns the combined U-values of the components assigned to the class “Class-1” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompUValueByClass(t=wall,'Class-1') returns the combined U-values of the components assigned to the class “Class-1” for all walls in the drawing
CompVolumeByClass(class)
The volume of the specified wall, slab, or roof component. Class is a string that specifies the component's class. If multiple components use the specified class the values will be summed.
Database header cell:
=CompVolumeByClass('Class-1') returns the combined volume of the components assigned to the class “Class-1” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompVolumeByClass(t=wall,'Class-1') returns the combined volume of the components assigned to the class “Class-1” for all walls in the drawing
CompAreaByName(name)
The area of one side of the specified wall, slab, or roof component, minus any holes. Name is a string that specifies the component's name. If multiple components use the same name the values will be summed.
Database header cell:
=CompAreaByName('Brick Veneer') returns the combined area of the components with the name “Brick Veneer” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompAreaByName(t=wall,'Brick Veneer') returns the combined area of the components with the name “Brick Veneer” for all walls in the drawing
CompLambdaByName(name)
The Lambda value of the specified wall, slab, or roof component. Name is a string that specifies the component's name. If multiple components use the same name the lambda value of the first matching component will be returned.
Database header cell:
=CompLambdaByName('Brick Veneer') returns the Lambda value of the first component with the name “Brick Veneer” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompLambdaByName(t=wall,'Brick Veneer') returns the Lambda value of the first component with the name “Brick Veneer” for all walls in the drawing
CompClassByName(name)
The class of the specified wall, slab, or roof component. Name is a string that specifies the component's name. If multiple components use the specified name the first component class will be returned.
Database header cell:
=CompClassByName('Brick Veneer') returns the class of the first component with the name “Brick Veneer” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompClassByName(t=wall,'Brick Veneer') returns the class of the first component with the name “Brick Veneer” for all walls in the drawing
CompRValuesByName(name)
The R-Value of the specified wall, slab, or roof component. Name is a string that specifies the component's name. If multiple components use the same name the values will be summed.
Database header cell:
=CompRValueByName('Brick Veneer') returns the combined R-values of the components with the name “Brick Veneer” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompRValueByName(t=wall,'Brick Veneer') returns the combined R-values of the components with the name “Brick Veneer” for all walls in the drawing
CompThicknessByName(name)
The thickness of the specified wall, slab, or roof component. Name is a string that specifies the component's name. If multiple components use the same name the values will be summed.
Database header cell:
=CompThicknessByName('Brick Veneer') returns the combined thickness of the components with the name “Brick Veneer” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompThicknessByName(t=wall,'Brick Veneer') returns the combined thickness of the components with the name “Brick Veneer” for all walls in the drawing
CompUValueByName(name)
The U-Value of the specified wall, slab, or roof component. Name is a string that specifies the component's name. If multiple components use the same name the values will be summed.
Database header cell:
=CompUValueByName('Brick Veneer') returns the combined U-values of the components with the name “Brick Veneer” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompUValueByName(t=wall,'Brick Veneer') returns the combined U-values of the components with the name “Brick Veneer” for all walls in the drawing
CompVolumeByName( name)
The volume of the specified wall, slab, or roof component. Name is a string that specifies the component's name. If multiple components use the same name the values will be summed.
Database header cell:
=CompVolumeByName('Brick Veneer') returns the combined volume of the components with the name “Brick Veneer” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompVolumeByName(t=wall,'Brick Veneer') returns the combined volume of the components with the name “Brick Veneer” for all walls in the drawing
CompMatByClass(class)
The material of the specified wall, slab, or roof component. Class is a string that specifies the component's class. If multiple components use the specified class the values will be summed.
Database header cell:
=CompMatByClass('Class-1') returns the materials used by the first component assigned to the class “Class-1” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompMatByClass(t=wall,'Class-1') returns the material used by the first component assigned to the class “Class-1” for all walls in the drawing
CompMatByName(name)
The material of the specified wall, slab, or roof component. Name is a string that specifies the component's name. If multiple components use the same name the values will be summed.
Database header cell:
=CompMatByName('Siding') returns the materials used by the first component with the name “Siding” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompMatByName(t=wall,'Siding') returns the material used by the first component with the name “Siding” for all walls in the drawing
CompAreaByMat(material)
The area of one side of the specified wall, slab, or roof component, minus any holes. Material is a string that specifies the component's material. If multiple components use the specified material the values will be summed.
Database header cell:
=CompAreaByMat('Mortar MT') returns the combined area of the components that use the material “Mortar MT” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompAreaByMat(t=wall, 'Mortar MT') returns the combined area of the components that use the material “Mortar MT” for all walls in the drawing
CompClassByMat(material)
The class of the specified wall, slab, or roof component. Material is a string that specifies the component's material. If multiple components use the specified material the first component class will be returned.
Database header cell:
=CompClassByMat('Mortar MT') returns the class of the first component that uses the material “Mortar MT” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompClassByMat(t=wall, 'Mortar MT') returns the class of the first component that uses the material “Mortar MT” for all walls in the drawing
CompLambdaByMat(material)
The Lambda value of the specified wall, slab, or roof component. Material is a string that specifies the component's material. If multiple components use the specified material the lambda value of the first matching component will be returned.
Database header cell:
=CompLambdaByMat('Mortar MT') returns the Lambda value of the first component that uses the material “Mortar MT” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompLambdaByMat(t=wall,'Mortar MT') returns the Lambda value of the first component that uses the material “Mortar MT” for all walls in the drawing
CompNameByMat(material)
The name of the specified wall, slab, or roof component. Material is a string that specifies the component's material. If multiple components use the specified material the first component name will be returned.
Database header cell:
=CompNameByMat('Mortar MT') returns the name of the first component that uses the material “Mortar MT” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompNameByMat(t=wall,'Mortar MT') returns the name of the first component that uses the material “Mortar MT” for all walls in the drawing
CompRValueByMat(material)
The R-Value of the specified wall, slab, or roof component. Material is a string that specifies the component's material. If multiple components use the specified material the values will be summed.
Database header cell:
=CompRValueByMat('Mortar MT') returns the combined R-values of the components that use the material “Mortar MT” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompRValueByMat(t=wall,'Mortar MT') returns the combined R-values of the components that use the material “Mortar MT” for all walls in the drawing
CompThicknessByMat(material)
The thickness of the specified wall, slab, or roof component. Material is a string that specifies the component's material. If multiple components use the specified material the values will be summed.
Database header cell:
=CompThicknessByMat('Mortar MT') returns the combined thickness of the components that use the material “Mortar MT” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompThicknessByMat(t=wall,'Mortar MT') returns the combined thickness of the components that use the material “Mortar MT” for all walls in the drawing
CompUValueByMat(material)
The U-Value of the specified wall, slab, or roof component. Material is a string that specifies the component's material. If multiple components use the specified material the values will be summed.
Database header cell:
=CompUValueByMat('Mortar MT') returns the combined U-values of the components that use the material “Mortar MT” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompUValueByMat(t=wall,'Mortar MT') returns the combined U-values of the components that use the material “Mortar MT” for all walls in the drawing
CompVolumeByMat(material)
The volume of the specified wall, slab, or roof component. Material is a string that specifies the component's material. If multiple components use the specified material the values will be summed.
Database header cell:
=CompVolumeByMat('Mortar MT') returns the combined volume of the components that use the material “Mortar MT” for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=CompVolumeByMat(t=wall,'Mortar MT') returns the combined volume of the components that use the material “Mortar MT” for all walls in the drawing

Material

MaterialName()
Returns the object's material.
Database header cell:
=MaterialName returns the names of materials in objects for each row in the database

Spreadsheet cell:
=MaterialName(t=SOLIDCSG) returns the names of materials in generic solids in the drawing
MaterialCount()
Returns the object's number of materials.
Database header cell:
=MaterialCount returns the total number of materials in objects for each row in the database

Spreadsheet cell:
=MaterialCount(t=SOLIDCSG) returns the total number of materials in generic solids in the drawing
MaterialTexture()
Returns the name of the object's material's texture assignment.
Database header cell:
=MaterialTexture returns the texture of the material assigned to objects for each row in the database

Spreadsheet cell:
=MaterialTexture(t=SOLIDCSG) returns the texture of the material assigned to the generic solid in the drawing
MatPropertyByName(materialName, propertyName)
Returns the value of the specified property for the specified material.
Spreadsheet cell:
=MatPropertyByName('Mortar MT','MaterialFinish') returns the material finish property for the material “Mortar MT”
MaterialIsSimple()
Returns true if the object's material is a simple material.
Database header cell:
=MaterialIsSimple returns TRUE if the material of the object referenced by the database row is a simple material.

Spreadsheet cell:
=MaterialIsSimple(t=SOLIDCSG) returns TRUE if the material of the generic solid in the drawing is a simple material.
MaterialPartName(materialName)
Returns the name of the material-bearing geometry that uses the specified material in the object.
Database header cell:
=MaterialPartName('Metal Steel MT') returns the name of the first part that uses the material “Metal Steel MT” for each row in the database

Spreadsheet cell:
=MaterialPartName(t=wall, 'Metal Steel MT') returns the name of the first part that uses the material “Metal Steel MT” for walls in the drawing
MaterialSurfaceArea()
Returns the surface area of the object's specified material assignment.
Database header cell:
=MaterialSurfaceArea('Mortar MT') returns the surface area for objects that use the material named “Mortar MT” for all objects for each row in the database

Spreadsheet cell:
=MaterialSurfaceArea(t=wall,'Mortar MT') returns the surface area for objects that use the material named “Mortar MT” for all walls in the drawing
MaterialVolume()
Returns the volume of the object's specified material assignment.
Database header cell:
=MaterialVolume('Mortar MT') returns the volume for objects that use the material named “Mortar MT” for all objects for each row in the database

Spreadsheet cell:
=MaterialVolume(t=wall,'Mortar MT') returns the volume for objects that use the material named “Mortar MT” for all walls in the drawing
MaterialPercent(materialName)
Returns percentage of the object's specified material.
Database header cell:
=MaterialPercent('Mortar MT') returns the percentage of the material “Mortar MT” in all objects for each row in the database

Spreadsheet cell:
=MaterialPercent(t=wall,'Mortar MT') returns the percentage of the material “Mortar MT” for all walls in the drawing
ComponentMaterial(index)
Returns the material of the specified component.
Database header cell:
=ComponentMaterial(2) returns the material used by the second component for each wall, round wall, roof, roof face, and slab object in the database

Spreadsheet cell:
=ComponentMaterial(t=wall,1) returns the material used by the first component for all walls in the drawing
MaterialProperty(propertyName)
Returns the value of the specified property for the material resource.
Database header cell:
=MaterialProperty('MaterialFinish') returns the value of the material property "MaterialCategory" for each material resource in the database

Spreadsheet cell:
=MaterialProperty((t=material) & (n='material-1'), 'MaterialCategory') returns the value of the material property "MaterialCategory" for the material resource named "material-1"

Available property names:

- General info fields
	'MaterialDescription'
	'MaterialKeynote'
	'MaterialMark'

- Physical values
	'MaterialUsesAcousticImpedance' and 'MaterialAcousticImpedance'
	'MaterialUsesAlbedo' and 'MaterialAlbedo'
	'MaterialUsesDensity' and 'MaterialDensity'
	'MaterialUsesEmbodiedCarbon' and 'MaterialEmbodiedCarbon'
	'MaterialUsesEmissivity' and 'MaterialEmissivity'
	'MaterialUsesLambda' and 'MaterialLambda'
	'MaterialUsesModulusOfElasticity' and 'MaterialModulusOfElasticity'
	'MaterialUsesSlipResistance' and 'MaterialSlipResistance'
	'MaterialUsesSoundVelocity' and 'MaterialSoundVelocity'
	'MaterialUsesSpecificGravity' and 'MaterialSpecificGravity'
	'MaterialUsesSpecificHeat' and 'MaterialSpecificHeat'
	'MaterialUsesTensileStrength' and 'MaterialTensileStrength'
	'MaterialUsesThermalExpansionCoefficient' and 'MaterialThermalExpansionCoefficient'
	'MaterialUsesYieldStrength' and 'MaterialYieldStrength'

Construction info
	'MaterialCategory'
	'MaterialClassificationDescription'
	'MaterialCost'
	'MaterialFinish'
	'MaterialIsSurfaceAreaMeasure'
	'MaterialIsVolumetric'
	'MaterialManufacturer'
	'MaterialProductDescription'
	'MaterialProductModel'
	'MaterialProductName'
	'MaterialProductURL'
	'MaterialReferenceID'
	'MaterialSource'
	'MaterialStandard'

Specialized for Adapter

ObjectData('eval adapter plug device', '<RecordName>', '<FieldName>')
Get parameter value or attached record field from the adapter's plug device.
ObjectData('eval adapter plug socket', '<RecordName>', '<FieldName>')
Get parameter value or attached record field from the adapter's plug socket.

Specialized for Circuit

ObjectData('eval circuit destination adapter', '<RecordName>', '<FieldName>')
Get parameter value or attached record field from the circuit's destination adapter.
ObjectData('eval circuit destination device', '<RecordName>', '<FieldName>')
Get parameter value or attached record field from the circuit's destination device.
ObjectData('eval circuit destination socket', '<RecordName>', '<FieldName>')
Get parameter value or attached record field from the circuit's destination socket.
ObjectData('eval circuit route', ['<RecordName>]', '[<FieldName>]')
Get path IDs, parameter values or attached record fields from the circuit's used cable paths. The drawing needs to be analyzed.
ObjectData('eval circuit source adapter', '<RecordName>', '<FieldName>')
Get parameter value or attached record field from the circuit's source adapter.
ObjectData('eval circuit source device', '<RecordName>', '<FieldName>')
Get parameter value or attached record field from the circuit's source device.
ObjectData('eval circuit source socket', '<RecordName>', '<FieldName>')
Get parameter value or attached record field from the circuit's source socket.

Specialized for Curtain Wall

CurtWallFrameLength(classname)
Returns the length of curtain wall frames in class 'classname'.
Database header cell:
=CurtWallFrameLength('') returns the combined length of the curtain wall frames for each curtain wall in the database

Spreadsheet cell:
=CurtWallFrameLength(t=wall, '') returns the combined length of the curtain wall frames for all curtain walls in the drawing
CurtWallPnlAreaGross(classname)
Returns the gross area of the curtain wall panels in class 'classname'.
Database header cell:
=CurtWallPnlAreaGross('') returns the combined gross area of the curtain wall panels for each curtain wall in the database

Spreadsheet cell:
=CurtWallPnlAreaGross(t=wall, '') returns the combined gross area of the curtain wall panels for all curtain walls in the drawing
CurtWallPnlAreaNet(classname)
Returns the net area of the curtain walls panels in class 'classname'.
Database header cell:
=CurtWallPnlAreaNet ('Class-1') returns the combined net area of the curtain wall panels assigned to the class “Class-1” for each curtain wall in the database

Spreadsheet cell:
=CurtWallPnlAreaNet(t=wall, 'Class-1') returns the combined net area of the curtain wall panels assigned to the class “Class-1” for all curtain walls in the drawing

Specialized for Device

ObjectData('eval equipment item', '<RecordName>', '<FieldName>')
Get parameter value or attached record field from the device's corresponding equipment item.

Specialized for Door

Angle('energos')
Get the orientation from the north used in the Energos calculations for this object.

Specialized for Door CW

Angle('energos')
Get the orientation from the north used in the Energos calculations for this object.

Specialized for Hardscape

Depth()
Calculate the depth of the Landscape Area, Hardscape, or Site Model and their components.
ProjectedArea()
Calculate the projected area of the Landscape Area, Hardscape, or Site Model and their components.
ObjectData('component name')
Return the name of the component subpart for Landscape Area, Hardscape, and Site Model.
Area()
Calculate the surface area of the Landscape Area, Hardscape, or Site Model and their components.
SurfaceArea()
Calculate the surface area of the Landscape Area, Hardscape, or Site Model and their components.
Volume()
Calculate the volume of the Landscape Area, Hardscape, or Site Model and their components.

Specialized for Hedgerow

ObjectData('percentage')
Return the percentage value of this plant from a Landscape Area. This must be used on a database row listing the plants of Landscape Areas.
ObjectData('Plant Record', <field>)
Provides access to the Plant Record data of the Landscape Area Plant subparts for edit if the style allows.
ObjectData('rate')
Return the rate value value of this plant from a Landscape Area. This must be used on a database row listing the plants of Landscape Areas.
ObjectData('rate unit')
Return the rate unit string of this plant from a Landscape Area. This must be used on a database row listing the plants of Landscape Areas.
ObjectData('rate with unit')
Return the rate value and unit of this plant from a Landscape Area. This must be used on a database row listing the plants of Landscape Areas.

Specialized for Landscape Area

Depth()
Calculate the depth of the Landscape Area, Hardscape, or Site Model and their components.
ProjectedArea()
Calculate the projected area of the Landscape Area, Hardscape, or Site Model and their components.
ObjectData('component name')
Return the name of the component subpart for Landscape Area, Hardscape, and Site Model.
ObjectData('divider')
Return the divider string or empty of this divider from a Landscape Area. This must be used on a database row listing the dividers/plants of Landscape Areas.
ObjectData('Landscape Area', <field>)
Provides access to the Landscape Area data field for edit if the style allows.
ObjectData('percentage')
Return the percentage value of this plant from a Landscape Area. This must be used on a database row listing the plants of Landscape Areas.
ObjectData('Plant Record', <field>)
Provides access to the Plant Record data of the Landscape Area Plant subparts for edit if the style allows.
ObjectData('rate')
Return the rate value value of this plant from a Landscape Area. This must be used on a database row listing the plants of Landscape Areas.
ObjectData('rate unit')
Return the rate unit string of this plant from a Landscape Area. This must be used on a database row listing the plants of Landscape Areas.
ObjectData('rate with unit')
Return the rate value and unit of this plant from a Landscape Area. This must be used on a database row listing the plants of Landscape Areas.
Area()
Calculate the surface area of the Landscape Area, Hardscape, or Site Model and their components.
SurfaceArea()
Calculate the surface area of the Landscape Area, Hardscape, or Site Model and their components.
Volume()
Calculate the volume of the Landscape Area, Hardscape, or Site Model and their components.

Specialized for Lighting Device

Weight(criteria)
Returns the total weight of the Lighting Device and all it's accessories.
ObjectData('Lighting Device', <field>)
Provides access to the Instrument Type of Lighting Device accessories. Use no parameters for all cells and accessories or use parameters to specify cells or accessories.
ObjectData('Lighting Device', <field>)
Provides access to a data of the Lighting Device accessory. Use the first parameter to specify the universal parameter name. Use no parameters additional for all cells and accessories or use additional parameters to specify cells or accessories.
ObjectData('Lighting Device', <field>)
Provides access to the symbol names of Lighting Device accessories. Use no parameters for all cells and accessories or use parameters to specify cells or accessories.
ObjectData('Lighting Device', <field>)
Provides access to a parameter of the Lighting Devices and ignores accessories. Use parameters to specify the universal parameter name.
ObjectData('Lighting Device', <field>)
Provides access to the channel of Lighting Devices. Use no parameters for all cells and accessories or use parameters to specify cells or accessories.
ObjectData('Lighting Device', <field>)
Provides access to the color of Lighting Devices. Use no parameters for all cells and accessories or use parameters to specify cells or accessories.
ObjectData('Lighting Device', <field>)
Provides access to a parameter of Lighting Devices. Use parameters to specify the universal parameter name, cell number and accessory number.

Specialized for Plant

PlantImage(index)
Returns an image of the object at the specified index.
Database header cell:
=PlantImage(2) displays the image specified for Image Detail in the More Data pane of the plant symbol definition

Spreadsheet cell:
=PlantImage((‘Plant’.’plant ID’=’TaxfR’), 4) displays the image specified for Custom Image in the More Data pane of the plant symbol definition with a plant ID of TaxfR

Specialized for Railing/Fence

Width()
Width([optional parameter])

This function is applicable to the following subparts: Wall Bracket, Face Mount, Frame and Panel.

OPTIONAL PARAMETER: 'subpart=...': If provided, only the given subpart is included.

QUANTITY DESCRIPTION: For Wall Bracket: Horizontal dimension of the Top Rails Wall Bracket.

For Face Mount: Horizontal dimension of the Face Mount Post.

For Frame: Width of the rectangular frame.

For Panel: Width of the panel in elevation.

Width('profile')
Width('profile', [optional parameter])

This function is applicable to the following subparts: Top Rail, Post, Crossbar Top and Bottom, Bar Vertical and Horizontal, Frame.

OPTIONAL PARAMETER: 'subpart=...': If provided, only the given subpart is included.

QUANTITY DESCRIPTION: For Top Rail: Width of the Railings TopRail cross section profile. For round or octagonal shape of profile, width equals height. For custom profile (symbol), the bounding box is used to calculate this value.

For Post: Width of the Posts cross section profile.

For Crossbar Top and Crossbar Bottom: Width of the profile of the crossbar.

For Bar Vertical and Bar Horizontal: Width of the vertical bars profile.

Height()
Height([optional parameter])

This function is applicable to the Railing object and the following subparts: Top Rail, Wall Bracket, Post, Face Mount, Frame, Panel.

OPTIONAL PARAMETER: 'subpart=...': If provided, only the given subpart is included.

QUANTITY DESCRIPTION: For Railing object: The height of the railing, measured as the vertical distance between the top of the floor or stair (which is Height Point 1 in the object info palette) and the top of the highest subpart of the Railing (Top Rail if available, Frame, Panel or Crossbar Top). This value is written into the IFC-field Pset_RailingCommon.Height.

For Top Rail: Height of the TopRail, measured as the distance between the top of the floor or stair (which is Height Point 1 in the object info palette) and the top of the Railings Top Rail.

For Wall Bracket: Vertical dimension of the Top Rails Wall Bracket.

For Post: Height of the Post.

For Face Mount: Vertical dimension of the Face Mount Post.

For Frame: Height of the rectangular frame.

For Panel: Height of the panel in elevation.

Height('profile')
Height('profile', [optional parameter])

This function is applicable to the following subparts: Top Rail, Post, Crossbar Top and Bottom, Bar Vertical and Horizontal, Frame.

OPTIONAL PARAMETER: 'subpart=...': If provided, only the given subpart is included.

QUANTITY DESCRIPTION: For Top Rail: Height of the Railings TopRail cross section profile. For round or octagonal shape of profile, width equals height. For custom profile (symbol), the bounding box is used to calculate this value.

For Post: Height of the Posts cross section profile.

For Crossbar Top and Crossbar Bottom: Height of the profile of the crossbar.

For Bar Vertical and Bar Horizontal: Height of the vertical bars profile.

Count('angle')
Count('angle', [optional parameter])

This function is applicable to the Railing object and the Top Rail.

OPTIONAL PARAMETER: 'subpart=...': If provided, only the given subpart is included.

QUANTITY DESCRIPTION: For Railing: Number of vertices that change the path without the beginning and end. Or IOW: the number of angles in the path..

For Top Rail: Number of angles in the Top Rail subpart.

Angle()
Angle([optional parameter])

This function is applicable to the following subparts: Bar Vertical and Bar Horizontal.

OPTIONAL PARAMETER: 'subpart=...': If provided, only the given subpart is included.

QUANTITY DESCRIPTION: For Bar Vertical: Angle of the vertical bars. Vertical is 0°.

For Bar Horizontal: Angle of the horizontal bar. horizontal is 0°.

Area()
Area([optional parameter])

This function is applicable to the Railing object and the Panel subpart.

OPTIONAL PARAMETER: 'subpart=...': If provided, only the given subpart is included.

QUANTITY DESCRIPTION: For Railing: Area of the Railing object measured by Railing Length multiplied by Railing Height. Length is the distance between the outer edges of the first and last post or between the infills, whichever results in the higher value. Extended handrails are excluded. This Length differs from buildingSMART standard which is stored in the Railing objects record field RailingLengthIFC. The height of the railing is measured as the vertical distance between the top of the floor or stair (which is Height Point 1 in the object info palette) and the top of the highest subpart of the Railing (Top Rail if available, Frame, Panel or Crossbar Top).

For Panel: Area of the panel (Width x Height).

Perimeter()
Length()
Length([optional parameter])

This function is applicable to the Railing object and the following subparts: Top Rail, Crossbar Top, Crossbar Bottom, Bar Vertical, Bar Horizontal, Frame.

OPTIONAL PARAMETER: 'subpart=...': If provided, only the given subpart is included.

QUANTITY DESCRIPTION: For Railing object: It is the distance between the outer edges of the first and last post or between the infills, whichever results in the higher value. Extended handrails are excluded. This Length differs from buildingSMART standard which is stored in the Railing objects record field RailingLengthIFC and written into Qto_RailingBaseQuantities.Length and BaseQuantities.Length.

For Top Rail: Length of the 3D path object of the top rail including extensions of the Top Rail at beginning or end of the Railing object.

For Crossbar Top and Bottom: Length of the crossbar.

For Bar Vertical and Horizontal: Length of the bar.

For Frame: It is the same value as for Width when applied to a Frame.

Length('max')
Maximum occuring distance between the axes of all instances of a subparts.

Eligible subparts are Wall Bracket, Post and Face Mount.

OPTIONAL PARAMETER: 'subpart=...': If provided, only the given subpart is included.

QUANTITY DESCRIPTION: For Wall Bracket: Returns the maximum distance between the axes of all Wall Brackets occuring anywhere in the Railing object.

For Post: Maximum occuring distance between the axes of all posts.

For Face Mount: Maximum Distance between the axes of all Face Mounts.

SurfaceArea()
SurfaceArea([optional parameter])

This function is applicable to the following subparts: Top Rail, Wall Bracket, Post, Face Mount, Crossbar Top and Bottom, Bar Vertical and Horizontal, Frame, Panel.

OPTIONAL PARAMETER: 'subpart=...': If provided, only the given subpart is included.

QUANTITY DESCRIPTION: For Top Rail: Outer surface of the top rail on all sides including the two caps at beginning and end.

For Wall Bracket: Complete outer surface of the Top Rails Wall Bracket.

For Post: Complete Outer Surface of the Post including the sides which face the stair or wall or handrail.

For Face Mount: Complete Outer Surface of the Face Mount Post including the caps surfaces which are mounted against a wall, post, stair or other object.

For Crossbar Top and Bottom: Complete Surface of all sides of the crossbar.

Bar Vertical and Horizontal: Complete Surface of all sides of the bar.

For Frame: Complete Surface of the rectangular frame.

For Panel: Complete surface area of all sides of the panel.

Specialized for Roof

ObjectData('Component Name')
Returns the name of the wall, slab or roof component.
ObjectData('Cost Index Code')
ObjectData('Cost Index System')
ObjectData('Description')
ObjectData('Exterior')
ObjectData('Fire Rating')
ObjectData('Function')
ObjectData('Lambda')
Returns the Lambda value of the object.
ObjectData('Manufacturer')
ObjectData('Mark')
ObjectData('Model')
ObjectData('RValue')
Returns the R-Value of the object.
ObjectData('UValue')
Returns the U-Value of the object.
RoofArea_Total()
Returns the total area along the slope of a roof.
Database header cell:
=RoofArea_Total returns the total area for each roof and roof face object in the database

Spreadsheet cell:
=RoofArea_Total(st=roofface) returns the combined total area of all roof face objects in the drawing
RoofArea_Heated()
Returns the heated area along the slope of a roof.

The heated area is the area that does not include an overhang.

Database header cell:
=RoofArea_Heated returns the heated area for each roof and roof face object in the database

Spreadsheet cell:
=RoofArea_Heated (st=roofface) returns the combined heated area of all roof face objects in the drawing
RoofArea_TotalProj()
Returns the total area of a roof projected on the active layer plane.
Database header cell:
=RoofArea_TotalProj returns the total area for each roof and roof face object in the database, as projected to the layer plane

Spreadsheet cell:
=RoofArea_Totalproj(t=roof) returns the combined total area of all roof objects in the drawing, as projected to the layer plane
RoofArea_HeatedProj()
Returns the heated area of a roof projected on the active layer plane.

The heated area is the area that does not include an overhang.

Database header cell:
=RoofArea_HeatedProj returns the heated area for each roof and roof face object in the database, as projected to the layer plane

Spreadsheet cell:
=RoofArea_HeatedProj (t=roof) returns the combined heated area of all roof objects in the drawing, as projected to the layer plane
RoofStyleName()
Returns the name the roof style used by the object.
Database header cell:
=RoofStyleName returns the roof style name for each roof object in the database

Spreadsheet cell:
=RoofStyleName(n='roof-1') returns the roof style name for the object named “roof-1”

Specialized for Site Model

Depth()
Calculate the depth of the Landscape Area, Hardscape, or Site Model and their components.
ProjectedArea()
Calculate the projected area of the Landscape Area, Hardscape, or Site Model and their components.
ObjectData('component name')
Return the name of the component subpart for Landscape Area, Hardscape, and Site Model.
Area()
Calculate the surface area of the Landscape Area, Hardscape, or Site Model and their components.
SurfaceArea()
Calculate the surface area of the Landscape Area, Hardscape, or Site Model and their components.
SurfaceArea( 'existing' )
Calculate the existing surface area of the Site Model and their components.
Database header cell:
=SURFACEAREA('Existing')     Returns the existing Surface Area for Site Model object or component in the DB row.

Spreadsheet cell:
=SURFACEAREA(SEL; 'Existing')    Returns the existing Surface Area for the selected Site Model object.
SurfaceArea( 'proposed' )
Calculate the proposed surface area of the Site Model and their components.
Database header cell:
=SURFACEAREA('Proposed')     Returns the proposed Surface Area for Site Model object or component in the DB row.

Spreadsheet cell:
=SURFACEAREA(SEL; 'Proposed')    Returns the proposed Surface Area for the selected Site Model object.
Volume()
Calculate the volume of the Landscape Area, Hardscape, or Site Model and their components.
Volume('existing')
Calculate the existing volume of the Site Model and their components.
Database header cell:
=VOLUME('existing')     	Returns the existing volume for Site Model object or component in the DB row.

Spreadsheet cell:
=VOLUME(SEL, 'existing')    Returns the existing volume for the selected Site Model object.
Volume('proposed')
Calculate the proposed volume of the Site Model and their components.
Database header cell:
=VOLUME('proposed')     	Returns the proposed volume for Site Model object or component in the DB row.

Spreadsheet cell:
=VOLUME(SEL, 'proposed')    Returns the proposed volume for the selected Site Model object.

Specialized for Slab

Weight('gross', [optional parameters])
Returns the weight of a slab or slab component in kg. All openings are ignored.

'component name=...': If provided, only openings in the components with the given name will be counted.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.

Weight('net', [optional parameters])
Returns the weight of a slab or slab component in kg.

'component name=...': If provided, only openings in the components with the given name will be counted.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.

ObjectData('Acoustic Rating')
ObjectData('Combustible Construction')
ObjectData('Compartmentation')
ObjectData('Component Name')
Returns the name of the wall, slab or roof component.
ObjectData('Cost Index Code')
ObjectData('Cost Index System')
ObjectData('Description')
ObjectData('Exterior')
ObjectData('Fire Rating')
ObjectData('Function')
ObjectData('Lambda')
Returns the Lambda value of the object.
ObjectData('Load Bearing')
ObjectData('Manufacturer')
ObjectData('Mark')
ObjectData('Model')
ObjectData('RValue')
Returns the R-Value of the object.
ObjectData('UValue')
Returns the U-Value of the object.
Width()
Returns the thickness of a wall, slab, roof or a roof face object or their components.
Count('modifiers', [optional parameters])
Returns the number of modifiers in a slab or wall. For walls, recesses and projections are counted. For slabs, additions, subtractions and drains are counted.

'modifier type=...': If provided, only modifiers with any of the given types are counted. Multiple types can be delimited by a semicolon.

'exclude modifier type=...': If provided, modifiers with any of the given types will not be counted.

Count('openings', [optional parameters])
Returns the number of openings in a wall, wall component, slab or slab component.

'component name=...': If provided, only openings in the components with the given name will be counted.

'component material=...': If provided, only openings in the components with the given material will be counted.

'component=...': If provided, only openings in the given components will be counted. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.

opening criteria: If provided, only openings that satisfy all given criteria will be counted. If the values don't have any units specified, millimeters, square millimeters or cubic millimeters will be assumed. For slabs, the following criteria are available: min opening area top, max opening area top, min opening area bottom, max opening area bottom, min opening volume, max opening volume, min opening perimeter top, max opening perimeter top, min opening perimeter bottom, max opening perimeter bottom. For walls, the following criteria are available: min opening area left, max opening area left, min opening area right, max opening area right, min opening area facing core, max opening area facing core, min opening area avert core, max opening area avert core, min opening area center, max opening area center, min opening area footprint, max opening area footprint, min opening length footprint left, max opening length footprint left, min opening length footprint right, max opening length footprint right, min opening length footprint facing core, max opening length footprint facing core, min opening length footprint avert core, max opening length footprint avert core, min opening length footprint center, max opening length footprint center, min opening volume, max opening volume.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon. Only applicable for walls.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted. Only applicable for walls.

'height=...': Specifies the height relative to the layer plane at which the footprint area and length along footprint criteria are measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.

=Count('openings') returns the number of openings in the wall, wall component, slab or slab component.

=Count('openings', 'min opening volume=10 cu cm') returns the number of openings with a volume of at least 10 cubic centimeters.

=Count('openings', 'min opening area top=0.5 sq m', 'max opening area top=1 sq m') returns the number of openings with an area between 0.5 and 1 square meter on the top of the slab or slab component.

=Count('openings', 'min opening area bottom=1 sq ft', 'max opening volume=10 cu in') returns the number of openings with an area of at least 1 square foot on the bottom of the slab or slab component and a volume of at most 10 cubic inches.

=Count('openings', 'opening type=Window') returns the number of openings created by "Window" plug-in objects.

=Count('openings', 'opening type=Window;WinDoor 6.0') returns the number of openings created by "Window" and "WinDoor 6.0" plug-in objects.

=Count('openings', 'component=core', 'min opening volume=10 cu cm') returns the number of openings with a volume of at least 10 cubic centimeters in the wall core component.

The difference between Count('inserts') and Count('openings') is that in the rare cases where two inserts share the same opening, Count('inserts') will treat them as different inserts, but Count('openings') will treat them as one large opening.
Angle('energos')
Get the orientation from the north used in the Energos calculations for this object.
SlabThickness()
Returns the thickness of slab objects.
Database header cell:
=SlabThickness returns the thickness for each object in the database

Spreadsheet cell:
=SlabThickness(PON=slab) returns the combined thickness of all slab objects in the drawing
SlabStyleName()
Returns the name of the slab style used by the slab.
Database header cell:
=SlabStyleName returns the name of the slab style for each slab object in the database

Spreadsheet cell:
=SlabStyleName(n='slab-1') returns the name of the slab style for the object named “slab-1”
Area()
Returns the area of a wall, slab, roof or a roof face object or their components.
Perim('bottom', [optional parameters])
Returns the perimeter of the bottom surface of a slab or slab component.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are top, bottom or a number indicating the component index.

Perim('openings bottom', [optional parameters])
Returns the sum of the opening perimeters on the bottom surface of a slab or slab component.

'component name=...': If provided, only openings in the components with the given name will be included.

'component material=...': If provided, only openings in the components with the given material will be included.

'component=...': If provided, only openings in the given components will be included. Possible values are top, bottom or a number indicating the component index.

'min opening perimeter=...' / 'max opening perimeter=...': If provided, only openings with a perimeter of at least min opening perimeter and at most max opening perimeter will be included. If the values don't have any units specified, millimeters will be assumed.

Perim('openings top', [optional parameters])
Returns the sum of the opening perimeters on the top surface of a slab or slab component.

'component name=...': If provided, only openings in the components with the given name will be included.

'component material=...': If provided, only openings in the components with the given material will be included.

'component=...': If provided, only openings in the given components will be included. Possible values are top, bottom or a number indicating the component index.

'min opening perimeter=...' / 'max opening perimeter=...': If provided, only openings with a perimeter of at least min opening perimeter and at most max opening perimeter will be included. If the values don't have any units specified, millimeters will be assumed.

Perim('top', [optional parameters])
Returns the perimeter of the top surface of a slab or slab component.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are top, bottom or a number indicating the component index.

SurfaceArea('bottom gross', [optional parameters])
Returns the area of the bottom surface of a slab or slab component. All openings are ignored.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are top, bottom or a number indicating the component index.

=SurfaceArea('bottom gross') returns the gross area of the bottom face of the slab or slab component.

=SurfaceArea('bottom gross', 'component=top') returns the gross area of the bottom face of the top component of the slab.
SurfaceArea('bottom net', [optional parameters])
Returns the area of the bottom surface of a slab or slab component.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are top, bottom or a number indicating the component index.

'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.

=SurfaceArea('bottom net') returns the area of the bottom face of the slab or slab component.

=SurfaceArea('bottom net', 'min opening area=0.5 sq m') returns the area of the bottom face of the slab or slab component, but ignoring any openings under 0.5 square meters.

=SurfaceArea('bottom net', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the area of the bottom face of the slab or slab component, but ignoring any openings under 0.5 square meters or over 1 square meter.

=SurfaceArea('bottom net', 'component=top') returns the area of the bottom face of the top component of the slab.
SurfaceArea('openings bottom', [optional parameters])
Returns the area of the openings on the bottom surface of a slab or slab component.

'component name=...': If provided, only openings in the components with the given name will be included.

'component material=...': If provided, only openings in the components with the given material will be included.

'component=...': If provided, only openings in the given components will be included. Possible values are top, bottom or a number indicating the component index.

'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.

=SurfaceArea('openings bottom') returns the total area of openings on the bottom face of the slab or slab component.

=SurfaceArea('openings bottom', 'min opening area=0.5 sq m') returns the total area of openings on the bottom face of the slab or slab component, but ignoring any openings under 0.5 square meters.

=SurfaceArea('openings bottom', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the total area of openings on the bottom face of the slab or slab component, but ignoring any openings under 0.5 square meters or over 1 square meter.

=SurfaceArea('openings bottom', 'component=top') returns the total area of openings on the bottom face of the top component of the slab.
SurfaceArea('openings top', [optional parameters])
Returns the area of the openings on the top surface of a slab or slab component.

'component name=...': If provided, only openings in the components with the given name will be included.

'component material=...': If provided, only openings in the components with the given material will be included.

'component=...': If provided, only openings in the given components will be included. Possible values are top, bottom or a number indicating the component index.

'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.

=SurfaceArea('openings top') returns the total area of openings on the top face of the slab or slab component.

=SurfaceArea('openings top', 'min opening area=0.5 sq m') returns the total area of openings on the top face of the slab or slab component, but ignoring any openings under 0.5 square meters.

=SurfaceArea('openings top', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the total area of openings on the top face of the slab or slab component, but ignoring any openings under 0.5 square meters or over 1 square meter.

=SurfaceArea('openings top', 'component=bottom') returns the total area of openings on the top face of the bottom component of the slab.
SurfaceArea('top gross', [optional parameters])
Returns the area of the top surface of a slab or slab component. All openings are ignored.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are top, bottom or a number indicating the component index.

=SurfaceArea('top gross') returns the gross area of the top face of the slab or slab component.

=SurfaceArea('top gross', 'component=bottom') returns the gross area of the top face of the bottom component of the slab.
SurfaceArea('top net', [optional parameters])
Returns the area of the top surface of a slab or slab component.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are top, bottom or a number indicating the component index.

'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.

=SurfaceArea('top net') returns the area of the top face of the slab or slab component.

=SurfaceArea('top net', 'min opening area=0.5 sq m') returns the area of the top face of the slab or slab component, but ignoring any openings under 0.5 square meters.

=SurfaceArea('top net', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the area of the top face of the slab or slab component, but ignoring any openings under 0.5 square meters or over 1 square meter.

=SurfaceArea('top net', 'component=bottom') returns the area of the top face of the bottom component of the slab.
Volume()
Returns the volume of a wall, slab, roof or a roof face object or their components.
Volume('gross', [optional parameters])
Returns the volume of a wall, wall component, slab or slab component. All openings are ignored.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.

=Volume('gross') returns the gross volume of the wall, wall component, slab or slab component.

=Volume('gross', 'component=core') returns the gross volume of the core wall component.
Volume('net', [optional parameters])
Returns the volume of a wall, wall component, slab or slab component.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.

'min opening volume=...' / 'max opening volume=...': If provided, only openings with a volume of at least min opening volume and at most max opening volume will be included. If the values don't have any units specified, cubic millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon. Only applicable for walls.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted. Only applicable for walls.

=Volume('net') returns the volume of the wall, wall component, slab or slab component.

=Volume('net', 'min opening volume=10 cu cm') returns the volume of the wall, wall component, slab or slab component, but only taking openings with at least 10 cubic centimeters of volume into account.

=Volume('net', 'min opening volume=10 cu cm', 'max opening volume=1 cu m') returns the volume of the wall, wall component, slab or slab component, but only taking openings with between 10 cubic centimeters and 1 cubic meter of volume into account.

=Volume('net', 'opening type=Window') returns the volume of the wall or wall component, but only taking openings created by "Window" plug-in objects into account.

=Volume('net', 'opening type=Window;WinDoor 6.0') returns the volume of the wall or wall component, but only taking openings created by "Window" and "WinDoor 6.0" plug-in objects into account.

=Volume('net', 'component=core', 'min opening volume=10 cu cm') returns the volume of the core wall component, but only taking openings with a volume of at least 10 cubic centimeters into account.
Volume('openings', [optional parameters])
Returns the volume of the openings in a wall, wall component, slab or slab component.

'component name=...': If provided, only openings in the components with the given name will be included.

'component material=...': If provided, only openings in the components with the given material will be included.

'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.

'min opening volume=...' / 'max opening volume=...': If provided, only openings with a volume of at least min opening volume and at most max opening volume will be included. If the values don't have any units specified, cubic millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon. Only applicable for walls.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted. Only applicable for walls.

=Volume('openings') returns the total volume of openings in the wall, wall component, slab or slab component.

=Volume('openings', 'min opening volume=10 cu cm') returns the total volume of openings with a volume of at least 10 cubic centimeters.

=Volume('openings', 'min opening volume=10 cu cm', 'max opening volume=1 cu m') returns the total volume of openings with a volume of at least 10 cubic centimeters and at most 1 cubic meter.

=Volume('openings', 'opening type=Window') returns the total volume of openings created by "Window" plug-in objects.

=Volume('openings', 'opening type=Window;WinDoor 6.0') returns the total volume of openings created by "Window" and "WinDoor 6.0" plug-in objects.

=Volume('openings', 'component=core', 'min opening volume=10 cu cm') returns the total volume of openings with a volume of at least 10 cubic centimeters in the wall core component.

Specialized for Socket

ObjectData('eval socket circuits', '<RecordName>', '<FieldName>')
Get parameter values or attached record fields from the socket's connected circuits.
ObjectData('eval socket device', '<RecordName>', '<FieldName>')
Get parameter value or attached record field from the socket's device.

Specialized for Space

GetSpaceNameForObj()
Returns the name of the space that surrounds the object.
Database header cell:
=GetSpaceNameForObj returns the space name for each object in the database

Spreadsheet cell:
=GetSpaceNameForObj(n='chair-1') returns the space name for the object named “chair-1”
GetSpaceNumForObj()
Returns the number of the space that surrounds the object.
Database header cell:
=GetSpaceNumForObj returns the space number for each object in the database

Spreadsheet cell:
=GetSpaceNumForObj(n='chair-1') returns the space number for the object named “chair-1”

Specialized for Structural Member

ObjectData(criteria, 'cover bound bottom')
Returns the bottom bound of the structural member cover.
Database header cell:
=OBJECTDATA('cover bound bottom')     Returns the bottom bound of the Structural Member cover.

Spreadsheet cell:
=OBJECTDATA(SEL; 'cover bound bottom')    Returns the bottom bound of the Structural Member cover.
ObjectData(criteria, 'cover bound top')
Returns the top bound of the Structural Member cover.
Database header cell:
=OBJECTDATA('cover bound top')     Returns the top bound of the Structural Member cover.

Spreadsheet cell:
=OBJECTDATA(SEL; 'cover bound top')    Returns the top bound of the Structural Member cover.
ObjectData(criteria, 'cover physical length')
Returns the physical length of the structural member cover including its start and end conditions.
Database header cell:
=OBJECTDATA('cover physical length')     Returns the physical length of the structural member cover including its start and end conditions.

Spreadsheet cell:
=OBJECTDATA(SEL; 'cover physical length')    Returns the physical length of the structural member cover including its start and end conditions.
ObjectData(criteria, 'member bound bottom')
Returns the bottom bound of the Structural Member.
Database header cell:
=OBJECTDATA('member bound bottom')     Returns the bottom bound of the Structural Member.

Spreadsheet cell:
=OBJECTDATA(SEL; 'member bound bottom')    Returns the bottom bound of the Structural Member.
ObjectData(criteria, 'member bound top')
Returns the top bound of the Structural Member.
Database header cell:
=OBJECTDATA('member bound top')     Returns the top bound of the Structural Member.

Spreadsheet cell:
=OBJECTDATA(SEL; 'member bound top')    Returns the top bound of the Structural Member.
ObjectData(criteria, 'member physical length')
Returns the physical length of the structural member including its start and end conditions.
Database header cell:
=OBJECTDATA('member physical length')     Returns the physical length of the structural member including its start and end conditions.

Spreadsheet cell:
=OBJECTDATA(SEL; 'member physical length')    Returns the physical length of the structural member including its start and end conditions.

Specialized for Wall

Weight('gross', [optional parameters])
Returns the weight of a slab or slab component in kg. All openings are ignored.

'component name=...': If provided, only openings in the components with the given name will be counted.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.

Weight('net', [optional parameters])
Returns the weight of a slab or slab component in kg.

'component name=...': If provided, only openings in the components with the given name will be counted.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.

FootPrintArea('gross', [optional parameters])
Returns the footprint area of a wall or wall component. All openings are ignored.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

'height=...': Specifies the height relative to the layer plane at which the area is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.

FootPrintArea('net', [optional parameters])
Returns the footprint area of a wall or wall component.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

'height=...': Specifies the height relative to the layer plane at which the area is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.

FootPrintArea('openings', [optional parameters])
Returns the area of the openings in the footprint of a wall or wall component.

'component name=...': If provided, only openings in the components with the given name will be included.

'component material=...': If provided, only openings in the components with the given material will be included.

'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.

'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

'height=...': Specifies the height relative to the layer plane at which the area is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.

ObjectData('Acoustic Rating')
ObjectData('Combustible Construction')
ObjectData('Compartmentation')
ObjectData('Component Name')
Returns the name of the wall, slab or roof component.
ObjectData('Cost Index Code')
ObjectData('Cost Index System')
ObjectData('Description')
ObjectData('Exterior')
ObjectData('Fire Rating')
ObjectData('Function')
ObjectData('Lambda')
Returns the Lambda value of the object.
ObjectData('Load Bearing')
ObjectData('Manufacturer')
ObjectData('Mark')
ObjectData('Model')
ObjectData('Path Type')
Returns the path type of a wall. 0 is line, and 1 is arc.
ObjectData('RValue')
Returns the R-Value of the object.
ObjectData('UValue')
Returns the U-Value of the object.
Width()
Returns the thickness of a wall, slab, roof or a roof face object or their components.
Height('average')
Returns the average height of a wall, including wall peaks and different starting and ending heights.
Height('overall')
Returns the overall height of a wall.
Count('inserts', [optional parameters])
Returns the number of inserts (symbols and parametric objects) in a wall.

'insert type=...': If provided, only inserts with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude insert type=...': If provided, inserts with any of the given types will not be counted.

=Count('inserts') returns the number of inserts in the wall object.

=Count('inserts', 'opening type=Window') returns the number of "Window" plug-in object inserts.

=Count('inserts', 'opening type=Window;WinDoor 6.0') returns the number of by "Window" and "WinDoor 6.0" plug-in object inserts.

The difference between Count('inserts') and Count('openings') is that in the rare cases where two inserts share the same opening, Count('inserts') will treat them as different inserts, but Count('openings') will treat them as one large opening.
Count('modifiers', [optional parameters])
Returns the number of modifiers in a slab or wall. For walls, recesses and projections are counted. For slabs, additions, subtractions and drains are counted.

'modifier type=...': If provided, only modifiers with any of the given types are counted. Multiple types can be delimited by a semicolon.

'exclude modifier type=...': If provided, modifiers with any of the given types will not be counted.

Count('openings', [optional parameters])
Returns the number of openings in a wall, wall component, slab or slab component.

'component name=...': If provided, only openings in the components with the given name will be counted.

'component material=...': If provided, only openings in the components with the given material will be counted.

'component=...': If provided, only openings in the given components will be counted. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.

opening criteria: If provided, only openings that satisfy all given criteria will be counted. If the values don't have any units specified, millimeters, square millimeters or cubic millimeters will be assumed. For slabs, the following criteria are available: min opening area top, max opening area top, min opening area bottom, max opening area bottom, min opening volume, max opening volume, min opening perimeter top, max opening perimeter top, min opening perimeter bottom, max opening perimeter bottom. For walls, the following criteria are available: min opening area left, max opening area left, min opening area right, max opening area right, min opening area facing core, max opening area facing core, min opening area avert core, max opening area avert core, min opening area center, max opening area center, min opening area footprint, max opening area footprint, min opening length footprint left, max opening length footprint left, min opening length footprint right, max opening length footprint right, min opening length footprint facing core, max opening length footprint facing core, min opening length footprint avert core, max opening length footprint avert core, min opening length footprint center, max opening length footprint center, min opening volume, max opening volume.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon. Only applicable for walls.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted. Only applicable for walls.

'height=...': Specifies the height relative to the layer plane at which the footprint area and length along footprint criteria are measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.

=Count('openings') returns the number of openings in the wall, wall component, slab or slab component.

=Count('openings', 'min opening volume=10 cu cm') returns the number of openings with a volume of at least 10 cubic centimeters.

=Count('openings', 'min opening area top=0.5 sq m', 'max opening area top=1 sq m') returns the number of openings with an area between 0.5 and 1 square meter on the top of the slab or slab component.

=Count('openings', 'min opening area bottom=1 sq ft', 'max opening volume=10 cu in') returns the number of openings with an area of at least 1 square foot on the bottom of the slab or slab component and a volume of at most 10 cubic inches.

=Count('openings', 'opening type=Window') returns the number of openings created by "Window" plug-in objects.

=Count('openings', 'opening type=Window;WinDoor 6.0') returns the number of openings created by "Window" and "WinDoor 6.0" plug-in objects.

=Count('openings', 'component=core', 'min opening volume=10 cu cm') returns the number of openings with a volume of at least 10 cubic centimeters in the wall core component.

The difference between Count('inserts') and Count('openings') is that in the rare cases where two inserts share the same opening, Count('inserts') will treat them as different inserts, but Count('openings') will treat them as one large opening.
Angle('energos')
Get the orientation from the north used in the Energos calculations for this object.
WallArea_Net()
Returns the average of the net area of the interior and exterior face of the wall. The net area is adjusted for holes in the wall.
Database header cell:
=WallArea_Net returns the average of the net area of the interior and exterior face of the wall, for each wall in the database; the net area is adjusted for holes in the wall

Spreadsheet cell:
=WallArea_Net(t=wall) returns the average of the net area of the interior and exterior face of the wall, combined for all walls in the drawing; the net area is adjusted for holes in the wall
WallArea_Gross()
Returns the average of the gross area of the interior and exterior face of the wall. The gross area ignores holes in the wall.
Database header cell:
=WallArea_Gross returns the average of the gross area of the interior and exterior face of the wall, for each wall in the database; the gross area ignores holes in the wall

Spreadsheet cell:
=WallArea_Gross(t=wall) returns the average of the gross area of the interior and exterior face of the wall, combined for all walls in the drawing; the gross area ignores holes in the wall
WallAverageHeight()
Returns the average wall height of a wall, including wall peaks and different starting and ending heights.
Database header cell:
=WallAverageHeight returns the average height for each wall object in the database

Spreadsheet cell:
=WallAverageHeight((t=wall)&(sel=true)) returns the average height of all walls that are selected in the drawing
WallThickness()
Returns the thickness of the wall.
Database header cell:
=WallThickness returns the thickness for each wall object in the database

Spreadsheet cell:
=WallThickness(t=wall) returns the combined thickness of all walls in the drawing
WallStyleName()
Returns the name of the wall style used by the wall.
Database header cell:
=WallStyleName returns the name of the wall style for each wall object in the database

Spreadsheet cell:
=WallStyleName(n='wall-1') returns the name of the wall style for the object named “wall-1”
Area()
Returns the area of a wall, slab, roof or a roof face object or their components.
Length()
Returns the length of a wall or its components.
Length('control line avert core', [optional parameters])
Returns the length of the control line of a wall component on the side that's oriented away from the core component. All openings, recesses, projections and peaks are ignored.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

Length('control line center', [optional parameters])
Returns the length of the central control line of a wall or wall component. All openings, recesses, projections and peaks are ignored.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

Length('control line facing core', [optional parameters])
Returns the length of the control line of a wall component on the side that's oriented towards the core component. All openings, recesses, projections and peaks are ignored.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

Length('control line left', [optional parameters])
Returns the length of the left control line of a wall or wall component. All openings, recesses, projections and peaks are ignored.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

Length('control line right', [optional parameters])
Returns the length of the right control line of a wall or wall component. All openings, recesses, projections and peaks are ignored.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

Length('avert core gross', [optional parameters])
Returns the length of a wall component along the bottom of the side that's oriented away from the core component. All openings are ignored.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.

Length('avert core net', [optional parameters])
Returns the length of a wall component along the bottom of the side that's oriented away from the core component.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.

Length('center gross', [optional parameters])
Returns the length of a wall or wall component along the bottom of the center line. All openings are ignored.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.

Length('center net', [optional parameters])
Returns the length of a wall or wall component along the bottom of the center line.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.

Length('facing core gross', [optional parameters])
Returns the length of a wall component along the bottom of the side that's oriented towards the core component. All openings are ignored.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.

Length('facing core net', [optional parameters])
Returns the length of a wall component along the bottom of the side that's oriented towards the core component.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.

Length('left gross', [optional parameters])
Returns the length of a wall or wall component along the bottom of the left face. All openings are ignored.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.

Length('left net', [optional parameters])
Returns the length of a wall or wall component along the bottom of the left face.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.

Length('right gross', [optional parameters])
Returns the length of a wall or wall component along the bottom of the right face. All openings are ignored.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.

Length('right net', [optional parameters])
Returns the length of a wall or wall component along the bottom of the right face.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.

Length('openings avert core', [optional parameters])
Returns the total length of wall or wall component openings along the side of the footprint that's oriented away from the core component.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only openings in the components with the given material will be included.

'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.

'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.

Length('openings center', [optional parameters])
Returns the total length of openings along the center line of the footprint of a wall or wall component.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only openings in the components with the given material will be included.

'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.

'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.

Length('openings facing core', [optional parameters])
Returns the total length of wall or wall component openings along the side of the footprint that's oriented towards the core component.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only openings in the components with the given material will be included.

'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.

'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.

Length('openings left', [optional parameters])
Returns the total length of openings along the left side of the footprint of a wall or wall component.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only openings in the components with the given material will be included.

'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.

'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.

Length('openings right', [optional parameters])
Returns the total length of openings along the right side of the footprint of a wall or wall component.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only openings in the components with the given material will be included.

'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.

'min opening length=...' / 'max opening length=...': If provided, only openings with a length of at least min opening length and at most max opening length will be included. If the values don't have any units specified, millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

'height=...': Specifies the height relative to the layer plane at which the length is measured. A height of 0 is used by default. If the value doesn't have any units specified, millimeters will be assumed.

SurfaceArea('avert core gross', [optional parameters])
Returns the area of a wall component's surface that's oriented away from the core component. All openings are ignored.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

SurfaceArea('avert core net', [optional parameters])
Returns the area of a wall component's surface that's oriented away from the core component.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

SurfaceArea('center gross', [optional parameters])
Returns the area along the center line of a wall or wall component. All openings are ignored.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

=SurfaceArea('center gross') returns the gross area along the center line of the wall or wall component.

=SurfaceArea('center gross', 'component=core') returns the gross area along the center line of the core component of the wall.
SurfaceArea('center net', [optional parameters])
Returns the area along the center line of a wall or wall component.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

=SurfaceArea('center net') returns the area along the center line of the wall or wall component.

=SurfaceArea('center net', 'min opening area=0.5 sq m') returns the area along the center line of the wall or wall component, but ignoring any openings under 0.5 square meters.

=SurfaceArea('center net', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the area along the center line of the wall or wall component, but ignoring any openings under 0.5 square meters or over 1 square meter.

=SurfaceArea('center net', 'opening type=Window') returns the area along the center line of the wall or wall component, but only taking openings created by "Window" plug-in objects into account.

=SurfaceArea('center net', 'exclude opening type=Window') returns the area along the center line of the wall or wall component, but ignoring any openings that are created by "Window" plug-in objects.

=SurfaceArea('center net', 'opening type=Window;WinDoor 6.0') returns the area along the center line of the wall or wall component, but only taking openings created by "Window" or "WinDoor 6.0" plug-in objects into account.

=SurfaceArea('center net', 'component=core') returns the area along the center line of the core component of the wall.
SurfaceArea('facing core gross', [optional parameters])
Returns the area of a wall component's surface that's oriented towards the core component. All openings are ignored.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

SurfaceArea('facing core net', [optional parameters])
Returns the area of a wall component's surface that's oriented towards the core component.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

SurfaceArea('left gross', [optional parameters])
Returns the area of the left surface of a wall or wall component. All openings are ignored.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

=SurfaceArea('left gross') returns the gross area of the left side of the wall or wall component.

=SurfaceArea('left gross', 'component=core') returns the gross area of the left side of the core component of the wall.
SurfaceArea('left net', [optional parameters])
Returns the area of the left surface of a wall or wall component.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

=SurfaceArea('left net') returns the area of the left side of the wall or wall component.

=SurfaceArea('left net', 'min opening area=0.5 sq m') returns the area of the left side of the wall or wall component, but ignoring any openings under 0.5 square meters.

=SurfaceArea('left net', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the area of the left side of the wall or wall component, but ignoring any openings under 0.5 square meters or over 1 square meter.

=SurfaceArea('left net', 'opening type=Window') returns the area of the left side of the wall or wall component, but only taking openings created by "Window" plug-in objects into account.

=SurfaceArea('left net', 'exclude opening type=Window') returns the area of the left side of the wall or wall component, but ignoring any openings that are created by "Window" plug-in objects.

=SurfaceArea('left net', 'opening type=Window;WinDoor 6.0') returns the area of the left side of the wall or wall component, but only taking openings created by "Window" or "WinDoor 6.0" plug-in objects into account.

=SurfaceArea('left net', 'component=core') returns the area of the left side of the core component of the wall.
SurfaceArea('openings avert core', [optional parameters])
Returns the area of the openings on a wall component's surface that's oriented away from the core component.

'component name=...': If provided, only openings in the components with the given name will be included.

'component material=...': If provided, only openings in the components with the given material will be included.

'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.

'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

SurfaceArea('openings center', [optional parameters])
Returns the area of the openings along the center line of a wall or wall component.

'component name=...': If provided, only openings in the components with the given name will be included.

'component material=...': If provided, only openings in the components with the given material will be included.

'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.

'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

=SurfaceArea('openings center') returns the total area of openings along the center line of the wall or wall component.

=SurfaceArea('openings center', 'min opening area=0.5 sq m') returns the total area of openings along the center line of the wall or wall component, but ignoring any openings under 0.5 square meters.

=SurfaceArea('openings center', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the total area of openings along the center line of the wall or wall component, but ignoring any openings under 0.5 square meters or over 1 square meter.

=SurfaceArea('openings center', 'opening type=Window') returns the total area of openings along the center line of the wall or wall component, but only taking openings created by "Window" plug-in objects into account.

=SurfaceArea('openings center', 'exclude opening type=Window') returns the total area of openings along the center line of the wall or wall component, but ignoring any openings that are created by "Window" plug-in objects.

=SurfaceArea('openings center', 'opening type=Window;WinDoor 6.0') returns the total area of openings along the center line of the wall or wall component, but only taking openings created by "Window" or "WinDoor 6.0" plug-in objects into account.

=SurfaceArea('openings center', 'component=core') returns the total area of openings along the center line of the core component of the wall.
SurfaceArea('openings facing core', [optional parameters])
Returns the area of the openings on a wall component's surface that's oriented towards the core component.

'component name=...': If provided, only openings in the components with the given name will be included.

'component material=...': If provided, only openings in the components with the given material will be included.

'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.

'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

SurfaceArea('openings left', [optional parameters])
Returns the area of the openings on the left surface of a wall or wall component.

'component name=...': If provided, only openings in the components with the given name will be included.

'component material=...': If provided, only openings in the components with the given material will be included.

'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.

'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

=SurfaceArea('openings left') returns the total area of openings on the left side of the wall or wall component.

=SurfaceArea('openings left', 'min opening area=0.5 sq m') returns the total area of openings on the left side of the wall or wall component, but ignoring any openings under 0.5 square meters.

=SurfaceArea('openings left', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the total area of openings on the left side of the wall or wall component, but ignoring any openings under 0.5 square meters or over 1 square meter.

=SurfaceArea('openings left', 'opening type=Window') returns the total area of openings on the left side of the wall or wall component, but only taking openings created by "Window" plug-in objects into account.

=SurfaceArea('openings left', 'exclude opening type=Window') returns the total area of openings on the left side of the wall or wall component, but ignoring any openings that are created by "Window" plug-in objects.

=SurfaceArea('openings left', 'opening type=Window;WinDoor 6.0') returns the total area of openings on the left side of the wall or wall component, but only taking openings created by "Window" or "WinDoor 6.0" plug-in objects into account.

=SurfaceArea('openings left', 'component=core') returns the total area of openings on the left side of the core component of the wall.
SurfaceArea('openings right', [optional parameters])
Returns the area of the openings on the right surface of a wall or wall component.

'component name=...': If provided, only openings in the components with the given name will be included.

'component material=...': If provided, only openings in the components with the given material will be included.

'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core or a number indicating the component index.

'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

=SurfaceArea('openings right') returns the total area of openings on the right side of the wall or wall component.

=SurfaceArea('openings right', 'min opening area=0.5 sq m') returns the total area of openings on the right side of the wall or wall component, but ignoring any openings under 0.5 square meters.

=SurfaceArea('openings right', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the total area of openings on the right side of the wall or wall component, but ignoring any openings under 0.5 square meters or over 1 square meter.

=SurfaceArea('openings right', 'opening type=Window') returns the total area of openings on the right side of the wall or wall component, but only taking openings created by "Window" plug-in objects into account.

=SurfaceArea('openings right', 'exclude opening type=Window') returns the total area of openings on the right side of the wall or wall component, but ignoring any openings that are created by "Window" plug-in objects.

=SurfaceArea('openings right', 'opening type=Window;WinDoor 6.0') returns the total area of openings on the right side of the wall or wall component, but only taking openings created by "Window" or "WinDoor 6.0" plug-in objects into account.

=SurfaceArea('openings right', 'component=core') returns the total area of openings on the right side of the core component of the wall.
SurfaceArea('right gross', [optional parameters])
Returns the area of the right surface of a wall or wall component. All openings are ignored.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

=SurfaceArea('right gross') returns the gross area of the right side of the wall or wall component.

=SurfaceArea('right gross', 'component=core') returns the gross area of the right side of the core component of the wall.
SurfaceArea('right net', [optional parameters])
Returns the area of the right surface of a wall or wall component.

'component name=...': If provided, components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core or a number indicating the component index.

'min opening area=...' / 'max opening area=...': If provided, only openings with an area of at least min opening area and at most max opening area will be included. If the values don't have any units specified, square millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted.

=SurfaceArea('right net') returns the area of the right side of the wall or wall component.

=SurfaceArea('right net', 'min opening area=0.5 sq m') returns the area of the right side of the wall or wall component, but ignoring any openings under 0.5 square meters.

=SurfaceArea('right net', 'min opening area=0.5 sq m', 'max opening area=1 sq m') returns the area of the right side of the wall or wall component, but ignoring any openings under 0.5 square meters or over 1 square meter.

=SurfaceArea('right net', 'opening type=Window') returns the area of the right side of the wall or wall component, but only taking openings created by "Window" plug-in objects into account.

=SurfaceArea('right net', 'exclude opening type=Window') returns the area of the right side of the wall or wall component, but ignoring any openings that are created by "Window" plug-in objects.

=SurfaceArea('right net', 'opening type=Window;WinDoor 6.0') returns the area of the right side of the wall or wall component, but only taking openings created by "Window" or "WinDoor 6.0" plug-in objects into account.

=SurfaceArea('right net', 'component=core') returns the area of the right side of the core component of the wall.
Volume()
Returns the volume of a wall, slab, roof or a roof face object or their components.
Volume('gross', [optional parameters])
Returns the volume of a wall, wall component, slab or slab component. All openings are ignored.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.

=Volume('gross') returns the gross volume of the wall, wall component, slab or slab component.

=Volume('gross', 'component=core') returns the gross volume of the core wall component.
Volume('net', [optional parameters])
Returns the volume of a wall, wall component, slab or slab component.

'component name=...': If provided, only components with the given name will be included.

'component material=...': If provided, only components with the given material will be included.

'component=...': If provided, only the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.

'min opening volume=...' / 'max opening volume=...': If provided, only openings with a volume of at least min opening volume and at most max opening volume will be included. If the values don't have any units specified, cubic millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon. Only applicable for walls.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted. Only applicable for walls.

=Volume('net') returns the volume of the wall, wall component, slab or slab component.

=Volume('net', 'min opening volume=10 cu cm') returns the volume of the wall, wall component, slab or slab component, but only taking openings with at least 10 cubic centimeters of volume into account.

=Volume('net', 'min opening volume=10 cu cm', 'max opening volume=1 cu m') returns the volume of the wall, wall component, slab or slab component, but only taking openings with between 10 cubic centimeters and 1 cubic meter of volume into account.

=Volume('net', 'opening type=Window') returns the volume of the wall or wall component, but only taking openings created by "Window" plug-in objects into account.

=Volume('net', 'opening type=Window;WinDoor 6.0') returns the volume of the wall or wall component, but only taking openings created by "Window" and "WinDoor 6.0" plug-in objects into account.

=Volume('net', 'component=core', 'min opening volume=10 cu cm') returns the volume of the core wall component, but only taking openings with a volume of at least 10 cubic centimeters into account.
Volume('openings', [optional parameters])
Returns the volume of the openings in a wall, wall component, slab or slab component.

'component name=...': If provided, only openings in the components with the given name will be included.

'component material=...': If provided, only openings in the components with the given material will be included.

'component=...': If provided, only openings in the given components will be included. Possible values are left, right, core (for walls), top, bottom (for slabs) or a number indicating the component index.

'min opening volume=...' / 'max opening volume=...': If provided, only openings with a volume of at least min opening volume and at most max opening volume will be included. If the values don't have any units specified, cubic millimeters will be assumed.

'opening type=...': If provided, only openings created by objects with any of the given names will be counted. Multiple names can be delimited by a semicolon. Only applicable for walls.

'exclude opening type=...': If provided, openings created by objects with any of the given names will not be counted. Only applicable for walls.

=Volume('openings') returns the total volume of openings in the wall, wall component, slab or slab component.

=Volume('openings', 'min opening volume=10 cu cm') returns the total volume of openings with a volume of at least 10 cubic centimeters.

=Volume('openings', 'min opening volume=10 cu cm', 'max opening volume=1 cu m') returns the total volume of openings with a volume of at least 10 cubic centimeters and at most 1 cubic meter.

=Volume('openings', 'opening type=Window') returns the total volume of openings created by "Window" plug-in objects.

=Volume('openings', 'opening type=Window;WinDoor 6.0') returns the total volume of openings created by "Window" and "WinDoor 6.0" plug-in objects.

=Volume('openings', 'component=core', 'min opening volume=10 cu cm') returns the total volume of openings with a volume of at least 10 cubic centimeters in the wall core component.
WallOverallHeight()
Returns the overall height of walls.
Database header cell:
=WallOverallHeight returns the average overall height for each wall object in the database

Spreadsheet cell:
=WallOverallHeight((t=wall)&(sel=true)) returns the average overall height of all walls that are selected in the drawing

Specialized for WinDoor

Angle('energos')
Get the orientation from the north used in the Energos calculations for this object.

Specialized for Window

Angle('energos')
Get the orientation from the north used in the Energos calculations for this object.

Specialized for Window CW

Angle('energos')
Get the orientation from the north used in the Energos calculations for this object.

Text

concat(text1, text2,...)
Joins several text strings into one text string.
=concat(B3,', ',B4) returns the contents of cells B3 and B4 as a single string, separated by a comma and a space
SubString(text, delimiter, index)
Splits a single string into an array of strings using a delimiter, and returns the string at the specified index.
=SUBSTRING('kitchen;bedroom;bathroom;basement', ';', 2) returns “bedroom,” which is the second substring in the specified string
txt(value, ToUnit, [Param1], [Param2], ...)
Converts a numeric value from document units to the specified units and returns a string representation using the options to control formatting. More information is available in the example.
The first parameter must be <ToUnit> and then a list of optional parameters to fine tune the conversion.

Parameter Details:
 - <ToUnit> - the units in which the value will be converted from the current document units
	Possible options are for using the current document units:
		Dim		- linear dimension 
		Area	- area dimension
		Volume	- volume dimension
		Angle	- angular dimension
		
	General purpose options:
		General	- as a general number
		Sci		- as a scienific number
		Percent	- as a percent number
	
	Linear specific units options (one of the list):
		FeetNInches, Inches, Feet, Miles, Yards, Microns, Millimeters, Centimeters, Meters, Kilometers, Degrees, Ares
	
	Area specific units options (one of the list):
		SquareInches, SquareFeet, SquareYards, SquareMiles, Acres, SquareMicrons, SquareMillimeters, SquareCentimeters, SquareMeters, SquareKilometers, Hectares
	
	Volume specific units options (one of the list):
		CubicInches, CubicFeet, CubicYards, Gallons, CubicMillimeters, CubicCentimeters, CubicMeters, Litres

 - <optional param> - rounding style
		Dec		- decimal representation of the number
		Frac	- fractional representation of the number
		Auto	- will use fractional representation if rounds up to one, or decimal representation if not

 - <optional param> - rounding format
	Decimal rounding represented by the number of digits after the decimal dot.
	Examples:
		0.000	- would round up three digits. e.g. 0.356 if the number is 0.3556678
		0.0		- would round up one digit. e.g. 0.4 if the number is 0.3556678
		0.		- would round up to no digits. e.g. 0 if the number is 0.3556678
	
	Fractional rounding represented by the number after the / symbol, from 1/1 to 1/64 max.
	Examples:
		1/8		- would round to 1/8th
		1/64	- would round to 1/64th
		1/1		- would round to integer number

- <optional param> - rounding base using multiples of tenths, quarters, or halves
		RoundTenth
		RoundQuarter
		RoundHalf

- <optional param> - Units display
		NoUnits
		Units

- <optional param> - thousands separator display
		ThousandsSeparator
		NoThousandsSeparator

- <optional param> - trailing zero display
		NoTrailingZero
		TrailingZero

- <optional param> - leading zero
		NoLeadingZeroes
		LeadingZeroes

Examples:
=TXT(2.45, 'Dim') - returns the number in the documents linear dimensions
=TXT(2.45, 'Feet', 'Frac', '1/16') - returns the number in feet as fraction with 1/16 rounding
isalnum(text)
True if all characters in the string are letters and/or digits and there is at least one character or digit, false otherwise. Real numbers will return False.
=isalnum('word123') returns True
isalpha(text)
True if all characters in the string are alphabetic and there is at least one character, false otherwise.
=isalpha('word') returns True
isdigit(text)
True if all characters in the string are digits and there is at least one digit, false otherwise. Real numbers will return False.
=isdigit('1234') returns True
islower(text)
True if all cased characters in the string are lowercase and there is at least one cased character, false otherwise. Non-alphabetic characters don't have a case and will return true.
=islower('does not have upper char') returns True
isspace(text)
True if there are only whitespace characters in the string and there is at least one character, false otherwise.
=isspace('      ') returns True
istitle(text)
True if the string is a titlecased string and there is at least one character, for example uppercase characters may only follow uncased characters and lowercase characters only cased ones. False otherwise.
=isTitle('This Is Title Text') returns True
isupper(text)
True if all cased characters in the string are uppercase and there is at least one cased character, false otherwise. Non-alphabetic characters don't have a case and will return true.
=isUpper('DOES NOT HAVE LOWER CHARS') returns True
TextJoin(delimiter, text1, text2, …)
The string which is the concatenation of the strings in the sequence seq. The separator between elements is the string providing this method.
=textJoin(', ', 1, 2, 3) returns '1, 2, 3'
Lower(text)
Converts all characters in a text string to lowercase.
=lower('MAKE THIS LOWER') returns 'make this lower'
TrimLeft(text, [chars])
Removes leading characters from a text string. The chars argument is a string specifying the set of characters to be removed. If omitted or None, whitespaces will be removed.
=trimLeft('abbcwordabbc', 'abc') returns 'wordabbc'
Replace(string, oldString, newString, [count])
Replaces occurrences of a substring in a text with a different substring. If the optional argument count is given, only the first count occurrences are replaced.
=replace('my car is your car', 'car', 'ball', 2) returns 'my car is your ball'
TrimRight(text, [chars])
Removes trailing characters from a text string. The chars argument is a string specifying the set of characters to be removed. If omitted or None, whitespaces will be removed.
=trimRight('abbcwordabbc', 'abc') returns 'abbcword'
Trim(text, [chars])
Removes leading and trailing characters from a text string. The chars argument is a string specifying the set of characters to be removed. If omitted or None, whitespaces will be removed.
=trim('abbcwordabbc', 'abc') returns 'word'
Proper(text)
Converts a text string to titlecase. The first letter in each word starts with uppercase characters, all remaining characters are lowercase.
=proper('make this title text') returns 'Make This Title Text'
Upper(text)
Converts all characters in a text string to uppercase.
=upper('make this upper') returns 'MAKE THIS UPPER'
Len(text)
The number of characters in the (text) string.
=len('hello there') returns 11
 
Insert(text, index, textToInsert)
Inserts a text (textToInsert) into an existing text string (text) at specified index position.
=insert('hey, this is ok', 12, ' not') returns 'hey, this is not ok'
Left(text, count)
Returns a string with the specified number of characters from the start of the text value.
=left('this is sample', 4) returns 'this'
Right(text, count)
Returns a string with the specified number of characters from the end of the text value.
=right('this is sample', 6) returns 'sample'
Mid(text, index, count)
Returns a string with the specified number of characters starting at a given position in the text value
=mid('apple', 2, 3) returns 'ppl'
=mid('apple', -4, 3) looking the index backwards, returns 'ppl'
=mid('apple', 4, -3) getting characters backward from the index, returns 'ppl
Delete(text, index, count)
Removes the specified number (count) of characters from the text string starting at a given position (index).
=delete('this is sample', 4, 3) returns 'this sample'. Here 3 characters after the 4th are deleted.
Quote(text)
Returns a the text enclosed in quotation marks.
=quote('quote this') returns "quote this" (The text, in double quotes)
Rept(text, num)
Repeats text a given number of times.
=rept('Line ', 3) returns 'Line Line Line '
Fixed(num, [decimals])
Formats a number as text with a fixed number of decimals.
=fixed(10.12345, 3) returns 10.123 (up to the 3rd digit after the decimal point)
JustNum(num, width)
Returns a numeric string of the specified size (width) with leading zeros appended to the number. The original string is returned if width is less than the original string length.
=justNum(10.123, 8) returns '0010.123'
Char(number)
Returns the Unicode character or text representation (U+1234) referenced by the given number .
=char(8734) returns the symbol ∞
=char('U+221E') also returns ∞
Code(text)
Returns the number (Unicode code point) for the first character of the text.
=code('∞') returns 8734. The unicode codepoint for ∞
Find(subtext, text, [caseSensitive])
The lowest index in the (text) where substring (subtext) is found. If the optional argument (case) is set to true, case-sensitive search is performed. Index of -1 if (subtext) is not found.
=find('text', 'this is text') returns 8
FindPattern(pattern, text, [caseSensitive])
The lowest index in the (text) where the regular expression provided in (pattern) is found. If the optional argument (case) is set to true, case-sensitive search is performed. Index of -1 if (subtext) is not found. Regular expression is a sequence of characters that specifies a search pattern. Uses ECMAScript syntax for the pattern: https://www.cplusplus.com/reference/regex/ECMAScript/?kw=ECMAScript
=findPattern('(Soft)(.*)', 'soft Software', True) returns 5
value(text)
Converts a text string that represents a number to a number.
=value('2e3') returns the numeric value of 2 times 10 raised to the power of 3