Vectorworks Scripting/ja: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Created page with "<div id="location-source"> .Vectorworks Scripting|Scripting ..Python|Python Scripting ..VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Refe...")
 
(Update to reflect the changes in the original page.)
 
(3 intermediate revisions by the same user not shown)
Line 10: Line 10:
</div>
</div>


Vectorworks provides two options for scripting: Python (as of Vectorworks 2014) and VectorScript.
Vectorworks では二つの方法でスクリプティングできます: Python (Vectorworks 2014以降) と VectorScriptです。


== Python Scripting ==
== Python スクリプティング ==


Vectorworks 2014 adds [[http://www.python.org|Python Python]] language as an alternative to VectorScript for creating menu commands, objects, tools, or general purpose scripts.
Vectorworks 2014 では VectorScriptに加えて、[[http://www.python.org|Python Python]] 言語がメニューコマンド、オブジェクト、ツール、あるいは一般的なスクリプトのために利用できるようになりました。


You can go to the [[Python]] page for more information.
[[Python]] のページにより詳しい情報があります。


== VectorScript ==
== VectorScript ==


[[VectorScript]] is a Pascal-like language allowing scripting in Vectorworks.
[[VectorScript]] はPascalライクな言語で、Vectorworksでスクリプティングを可能にします。


VectorScript function reference is available [[VS:Function Reference|here]].
VectorScript の関数リファレンスは [[VS:Function Reference|こちら]].


You can also use the [[:Category:VectorScript|main VectorScript category]] to help navigate.
[[:Category:VectorScript|main VectorScript category]] をたどって情報を探すこともできます。
 
== 一般的な例 ==
 
* [[VS:Parametric Custom Opening in Wall]]
* [[VS:Parametric Custom Selection Indication]]
* [[VS:Parametric Custom Shape Pane]]
* [[VS:Parametric Custom Shape Pane Popup]]
* [[VS:Parametric Hide Details]]
* [[VS:Parametric State Notifications]]
* [[VS:Similar Objects Creation]]
* [[VS:Progress Dialog]]
 
== スクリプトのインストール ==
プラグインを作ると、ユーザーフォルダーのプラグインフォルダーに全て保存されます。Vectorworksを実行する度に、そのフォルダーにある全てのプラグインが再帰的に(ショートカットを含めて)ロードされます。いずれかのスクリプト言語で作ったプラグインを他のマシンや、Vectorworksで実行したいこともあるでしょう。Vectorworksプラグインマネージャを使うとスクリプトや他のコンテンツを含んだパッケージをインストールすることができます。単純なインストール例では、指定したプラグイン(zipファイルで)をユーザープラグインフォルダーへ単純にコピーします。インストール用スクリプトが用意されている場合は、そのスクリプトも実行されます。より詳しい説明や事例は、以下のリンクをたどってください。
*[[VS:Basic Installation]]
*[[VS:Implementing Installation Script]]
*[[VS:A more Complicated Installation Script]]
 
== バージョン情報 ==
 
*[[VS:Vectorworks 2016 Development|Vectorworks 2016]]
*[[VS:Vectorworks 2015 Development|Vectorworks 2015]]
*[[VS:Vectorworks 2014 Development|Vectorworks 2014]]
*[[VS:Vectorworks 2013 Development|Vectorworks 2013]]
*[[VS:Vectorworks 2012 Development|Vectorworks 2012]]
*[[VS:Vectorworks 2011 Development|Vectorworks 2011]]
*[[VS:Vectorworks 2010 Development|Vectorworks 2010]]
*[[VS:Vectorworks 2009 Development|Vectorworks 2009]]
 
== 非推奨関数の一覧 ==
 
非推奨関数のすべてのバージョン一覧はこちら:
 
[[VS:Obsolete Functions Table]]

Latest revision as of 12:43, 14 January 2016

.Vectorworks Scripting|Scripting ..Python|Python Scripting ..VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Vectorworks では二つの方法でスクリプティングできます: Python (Vectorworks 2014以降) と VectorScriptです。

Python スクリプティング

Vectorworks 2014 では VectorScriptに加えて、[Python] 言語がメニューコマンド、オブジェクト、ツール、あるいは一般的なスクリプトのために利用できるようになりました。

Python のページにより詳しい情報があります。

VectorScript

VectorScript はPascalライクな言語で、Vectorworksでスクリプティングを可能にします。

VectorScript の関数リファレンスは こちら.

main VectorScript category をたどって情報を探すこともできます。

一般的な例

スクリプトのインストール

プラグインを作ると、ユーザーフォルダーのプラグインフォルダーに全て保存されます。Vectorworksを実行する度に、そのフォルダーにある全てのプラグインが再帰的に(ショートカットを含めて)ロードされます。いずれかのスクリプト言語で作ったプラグインを他のマシンや、Vectorworksで実行したいこともあるでしょう。Vectorworksプラグインマネージャを使うとスクリプトや他のコンテンツを含んだパッケージをインストールすることができます。単純なインストール例では、指定したプラグイン(zipファイルで)をユーザープラグインフォルダーへ単純にコピーします。インストール用スクリプトが用意されている場合は、そのスクリプトも実行されます。より詳しい説明や事例は、以下のリンクをたどってください。

バージョン情報

非推奨関数の一覧

非推奨関数のすべてのバージョン一覧はこちら:

VS:Obsolete Functions Table