Vectorworks Scripting

From Vectorworks Developer
Jump to navigation Jump to search

.Vectorworks Scripting|Scripting ..Python|Python Scripting ..VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Vectorworks provides two options for scripting: Python (as of Vectorworks 2014) and VectorScript.

Python Scripting

Vectorworks 2014 adds [Python] language as an alternative to VectorScript for creating menu commands, objects, tools, or general purpose scripts.

You can go to the Python page for more information.

VectorScript

VectorScript is a Pascal-like language allowing scripting in Vectorworks.

VectorScript function reference is available here.

You can also use the main VectorScript category to help navigate.

Common Tasks

Installing Scripts

When, for the first time, you create a plug-in, Vectorworks puts all of its content in user plug-in path and each time Vectorworks runs it recursiveley load all the Plug-Ins in that path (Also looking for the short-cuts). When you designed and implemented your plug-in in either of the scripting languages, you may want to use it on different machines or VW instances. Vectorworks Plug-in manager allows users to install packages containing scripts and other content. For basic installation it just simply copy provided plug-in (which should be as a zip file) into the user plug-in path. Also if a installation scrpit is provided it will run that script as well. Please follow below links for more explanations and examples.

Version Information

Vectorworks 2013 Vectorworks 2012 Vectorworks 2011 Vectorworks 2010 Vectorworks 2009 VectorWorks 2008 VectorWorks12.5 VectorWorks12.0 VectorWorks10.1 VectorWorks9.0 VectorWorks8.0
GetClLS

SetClLS PenPat SetLS FPenPat GetLS || || || || || || || || || ||

Perim

RightBound TopBound SetLinkHeightToLayerDeltaZ XCenter BotBound YCenter GetLayerDeltaZOffset InsertProposedClassOrLayerItem SetLayerDeltaZOffset GetLinkHeightToLayerDeltaZ AddLBImage CriteriaVolume CriteriaSurfaceArea CriteriaArea InsertEnhancedPullDownMenuItem CreateIconPushButton SetLBMultImageIndexes SetWallHeights ZCenter LeftBound Length WallHeight HWallHeight || || || || || || || || ||

GetType
SetTextureRef

GetTexMapReal SetTexMapReal GetTexMapInt GetTextureRef GetTexMapBool SetTexMapBool SetDefaultTexMap SetTexMapInt || || || || || || ||

SetTexSpaceOrientU

GetTextureSpace GetTexSpaceOrientW GetTexSpaceStartCap SetTexSpaceOrientV SetTexSpaceOrientW GetTexSpaceOrigin SetTexSpaceOrigin SetObjExpandTexture GetObjExpandTexture SetTexSpaceStartCap GetTexSpaceEndCap GetTexSpace2DOffset SetTexSpace2DOffset GetTexSpace2DScale SetTexSpaceEndCap SetTexSpace2DScale GetTexSpace2DRadius SetTexSpace2DRot GetTexSpacePartID SetTexSpace2DRadius SetTexSpacePartID GetTexSpace2DRot GetTexSpaceOrientU GetTexSpaceOrientV DeleteTextureSpace AttachDefaultTextureSpace GetTexSpaceKind SetTexSpaceKind SetDefaultTextureSpace EditTextureSpace || || || || || ||

GetMarker

SetMarker SetMarkerChoice FMarker GetClassArrow SetClassArrow GetObjArrow SetObjArrow GetMarkerChoice Marker || || || || ||

SetWallControlOffset

Volume SurfaceArea GetWallControlOffset CalcVolume CalcSurfaceArea Area ClearCavities HArea DoubLines || || || ||

GetTexBitPaintNode

SetWSCellBorder SetTexBitPaintNode AddCavity SetWallWidth || || ||

CreateTextureBitmap
GetCWidth

TargetSprdSheet SelectSS ActSSheet GetSprdSortSumColumns EditTextureBitmap CloseSS SprdWidth GetTextureShininess SetTextureShininess GetTextureTransp SetTextureTransp GetTextureShader SetTextureShader GetTexBitmapOrigin SetTexBitmapOrigin SprdSize LoadCell CellHasStr GetSprdSortSum SetSprdSortSumColumns CellValue SetSprdSortSum GetCAlign GetCellNum GetCellStr CellString CellHasNum SprdFormat SprdBorder SprdAlign NewSprdSheet ||

DoMenuText