Vectorworks Scripting: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(17 intermediate revisions by 2 users not shown)
Line 34: Line 34:
* [[VS:Parametric Hide Details]]
* [[VS:Parametric Hide Details]]
* [[VS:Parametric State Notifications]]
* [[VS:Parametric State Notifications]]
* [[VS:Object_Events]]
* [[VS:Similar Objects Creation]]
* [[VS:Similar Objects Creation]]
* [[VS:Progress Dialog]]
* [[VS:Progress Dialog]]
* [[VS:Working_with_Materials]]
* [[SDK:Auto-dimension support]]
* [[VS:Equipment item attaching sample]]


== Installing Scripts ==
== Install Partner Products ==


When, for the first time, you create a plug-in, Vectorworks puts all of its content in user plug-in path and each time Vectorworks runs it recursiveley load all the Plug-Ins in that path (Also looking for the short-cuts)
Vectorworks 2021 introduced a feature called 'Install Partner Products' (as a menu command under the Help menu) that allows users to browse and install features from third-party developers.
When you designed and implemented your plug-in in either of the scripting languages, you may want to use it on different machines or VW instances. Vectorworks Plug-in manager allows users to install packages containing scripts and other content.
For basic installation it just simply copy provided plug-in (which should be as a zip file) into the user plug-in path.
Also if a installation scrpit is provided it will run that script as well.
Please follow below links for more explanations and examples.


*[[VS:Basic Installation]]
The Install Partner Products feature works with packages, provided by the developer, and uploaded on Vectorworks online storage. More information about how these packages are structured and how the system works, you can find in the [[Partner Product Install Package]] article.
*[[VS:Implementing Installation Script]]
 
*[[VS:A more Complicated Installation Script]]
As a developer, if you are interested in listing your products/features there, please contact us at [mailto:devsupport@vectorworks.net devsupport@vectorworks.net].
 
== Obsolete Installing Scripts ==
 
The old way of installing has been deprecated. Information on it can be found in the deprecated section of [[VS:Vectorworks 2023 Development|Vectorworks 2023]]


== Version Information ==
== Version Information ==


*[[VS:Vectorworks 2023 Development|Vectorworks 2023]]
*[[VS:Vectorworks 2022 Development|Vectorworks 2022]]
*[[VS:Vectorworks 2021 Development|Vectorworks 2021]]
*[[VS:Vectorworks 2020 Development|Vectorworks 2020]]
*[[VS:Vectorworks 2019 Development|Vectorworks 2019]]
*[[VS:Vectorworks 2018 Development|Vectorworks 2018]]
*[[VS:Vectorworks 2017 Development|Vectorworks 2017]]
*[[VS:Vectorworks 2016 Development|Vectorworks 2016]]
*[[VS:Vectorworks 2015 Development|Vectorworks 2015]]
*[[VS:Vectorworks 2015 Development|Vectorworks 2015]]
*[[VS:Vectorworks 2014 Development|Vectorworks 2014]]
*[[VS:Vectorworks 2014 Development|Vectorworks 2014]]
Line 59: Line 71:
*[[VS:Vectorworks 2009 Development|Vectorworks 2009]]
*[[VS:Vectorworks 2009 Development|Vectorworks 2009]]


{| border=1
== Obsolete Functions Table ==
! Vectorworks 2013 !! Vectorworks 2012 !! Vectorworks 2011 !! Vectorworks 2010 !! Vectorworks 2009 !! VectorWorks 2008 !! VectorWorks12.5 !! VectorWorks12.0 !! VectorWorks10.1 !! VectorWorks9.0 !! VectorWorks8.0
 
|-
Find the full version table for all obsolete functions here:
|GetClLS
 
SetClLS
[[VS:Obsolete Functions Table]]
PenPat
SetLS
FPenPat
GetLS ||  ||  ||  ||  ||  ||  ||  ||  ||  ||
|-
| || Perim
RightBound
TopBound
SetLinkHeightToLayerDeltaZ
XCenter
BotBound
YCenter
GetLayerDeltaZOffset
InsertProposedClassOrLayerItem
SetLayerDeltaZOffset
GetLinkHeightToLayerDeltaZ
AddLBImage
CriteriaVolume
CriteriaSurfaceArea
CriteriaArea
InsertEnhancedPullDownMenuItem
CreateIconPushButton
SetLBMultImageIndexes
SetWallHeights
ZCenter
LeftBound
Length
WallHeight
HWallHeight ||  ||  ||  ||  ||  ||  ||  ||  ||
|-
| ||  || GetType ||  ||  ||  ||  ||  ||  ||  ||
|-
| ||  ||  || SetTextureRef
GetTexMapReal
SetTexMapReal
GetTexMapInt
GetTextureRef
GetTexMapBool
SetTexMapBool
SetDefaultTexMap
SetTexMapInt ||  ||  ||  ||  ||  ||  ||
|-
| ||  ||  ||  || SetTexSpaceOrientU
GetTextureSpace
GetTexSpaceOrientW
GetTexSpaceStartCap
SetTexSpaceOrientV
SetTexSpaceOrientW
GetTexSpaceOrigin
SetTexSpaceOrigin
SetObjExpandTexture
GetObjExpandTexture
SetTexSpaceStartCap
GetTexSpaceEndCap
GetTexSpace2DOffset
SetTexSpace2DOffset
GetTexSpace2DScale
SetTexSpaceEndCap
SetTexSpace2DScale
GetTexSpace2DRadius
SetTexSpace2DRot
GetTexSpacePartID
SetTexSpace2DRadius
SetTexSpacePartID
GetTexSpace2DRot
GetTexSpaceOrientU
GetTexSpaceOrientV
DeleteTextureSpace
AttachDefaultTextureSpace
GetTexSpaceKind
SetTexSpaceKind
SetDefaultTextureSpace
EditTextureSpace ||  ||  ||  ||  ||  ||
|-
| ||  ||  ||  ||  || GetMarker
SetMarker
SetMarkerChoice
FMarker
GetClassArrow
SetClassArrow
GetObjArrow
SetObjArrow
GetMarkerChoice
Marker ||  ||  ||  ||  ||
|-
| ||  ||  ||  ||  ||  || SetWallControlOffset
Volume
SurfaceArea
GetWallControlOffset
CalcVolume
CalcSurfaceArea
Area
ClearCavities
HArea
DoubLines ||  ||  ||  ||
|-
| ||  ||  ||  ||  ||  ||  || GetTexBitPaintNode
SetWSCellBorder
SetTexBitPaintNode
AddCavity
SetWallWidth ||  ||  ||
|-
| ||  ||  ||  ||  ||  ||  ||  || CreateTextureBitmap ||  ||
|-
| ||  ||  ||  ||  ||  ||  ||  ||  || GetCWidth
TargetSprdSheet
SelectSS
ActSSheet
GetSprdSortSumColumns
EditTextureBitmap
CloseSS
SprdWidth
GetTextureShininess
SetTextureShininess
GetTextureTransp
SetTextureTransp
GetTextureShader
SetTextureShader
GetTexBitmapOrigin
SetTexBitmapOrigin
SprdSize
LoadCell
CellHasStr
GetSprdSortSum
SetSprdSortSumColumns
CellValue
SetSprdSortSum
GetCAlign
GetCellNum
GetCellStr
CellString
CellHasNum
SprdFormat
SprdBorder
SprdAlign
NewSprdSheet ||
|-
| ||  ||  ||  ||  ||  ||  ||  ||  ||  || DoMenuText
|}

Revision as of 14:36, 10 January 2023

.Vectorworks Scripting|Scripting ..Python|Python Scripting ..VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Vectorworks provides two options for scripting: Python (as of Vectorworks 2014) and VectorScript.

Python Scripting

Vectorworks 2014 adds [Python] language as an alternative to VectorScript for creating menu commands, objects, tools, or general purpose scripts.

You can go to the Python page for more information.

VectorScript

VectorScript is a Pascal-like language allowing scripting in Vectorworks.

VectorScript function reference is available here.

You can also use the main VectorScript category to help navigate.

Common Tasks

Install Partner Products

Vectorworks 2021 introduced a feature called 'Install Partner Products' (as a menu command under the Help menu) that allows users to browse and install features from third-party developers.

The Install Partner Products feature works with packages, provided by the developer, and uploaded on Vectorworks online storage. More information about how these packages are structured and how the system works, you can find in the Partner Product Install Package article.

As a developer, if you are interested in listing your products/features there, please contact us at devsupport@vectorworks.net.

Obsolete Installing Scripts

The old way of installing has been deprecated. Information on it can be found in the deprecated section of Vectorworks 2023

Version Information

Obsolete Functions Table

Find the full version table for all obsolete functions here:

VS:Obsolete Functions Table