Vectorworks Scripting: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
(12 intermediate revisions by 2 users not shown)
Line 35: Line 35:
* [[VS:Parametric State Notifications]]
* [[VS:Parametric State Notifications]]
* [[VS:Similar Objects Creation]]
* [[VS:Similar Objects Creation]]
* [[VS:Progress Dialog]]


== Installing Scripts ==
== Installing Scripts ==
Line 41: Line 42:
When you designed and implemented your plug-in in either of the scripting languages, you may want to use it on different machines or VW instances. Vectorworks Plug-in manager allows users to install packages containing scripts and other content.
When you designed and implemented your plug-in in either of the scripting languages, you may want to use it on different machines or VW instances. Vectorworks Plug-in manager allows users to install packages containing scripts and other content.
For basic installation it just simply copy provided plug-in (which should be as a zip file) into the user plug-in path.  
For basic installation it just simply copy provided plug-in (which should be as a zip file) into the user plug-in path.  
Also if a installation scrpit is provided it will run that script as well.  
Also if a installation script is provided it will run that script as well.  
Please follow below links for more explanations and examples.
Please follow below links for more explanations and examples.


Line 47: Line 48:
*[[VS:Implementing Installation Script]]
*[[VS:Implementing Installation Script]]
*[[VS:A more Complicated Installation Script]]
*[[VS:A more Complicated Installation Script]]
*[[VS:Installing Thirdparty into Vectorworks Workspace]]
== Version Information ==
*[[VS:Vectorworks 2020 Development|Vectorworks 2020]]
*[[VS:Vectorworks 2019 Development|Vectorworks 2019]]
*[[VS:Vectorworks 2018 Development|Vectorworks 2018]]
*[[VS:Vectorworks 2017 Development|Vectorworks 2017]]
*[[VS:Vectorworks 2016 Development|Vectorworks 2016]]
*[[VS:Vectorworks 2015 Development|Vectorworks 2015]]
*[[VS:Vectorworks 2014 Development|Vectorworks 2014]]
*[[VS:Vectorworks 2013 Development|Vectorworks 2013]]
*[[VS:Vectorworks 2012 Development|Vectorworks 2012]]
*[[VS:Vectorworks 2011 Development|Vectorworks 2011]]
*[[VS:Vectorworks 2010 Development|Vectorworks 2010]]
*[[VS:Vectorworks 2009 Development|Vectorworks 2009]]
== Obsolete Functions Table ==
Find the full version table for all obsolete functions here:
[[VS:Obsolete Functions Table]]

Revision as of 18:18, 29 October 2019

.Vectorworks Scripting|Scripting ..Python|Python Scripting ..VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Vectorworks provides two options for scripting: Python (as of Vectorworks 2014) and VectorScript.

Python Scripting

Vectorworks 2014 adds [Python] language as an alternative to VectorScript for creating menu commands, objects, tools, or general purpose scripts.

You can go to the Python page for more information.

VectorScript

VectorScript is a Pascal-like language allowing scripting in Vectorworks.

VectorScript function reference is available here.

You can also use the main VectorScript category to help navigate.

Common Tasks

Installing Scripts

When, for the first time, you create a plug-in, Vectorworks puts all of its content in user plug-in path and each time Vectorworks runs it recursiveley load all the Plug-Ins in that path (Also looking for the short-cuts). When you designed and implemented your plug-in in either of the scripting languages, you may want to use it on different machines or VW instances. Vectorworks Plug-in manager allows users to install packages containing scripts and other content. For basic installation it just simply copy provided plug-in (which should be as a zip file) into the user plug-in path. Also if a installation script is provided it will run that script as well. Please follow below links for more explanations and examples.

Version Information

Obsolete Functions Table

Find the full version table for all obsolete functions here:

VS:Obsolete Functions Table