VS:wsEditAddTool: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 7: Line 7:
<desc>
<desc>
Add a menu under Third-party palette and companyName tool set.
Add a menu under Third-party palette and companyName tool set.
As of Vectorworks 2018 SP2, this function takes an integer parameter toolType to specify the type of tool being added. Vectorworks 2018 prior to SP2 will only take a single parameter as input.




Line 34: Line 36:
</funcDef>
</funcDef>
<funcDef lang="py">
<funcDef lang="py">
def vs.wsEditAddTool(toolName):
def vs.wsEditAddTool(toolName, toolType):
     return None
     return None
</funcDef>
</funcDef>

Revision as of 16:07, 8 November 2017

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Add a menu under Third-party palette and companyName tool set.

As of Vectorworks 2018 SP2, this function takes an integer parameter toolType to specify the type of tool being added. Vectorworks 2018 prior to SP2 will only take a single parameter as input.


Tool Type Constant
Regular External Tool 1
VectorScript Tool (.vst) 2
VectorScript Object (.vso) 3
Custom Parametric 4

Note: The Custom Parametric tool type includes SDK objects of type Point, Line, Box, 2D Path, and 3D Path.

PROCEDURE wsEditAddTool(
toolName :STRING;
toolType :INTEGER);
def vs.wsEditAddTool(toolName, toolType):
    return None

Parameters

toolName STRING
toolType INTEGER

Version

Availability: from Vectorworks 2018