VS:ws2SetToolInfo

From Vectorworks Developer
Revision as of 15:48, 16 September 2020 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Workspace advanced APIs. Set the tool information at the specified index of the parent tool at the specified path. See 'ws2GetToolsCnt'.

PROCEDURE ws2SetToolInfo(
toolPath :DYNARRAY[] of CHAR;
displayName :DYNARRAY[] of CHAR;
shortcutKey :CHAR;
shortcutKeyModifier :INTEGER;
resourceID :INTEGER);
def vs.ws2SetToolInfo(toolPath, displayName, shortcutKey, shortcutKeyModifier, resourceID):
    return None

Parameters

toolPath DYNARRAY[] of CHAR
displayName DYNARRAY[] of CHAR
shortcutKey CHAR
shortcutKeyModifier INTEGER
resourceID INTEGER

Version

Availability: from Vectorworks 2021