VS:ws2SetMenuInfo

From Vectorworks Developer
Revision as of 15:48, 16 September 2020 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Workspace advanced APIs. Set the localized (if any) name, and shortkey combinations (if any) of the specified index inside the provided menu path. See 'ws2GetMenusCnt'.

PROCEDURE ws2SetMenuInfo(
menuPath :DYNARRAY[] of CHAR;
displayName :DYNARRAY[] of CHAR;
hasShortcutKey :BOOLEAN;
shortcutKey :CHAR;
shortcutKeyModifier :INTEGER);
def vs.ws2SetMenuInfo(menuPath, displayName, hasShortcutKey, shortcutKey, shortcutKeyModifier):
    return None

Parameters

menuPath DYNARRAY[] of CHAR
displayName DYNARRAY[] of CHAR
hasShortcutKey BOOLEAN
shortcutKey CHAR
shortcutKeyModifier INTEGER

Version

Availability: from Vectorworks 2021