VS:ws2GetToolInfo: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision)
 
(No difference)

Latest revision as of 15:48, 16 September 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Workspace advanced APIs. Return the tool information at the specified index of the parent tool at the specified path. See 'ws2GetToolsCnt'.

FUNCTION ws2GetToolInfo(
toolPath :DYNARRAY[] of CHAR;
VAR outDisplayName :DYNARRAY[] of CHAR;
VAR outShortcutKey :CHAR;
VAR outShortcutKeyModifier :INTEGER;
VAR outResourceID :INTEGER) : BOOLEAN;
def vs.ws2GetToolInfo(toolPath):
    return (BOOLEAN, outDisplayName, outShortcutKey, outShortcutKeyModifier, outResourceID)

Parameters

toolPath DYNARRAY[] of CHAR
outDisplayName DYNARRAY[] of CHAR
outShortcutKey CHAR
outShortcutKeyModifier INTEGER
outResourceID INTEGER

Version

Availability: from Vectorworks 2021