VS:ws2GetMenuInfo

From Vectorworks Developer
Revision as of 15:48, 16 September 2020 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Workspace advanced APIs. Return the localized (if any) name, and shortkey combinations (if any) of the specified index inside the provided menu path. See 'ws2GetMenusCnt'.

FUNCTION ws2GetMenuInfo(
menuPath :DYNARRAY[] of CHAR;
VAR outHasShortcutKey :BOOLEAN;
VAR outShortcutKey :CHAR;
VAR outShortcutKeyModifier :INTEGER) : DYNARRAY[] of CHAR;
def vs.ws2GetMenuInfo(menuPath):
    return (DYNARRAY[] of CHAR, outHasShortcutKey, outShortcutKey, outShortcutKeyModifier)

Parameters

menuPath DYNARRAY[] of CHAR
outHasShortcutKey BOOLEAN
outShortcutKey CHAR
outShortcutKeyModifier INTEGER

Version

Availability: from Vectorworks 2021