VS:ws2GetMenuInfo: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision)
 
(No difference)

Latest revision as of 15:48, 16 September 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Workspace advanced APIs. Return the localized (if any) name, and shortkey combinations (if any) of the specified index inside the provided menu path. See 'ws2GetMenusCnt'.

FUNCTION ws2GetMenuInfo(
menuPath :DYNARRAY[] of CHAR;
VAR outHasShortcutKey :BOOLEAN;
VAR outShortcutKey :CHAR;
VAR outShortcutKeyModifier :INTEGER) : DYNARRAY[] of CHAR;
def vs.ws2GetMenuInfo(menuPath):
    return (DYNARRAY[] of CHAR, outHasShortcutKey, outShortcutKey, outShortcutKeyModifier)

Parameters

menuPath DYNARRAY[] of CHAR
outHasShortcutKey BOOLEAN
outShortcutKey CHAR
outShortcutKeyModifier INTEGER

Version

Availability: from Vectorworks 2021