VS:ws2GetMenuAt: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
No edit summary
 
(One intermediate revision by one other user not shown)
Line 36: Line 36:


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark></remark>
<remark>Pat Stanford 4-20-21
The top level menu items do not seem to use the text version of the name as the "Universal Name"
but rather a UUID looking string. The positions are numbered starting at 0 (zero)
 
Use ws2GetMenuAt(ˈˈ, INDEX) where the first item is an empty string and INDEX is an integer specifying the menu item you are interested in to
get the Universal Name of the View menu.
 
</remark>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------

Latest revision as of 04:03, 21 April 2022

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Workspace advanced APIs. Return the universal name of the specified index inside the provided menu path See 'ws2GetMenusCnt'.

FUNCTION ws2GetMenuAt(
menuPath :DYNARRAY[] of CHAR;
index :INTEGER) : DYNARRAY[] of CHAR;
def vs.ws2GetMenuAt(menuPath, index):
    return DYNARRAY[] of CHAR

Parameters

menuPath DYNARRAY[] of CHAR
index INTEGER

Remarks

Pat Stanford 4-20-21

The top level menu items do not seem to use the text version of the name as the "Universal Name" but rather a UUID looking string. The positions are numbered starting at 0 (zero)

Use ws2GetMenuAt(ˈˈ, INDEX) where the first item is an empty string and INDEX is an integer specifying the menu item you are interested in to get the Universal Name of the View menu.

Version

Availability: from Vectorworks 2021