VS:ws2FindMenuIndex

From Vectorworks Developer
Revision as of 15:48, 16 September 2020 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Workspace advanced APIs. Return the indx of the specified universal name inside the provided menu path. Return -1 if not found. See 'ws2GetMenusCnt'.

FUNCTION ws2FindMenuIndex(
menuPath :DYNARRAY[] of CHAR;
findMenuUnivName :DYNARRAY[] of CHAR) : INTEGER;
def vs.ws2FindMenuIndex(menuPath, findMenuUnivName):
    return INTEGER

Parameters

menuPath DYNARRAY[] of CHAR
findMenuUnivName DYNARRAY[] of CHAR

Version

Availability: from Vectorworks 2021