VS:ws2AddMenuItem

From Vectorworks Developer
Revision as of 15:48, 16 September 2020 by Unknown user
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Workspace advanced APIs. Adds a new menu item by universal name before the specified index (-1 for the end) inside the provided menu path. See 'ws2GetMenusCnt'.

FUNCTION ws2AddMenuItem(
menuPath :DYNARRAY[] of CHAR;
newMenuUnivName :DYNARRAY[] of CHAR;
beforeIndex :INTEGER) : BOOLEAN;
def vs.ws2AddMenuItem(menuPath, newMenuUnivName, beforeIndex):
    return BOOLEAN

Parameters

menuPath DYNARRAY[] of CHAR
newMenuUnivName DYNARRAY[] of CHAR
beforeIndex INTEGER

Version

Availability: from Vectorworks 2021