VS:ws2AddMenuGroup

From Vectorworks Developer
Revision as of 15:48, 16 September 2020 by Unknown user
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Workspace advanced APIs. Adds a new menu group (container) by universal name before the specified index (-1 for the end) inside the provided menu path. See 'ws2GetMenusCnt'.

FUNCTION ws2AddMenuGroup(
menuPath :DYNARRAY[] of CHAR;
newUnivName :DYNARRAY[] of CHAR;
newDisplayName :DYNARRAY[] of CHAR;
beforeIndex :INTEGER) : BOOLEAN;
def vs.ws2AddMenuGroup(menuPath, newUnivName, newDisplayName, beforeIndex):
    return BOOLEAN

Parameters

menuPath DYNARRAY[] of CHAR
newUnivName DYNARRAY[] of CHAR
newDisplayName DYNARRAY[] of CHAR
beforeIndex INTEGER

Version

Availability: from Vectorworks 2021