VS:ws2AddMenuGroup: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
m (1 revision)
 
(No difference)

Latest revision as of 15:48, 16 September 2020

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Workspace advanced APIs. Adds a new menu group (container) by universal name before the specified index (-1 for the end) inside the provided menu path. See 'ws2GetMenusCnt'.

FUNCTION ws2AddMenuGroup(
menuPath :DYNARRAY[] of CHAR;
newUnivName :DYNARRAY[] of CHAR;
newDisplayName :DYNARRAY[] of CHAR;
beforeIndex :INTEGER) : BOOLEAN;
def vs.ws2AddMenuGroup(menuPath, newUnivName, newDisplayName, beforeIndex):
    return BOOLEAN

Parameters

menuPath DYNARRAY[] of CHAR
newUnivName DYNARRAY[] of CHAR
newDisplayName DYNARRAY[] of CHAR
beforeIndex INTEGER

Version

Availability: from Vectorworks 2021