VS:vstSetDataString

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets tool data.

PROCEDURE vstSetDataString(
inDataID :LONGINT;
inDataVal :DYNARRAY [] OF CHAR;
VAR result :BOOLEAN);
def vs.vstSetDataString(inDataID, inDataVal):
    return result

Parameters

inDataID LONGINT
inDataVal DYNARRAY [] OF CHAR
result BOOLEAN Output parameter.

Remarks

Use a STRING rather than a DYNARRAY [] OF CHAR. Currently DYNARRAY will cause VW to crash. (VW 2010)

Version

Availability: from All Versions

This is drop-in function.