VS:vstGetPt2D

From Vectorworks Developer
Revision as of 14:50, 12 August 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the point clicked by the user. inPtIndex is 0-based. If you pass in an index that is greater than the number of points clicked by the user, result will be false.

PROCEDURE vstGetPt2D(
inPtIndex :LONGINT;
VAR outX :REAL;
VAR outY :REAL;
result :BOOLEAN);
def vs.vstGetPt2D(inPtIndex, result):
    return (outX, outY)

Parameters

inPtIndex LONGINT
outX REAL Output parameter.
outY REAL Output parameter.
result BOOLEAN

Remarks

Note that VS:vstNumPts will return a 1-based index. vstGetPt2D is zero-based. So if you're collecting points in the kToolEventPointAdded event you'll likely have to do something like

vstNumPoints(pointNum);
vstGetPt2D(pointNum-1, ...);

Version

Availability: from All Versions

This is drop-in function.