VS:vstGetDataLong

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

VSTs store persistent data between calls using vstSetDataLong and vstGetDataLong.

PROCEDURE vstGetDataLong(
inDataID :LONGINT;
VAR outData :LONGINT;
VAR result :BOOLEAN);
def vs.vstGetDataLong(inDataID):
    return (outData, result)

Parameters

inDataID LONGINT
outData LONGINT Output parameter.
result BOOLEAN Output parameter.

Version

Availability: from All Versions

This is drop-in function.