VS:vstGetCurrPt3D: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
No edit summary
 
(One intermediate revision by one other user not shown)
Line 52: Line 52:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
 
In Python, the result boolean input variable doesn't seem to do anything.
</remark>
</remark>



Latest revision as of 22:28, 22 February 2023

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the current location of the mouse.

PROCEDURE vstGetCurrPt3D(
VAR outX :REAL;
VAR outY :REAL;
VAR outZ :REAL;
result :BOOLEAN);
def vs.vstGetCurrPt3D(result):
    return (outX, outY, outZ)

Parameters

outX REAL Output parameter.
outY REAL Output parameter.
outZ REAL Output parameter.
result BOOLEAN

Remarks

In Python, the result boolean input variable doesn't seem to do anything.

Version

Availability: from All Versions

This is drop-in function.