VS:vstAddRadioMode: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
mNo edit summary
 
Line 12: Line 12:


Rsrc IDs must be greater than 10000.
Rsrc IDs must be greater than 10000.
(Seems like this has been replaced by [[VS:AddRadioMode]])
</desc>
</desc>



Latest revision as of 12:22, 13 October 2021

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Adds a group of radio buttons to the mode bar.

  • inNumButtons is the number of buttons <= 6
  • id# is the 'ICN#' resource ID of the button's icon.
  • initialSetting is the number, left to right, of the button originally highlighted.

Rsrc IDs must be greater than 10000.

(Seems like this has been replaced by VS:AddRadioMode)

PROCEDURE vstAddRadioMode(
inInitialSetting :INTEGER;
inNumButtons :INTEGER;
inRsrcID_1 :INTEGER;
inRsrcID_2 :INTEGER;
inRsrcID_3 :INTEGER;
inRsrcID_4 :INTEGER;
inRsrcID_5 :INTEGER;
inRsrcID_6 :INTEGER);
def vs.vstAddRadioMode(inInitialSetting, inNumButtons, inImageSpecification1, inImageSpecification2, inImageSpecification3, inImageSpecification4, inImageSpecification5, inImageSpecification6):
    return None

Parameters

inInitialSetting INTEGER
inNumButtons INTEGER
inRsrcID_1 INTEGER
inRsrcID_2 INTEGER
inRsrcID_3 INTEGER
inRsrcID_4 INTEGER
inRsrcID_5 INTEGER
inRsrcID_6 INTEGER

Version

Availability: from All Versions

This is drop-in function.