VS:vsoWidgetSetEnable

From Vectorworks Developer
Revision as of 14:39, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets whether or not the specified parameter is enabled on the Object Info Palette.

Note: This function should be called during the parametric OIP generation event: 41: {kObjOnWidgetPrep}. See VS:Parametric Custom Shape Pane Popup.

PROCEDURE vsoWidgetSetEnable(
widgetID  : LONGINT;
enabled  : BOOLEAN);
def vs.vsoWidgetSetEnable(widgetID, enabled):
    return None

Parameters

widgetID LONGINT
enabled BOOLEAN

Version

Availability: from All Versions

This is drop-in function.