VS:vsoWidgetPopupSet

From Vectorworks Developer
Revision as of 10:04, 26 March 2018 by MaKro (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the value of a choice in a popup widget. (For example, the item text of a dropdown list in a PIO)

PROCEDURE vsoWidgetPopupSet(
widgetID  : LONGINT;
index  : LONGINT;
id  : STRING;
text  : STRING);
def vs.vsoWidgetPopupSet(widgetID, index, id, text):
    return None

Parameters

widgetID LONGINT The ID as shown in the 'Edit Plugin Definition' Dialog under Parameters->Column #
index LONGINT The 0-based index of the item
id STRING The id of the item. (Can be the same as outText)
text STRING The text of the item

Version

Availability: from All Versions

This is drop-in function.