VS:vsoWidgetPopupSet: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
No edit summary
 
(2 intermediate revisions by 2 users not shown)
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
?
Sets the value of a choice in a popup widget. (For example, the item text of a dropdown list in a PIO)
</desc>
</desc>


Line 25: Line 25:
widgetID
widgetID
LONGINT
LONGINT
 
The ID as shown in the 'Edit Plugin Definition' Dialog under Parameters->Column #
</line>
</line>
<line>
<line>
index
index
LONGINT
LONGINT
 
The 0-based index of the item
</line>
</line>
<line>
<line>
id
id
STRING
STRING
 
The id of the item. (Can be the same as outText)
</line>
</line>
<line>
<line>
text
text
STRING
STRING
 
The text of the item
</line>
</line>
</lineList>
</lineList>

Latest revision as of 10:04, 26 March 2018

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Sets the value of a choice in a popup widget. (For example, the item text of a dropdown list in a PIO)

PROCEDURE vsoWidgetPopupSet(
widgetID  : LONGINT;
index  : LONGINT;
id  : STRING;
text  : STRING);
def vs.vsoWidgetPopupSet(widgetID, index, id, text):
    return None

Parameters

widgetID LONGINT The ID as shown in the 'Edit Plugin Definition' Dialog under Parameters->Column #
index LONGINT The 0-based index of the item
id STRING The id of the item. (Can be the same as outText)
text STRING The text of the item

Version

Availability: from All Versions

This is drop-in function.