VS:vsoWidgetPopupGet

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Get the text of an item from a popup widget. (For example, a dropdown list item of a PIO)

PROCEDURE vsoWidgetPopupGet(
widgetID  : LONGINT;
index  : LONGINT;
VAR outId  : STRING;
VAR outText  : STRING);
def vs.vsoWidgetPopupGet(widgetID, index):
    return (outId, outText)

Parameters

widgetID LONGINT The ID as shown in the 'Edit Plugin Definition' Dialog under Parameters->Column #
index LONGINT The 0-based index of the item
outId STRING Output parameter. The id of the item (if not overwritten, same as outText)
outText STRING Output parameter. The text of the item.

Return Value

Id and text of the list item.

Version

Availability: from All Versions

This is drop-in function.