VS:vsoWidgetPopupGet: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
?
Get the text of a item from a popup widget. (For example, a dropdown list item of a PIO)
</desc>
</desc>


Line 25: Line 25:
widgetID
widgetID
LONGINT
LONGINT
 
The ID as shown in the 'Edit Plugin Definition' Dialog under Parameters->Column #
</line>
</line>
<line>
<line>
index
index
LONGINT
LONGINT
 
The 0-based index of the item
</line>
</line>
<line>
<line>
outId
outId
STRING
STRING
Output parameter.  
Output parameter. The id of the item (if not overwritten, same as outText)
</line>
</line>
<line>
<line>
outText
outText
STRING
STRING
Output parameter.  
Output parameter. The text of the item.
</line>
</line>
</lineList>
</lineList>
Line 48: Line 48:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<return>
<return>
Id and text of the list item.
</return>
</return>



Revision as of 09:56, 26 March 2018

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Get the text of a item from a popup widget. (For example, a dropdown list item of a PIO)

PROCEDURE vsoWidgetPopupGet(
widgetID  : LONGINT;
index  : LONGINT;
VAR outId  : STRING;
VAR outText  : STRING);
def vs.vsoWidgetPopupGet(widgetID, index):
    return (outId, outText)

Parameters

widgetID LONGINT The ID as shown in the 'Edit Plugin Definition' Dialog under Parameters->Column #
index LONGINT The 0-based index of the item
outId STRING Output parameter. The id of the item (if not overwritten, same as outText)
outText STRING Output parameter. The text of the item.

Return Value

Id and text of the list item.

Version

Availability: from All Versions

This is drop-in function.