VS:vsoWidgetPopupGet: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
Get the text of a item from a popup widget. (For example, a dropdown list item of a PIO)
Get the text of an item from a popup widget. (For example, a dropdown list item of a PIO)
</desc>
</desc>



Latest revision as of 09:59, 26 March 2018

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Get the text of an item from a popup widget. (For example, a dropdown list item of a PIO)

PROCEDURE vsoWidgetPopupGet(
widgetID  : LONGINT;
index  : LONGINT;
VAR outId  : STRING;
VAR outText  : STRING);
def vs.vsoWidgetPopupGet(widgetID, index):
    return (outId, outText)

Parameters

widgetID LONGINT The ID as shown in the 'Edit Plugin Definition' Dialog under Parameters->Column #
index LONGINT The 0-based index of the item
outId STRING Output parameter. The id of the item (if not overwritten, same as outText)
outText STRING Output parameter. The text of the item.

Return Value

Id and text of the list item.

Version

Availability: from All Versions

This is drop-in function.