VS:vsoWidgetPopupAdd

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Adds an item to the widget choices.

PROCEDURE vsoWidgetPopupAdd(
widgetID  : LONGINT;
id  : STRING;
text  : STRING);
def vs.vsoWidgetPopupAdd(widgetID, id, text):
    return None

Parameters

widgetID LONGINT
id STRING The value that is written into the database field when the related text is selected.
text STRING This value is displayed in the PopUp.

Remarks

The PopUp is easy to handle if you use the same value for id and text. So that the display text is equal to the database value.

Version

Availability: from All Versions

This is drop-in function.