VS:vsoWidgetPopupAdd

From Vectorworks Developer
Revision as of 13:22, 19 April 2017 by Patrick (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Adds an item to the widget choices.

PROCEDURE vsoWidgetPopupAdd(
widgetID  : LONGINT;
id  : STRING;
text  : STRING);
def vs.vsoWidgetPopupAdd(widgetID, id, text):
    return None

Parameters

widgetID LONGINT
id STRING The value that is written into the database field when the related text is selected.
text STRING This value is displayed in the PopUp.

Remarks

The PopUp is easy to handle if you use the same value for id and text. So that the display text is equal to the database value.

Version

Availability: from All Versions

This is drop-in function.