VS:vsoWidgetPopupAdd: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
 
Line 5: Line 5:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
<desc>
?
Adds an item to the widget choices.
</desc>
</desc>


Line 29: Line 29:
<line>
<line>
id
id
STRING
STRING The value that is written into the database field when the related text is selected.


</line>
</line>
<line>
<line>
text
text
STRING
STRING This value is displayed in the PopUp.


</line>
</line>
Line 47: Line 47:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
 
The PopUp is easy to handle if you use the same value for id and text. So that the display text is equal to the database value.
</remark>
</remark>



Latest revision as of 13:22, 19 April 2017

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Adds an item to the widget choices.

PROCEDURE vsoWidgetPopupAdd(
widgetID  : LONGINT;
id  : STRING;
text  : STRING);
def vs.vsoWidgetPopupAdd(widgetID, id, text):
    return None

Parameters

widgetID LONGINT
id STRING The value that is written into the database field when the related text is selected.
text STRING This value is displayed in the PopUp.

Remarks

The PopUp is easy to handle if you use the same value for id and text. So that the display text is equal to the database value.

Version

Availability: from All Versions

This is drop-in function.