VS:vsoSetQTOValue

From Vectorworks Developer
Revision as of 18:24, 15 September 2021 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Set a requested QTO value during event 84 (kParametricGetQTOValue). Check the requested QTO value by using vsoGetQTOFunction. 'valueType' [0:real; 1:integer; 2:string] determines which parameter is considered for the value, the others can be empty (zero).

PROCEDURE vsoSetQTOValue(
valueType :INTEGER;
int :INTEGER;
real :REAL;
string :DYNARRAY[] of CHAR);
def vs.vsoSetQTOValue(valueType, int, real, string):
    return None

Parameters

valueType INTEGER
int INTEGER
real REAL
string DYNARRAY[] of CHAR

Version

Availability: from Vectorworks 2022