VS:vsoPrmName2WidgetID: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
Line 1: Line 1:
{{LocationMain|category=LocationVS|specific=}}
{{LocationMain|category=LocationVS|specific=}}
__TOC__
__TOC__
Line 5: Line 6:
<desc>
<desc>
Retrieves the widget id of a field from the plugin-definition by name.
Retrieves the widget id of a field from the plugin-definition by name.
The opposite of [[VS:vsoWidgetGetRecParam|vsoWidgetGetRecParam]]
</desc>
</desc>
<def>
<def>

Latest revision as of 07:05, 2 September 2018

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Retrieves the widget id of a field from the plugin-definition by name.

The opposite of vsoWidgetGetRecParam

FUNCTION vsoPrmName2WidgetID(
recName :STRING;
paramName :STRING;
VAR outWidgetID :LONGINT) : BOOLEAN;
def vs.vsoPrmName2WidgetID(recName, paramName):
    return (BOOLEAN, outWidgetID)

Parameters

recName STRING
paramName STRING
outWidgetID LONGINT

Remarks

For this function to work, you need to use an empty string for the record name.

Version

Availability: from Vectorworks 2011