VS:vsoPrmName2WidgetID: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 3: Line 3:
<vwDoc>
<vwDoc>
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<desc>
Retrieves the widget id of a field from the plugin-definition by name.
</desc>
<def>
<def>
Retrieves the widget id of a field from the plugin-definition by name.
<funcDef lang="vs">
<funcDef lang="vs">
FUNCTION vsoPrmName2WidgetID(recName:STRING; paramName:STRING; VAR outWidgetID:LONGINT) : BOOLEAN;
FUNCTION vsoPrmName2WidgetID(recName:STRING; paramName:STRING; VAR outWidgetID:LONGINT) : BOOLEAN;

Revision as of 07:02, 2 September 2018

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Retrieves the widget id of a field from the plugin-definition by name.

FUNCTION vsoPrmName2WidgetID(
recName :STRING;
paramName :STRING;
VAR outWidgetID :LONGINT) : BOOLEAN;
def vs.vsoPrmName2WidgetID(recName, paramName):
    return (BOOLEAN, outWidgetID)

Parameters

recName STRING
paramName STRING
outWidgetID LONGINT

Remarks

For this function to work, you need to use an empty string for the record name.

Version

Availability: from Vectorworks 2011