VS:vsoGetEventInfo

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the ID of the event in an event-enabled object. If the event was a button press, outEventData will indicate which button it was.

PROCEDURE vsoGetEventInfo(
VAR outObjEvent :LONGINT;
VAR outEventData :LONGINT);
def vs.vsoGetEventInfo():
    return (outObjEvent, outEventData)

Parameters

outObjEvent LONGINT Output parameter.
outEventData LONGINT Output parameter.

Version

Availability: from All Versions

This is drop-in function.