VS:vsoGetEventInfo

From Vectorworks Developer
Revision as of 14:39, 12 August 2013 by Root (talk | contribs) (1 revision)
Jump to navigation Jump to search

.VectorScript|VectorScript ..VS:Function Reference|Function Reference ..VS:Function_Reference_Appendix|Appendix

Description

Returns the ID of the event in an event-enabled object. If the event was a button press, outEventData will indicate which button it was.

See the <a href=http://www.vectorlab.info/index.php?title=Events>VectorLab article</a> on object events.

PROCEDURE vsoGetEventInfo(
VAR outObjEvent :LONGINT;
VAR outEventData :LONGINT);
def vs.vsoGetEventInfo():
    return (outObjEvent, outEventData)

Parameters

outObjEvent LONGINT Output parameter.
outEventData LONGINT Output parameter.

Version

Availability: from All Versions

This is drop-in function.